summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-03-29 11:33:08 +0000
committerJohannes Huber <johu@gentoo.org>2015-03-29 11:33:08 +0000
commitc86d5fb3bc1c649e6e615db14c4b78a0e2f86e58 (patch)
treee7b67b79d79e5da5aa0c581ed0a36547f0896d4d /kde-base/kcheckpass
parentVersion bump, which fixes security bugs #538152 and #540626. Bump EAPI. Renam... (diff)
downloadgentoo-2-c86d5fb3bc1c649e6e615db14c4b78a0e2f86e58.tar.gz
gentoo-2-c86d5fb3bc1c649e6e615db14c4b78a0e2f86e58.tar.bz2
gentoo-2-c86d5fb3bc1c649e6e615db14c4b78a0e2f86e58.zip
Version bump KDE Workspace 4.11.17
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.11.17.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index 93a9abff84c8..437ced291530 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.335 2015/02/19 07:43:17 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.336 2015/03/29 11:33:07 johu Exp $
+
+*kcheckpass-4.11.17 (29 Mar 2015)
+
+ 29 Mar 2015; Johannes Huber <johu@gentoo.org> +kcheckpass-4.11.17.ebuild:
+ Version bump KDE Workspace 4.11.17
19 Feb 2015; Michael Palimaka <kensington@gentoo.org>
-kcheckpass-4.11.9.ebuild:
diff --git a/kde-base/kcheckpass/kcheckpass-4.11.17.ebuild b/kde-base/kcheckpass/kcheckpass-4.11.17.ebuild
new file mode 100644
index 000000000000..90df14fcf3a1
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.11.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.11.17.ebuild,v 1.1 2015/03/29 11:33:07 johu Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}