summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
committerDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
commit2c22cfa8ffcfc73043bf37aeee39170605f0eb4d (patch)
treed056634258bce285b9c3837f09ef42145572f845 /kde-base/kcontrol
parentAdd the missing HOMEPAGE variable so repoman doesn't complain. (diff)
downloadgentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.gz
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.tar.bz2
gentoo-2-2c22cfa8ffcfc73043bf37aeee39170605f0eb4d.zip
KDE 3.4.1 ebuilds; package.masked as they aren't released yet
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'kde-base/kcontrol')
-rw-r--r--kde-base/kcontrol/ChangeLog8
-rw-r--r--kde-base/kcontrol/Manifest4
-rw-r--r--kde-base/kcontrol/files/digest-kcontrol-3.4.12
-rw-r--r--kde-base/kcontrol/kcontrol-3.4.1.ebuild40
4 files changed, 52 insertions, 2 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index 322c4cd008c6..292991857d35 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.11 2005/04/27 17:50:48 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.12 2005/05/25 21:23:02 danarmak Exp $
+
+*kcontrol-3.4.1 (25 May 2005)
+
+ 25 May 2005; Dan Armak <danarmak@gentoo.org> +kcontrol-3.4.1.ebuild:
+ Ebuilds for KDE 3.4.1. These are package.masked until 3.4.1 is actually
+ released. You can't get the tarballs yet.
27 Apr 2005; Markus Rothe <corsair@gentoo.org> kcontrol-3.4.0.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/kde-base/kcontrol/Manifest b/kde-base/kcontrol/Manifest
index 995c0266aa2a..8cb0b27d7f8d 100644
--- a/kde-base/kcontrol/Manifest
+++ b/kde-base/kcontrol/Manifest
@@ -1,5 +1,7 @@
+MD5 8a41e21a90ae099edd660770051b2960 kcontrol-3.4.1.ebuild 1260
MD5 493c61c96b6efcdf1c2c0b0eea4cf4a0 ChangeLog 2024
MD5 e2034d1d07b3a852d5e5ed7978a144b5 kcontrol-3.4.0.ebuild 1279
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
-MD5 64e656c39553f20b12d38eca1f8120d6 files/configure.in.in-kdm-settings.diff 686
MD5 54e17e8f38d377972c220f10357c9b2f files/digest-kcontrol-3.4.0 68
+MD5 2ed3f0976007ee8a8406f3f6422d66bf files/digest-kcontrol-3.4.1 136
+MD5 64e656c39553f20b12d38eca1f8120d6 files/configure.in.in-kdm-settings.diff 686
diff --git a/kde-base/kcontrol/files/digest-kcontrol-3.4.1 b/kde-base/kcontrol/files/digest-kcontrol-3.4.1
new file mode 100644
index 000000000000..7a8ed33cbdb4
--- /dev/null
+++ b/kde-base/kcontrol/files/digest-kcontrol-3.4.1
@@ -0,0 +1,2 @@
+MD5 c88659e558ca98dc45377bf8ddfc26c9 kdebase-3.4.0.tar.bz2 22670772
+MD5 8fbe0b943721b79f2549064b580acdde kdebase-3.4.1.tar.bz2 22433034
diff --git a/kde-base/kcontrol/kcontrol-3.4.1.ebuild b/kde-base/kcontrol/kcontrol-3.4.1.ebuild
new file mode 100644
index 000000000000..8089b6db232d
--- /dev/null
+++ b/kde-base/kcontrol/kcontrol-3.4.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.4.1.ebuild,v 1.1 2005/05/25 21:23:02 danarmak Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS="~x86 ~amd64"
+IUSE="ssl arts ieee1394 logitech-mouse opengl"
+PATCHES="$FILESDIR/configure.in.in-kdm-settings.diff"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ arts? ( $(deprange $PV $MAXKDEVER kde-base/arts) )
+ opengl? ( virtual/opengl )
+ ieee1394? ( sys-libs/libraw1394 )
+ logitech-mouse? ( >=dev-libs/libusb-0.1.10a )"
+
+RDEPEND="${DEPEND}
+$(deprange $PV $MAXKDEVER kde-base/kcminit)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)"
+
+KMEXTRACTONLY="kicker/core/kicker.h
+ kwin/kwinbindings.cpp
+ kicker/core/kickerbindings.cpp
+ kicker/taskbar/taskbarbindings.cpp
+ kdesktop/kdesktopbindings.cpp
+ klipper/klipperbindings.cpp
+ kxkb/kxkbbindings.cpp
+ libkonq/
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+
+KMCOMPILEONLY="kicker/share" # for kickerSettings.h
+
+src_compile() {
+ myconf="$myconf `use_with ssl` `use_with arts` `use_with opengl gl`"
+ kde-meta_src_compile
+}