summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-05-13 19:42:32 +0000
committerDan Armak <danarmak@gentoo.org>2002-05-13 19:42:32 +0000
commit477faa83b384e0e2c2689e9f589bd218374e3052 (patch)
treeccf98f9884ae8b84a4989840e47e7374aebcde93 /kde-base/kdeaddons
parentmasking kde-3.0.1 (diff)
downloadgentoo-2-477faa83b384e0e2c2689e9f589bd218374e3052.tar.gz
gentoo-2-477faa83b384e0e2c2689e9f589bd218374e3052.tar.bz2
gentoo-2-477faa83b384e0e2c2689e9f589bd218374e3052.zip
kde 3.0.1 (not available yet, in testing by packagers - me and verwilst)
Diffstat (limited to 'kde-base/kdeaddons')
-rw-r--r--kde-base/kdeaddons/files/digest-kdeaddons-3.0.11
-rw-r--r--kde-base/kdeaddons/kdeaddons-3.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kdeaddons/files/digest-kdeaddons-3.0.1 b/kde-base/kdeaddons/files/digest-kdeaddons-3.0.1
new file mode 100644
index 000000000000..75f57ca8069f
--- /dev/null
+++ b/kde-base/kdeaddons/files/digest-kdeaddons-3.0.1
@@ -0,0 +1 @@
+MD5 341be30069550f32bd3894bb0da51ec4 kdeaddons-3.0.1.tar.bz2 920334
diff --git a/kde-base/kdeaddons/kdeaddons-3.0.1.ebuild b/kde-base/kdeaddons/kdeaddons-3.0.1.ebuild
new file mode 100644
index 000000000000..5ef04c868624
--- /dev/null
+++ b/kde-base/kdeaddons/kdeaddons-3.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons/kdeaddons-3.0.1.ebuild,v 1.1 2002/05/13 19:42:32 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist || die
+
+DESCRIPTION="${DESCRIPTION}Addons"
+
+newdepend ">=kde-base/kdebase-${PV}
+ ~kde-base/kdenetwork-${PV}
+ ~kde-base/kdemultimedia-${PV}
+ >=media-libs/libsdl-1.2
+ sdl? ( media-libs/libsdl )"
+
+#myconf="$myconf --with-extra-includes=/usr/include/noatun"
+use sdl && myconf="$myconf --with-sdl --with-sdl-prefix=/usr" || myconf="$myconf --without-sdl --disable-sdltest"
+
+# needed for some stupid noatun plugins that can't find arts include file reference.h, which lives in /usr/kde/3/include/arts
+#myconf="$myconf --with-extra-includes=/usr/kde/3/include/arts"
+
+src_unpack2() {
+
+ base_src_unpack
+
+ cd ${S}/noatun-plugins
+ for x in `find -iname Makefile.am` `find -iname Makefile.in`; do
+ echo "(Maybe) patching ${x}..."
+ cp ${x} ${x}2
+ sed -e "s:\$(kde_libraries)/libnoatun.so:${KDEDIR}/lib/libnoatun.so:" ${x}2 > ${x}
+ rm ${x}2
+ done
+
+}
+