summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-02-10 14:15:22 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-02-10 14:15:22 +0000
commite731e74dc8b645541b42d4804791904d410ef3f2 (patch)
tree326725b90dbe611055e667cf09a6ee358e8f5575 /kde-base/kdebase
parentVersion bump as per bug #80946 (diff)
downloadgentoo-2-e731e74dc8b645541b42d4804791904d410ef3f2.tar.gz
gentoo-2-e731e74dc8b645541b42d4804791904d410ef3f2.tar.bz2
gentoo-2-e731e74dc8b645541b42d4804791904d410ef3f2.zip
Add patch to fix compilation with gcc 3.4.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/ChangeLog6
-rw-r--r--kde-base/kdebase/files/kicker-visibility.diff58
-rw-r--r--kde-base/kdebase/kdebase-3.4.0_beta2.ebuild5
3 files changed, 67 insertions, 2 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 9ef3703aa8b0..50766798529a 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.179 2005/02/09 16:14:47 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.180 2005/02/10 14:15:22 greg_g Exp $
+
+ 10 Feb 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kicker-visibility.diff, kdebase-3.4.0_beta2.ebuild:
+ Add patch to fix compilation with gcc 3.4.
*kdebase-3.4.0_beta2 (09 Feb 2005)
diff --git a/kde-base/kdebase/files/kicker-visibility.diff b/kde-base/kdebase/files/kicker-visibility.diff
new file mode 100644
index 000000000000..8f295409f19d
--- /dev/null
+++ b/kde-base/kdebase/files/kicker-visibility.diff
@@ -0,0 +1,58 @@
+Index: global.h
+===================================================================
+RCS file: /home/kde/kdebase/kicker/share/global.h,v
+retrieving revision 1.29
+retrieving revision 1.30
+diff -u -p -r1.29 -r1.30
+--- kicker/share/global.h 4 Feb 2005 14:56:46 -0000 1.29
++++ kicker/share/global.h 4 Feb 2005 15:23:59 -0000 1.30
+@@ -33,26 +33,26 @@ CONNECTION WITH THE SOFTWARE OR THE USE
+ namespace KickerLib
+ {
+
+-KPanelExtension::Position directionToPosition(KPanelApplet::Direction d);
+-KPanelExtension::Position directionToPopupPosition(KPanelApplet::Direction d);
+-KPanelApplet::Direction positionToDirection(KPanelExtension::Position p);
+-int sizeValue(KPanelExtension::Size s);
+-QString copyDesktopFile(const KURL&url);
+-QString newDesktopFile(const KURL&url);
++KDE_EXPORT KPanelExtension::Position directionToPosition(KPanelApplet::Direction d);
++KDE_EXPORT KPanelExtension::Position directionToPopupPosition(KPanelApplet::Direction d);
++KDE_EXPORT KPanelApplet::Direction positionToDirection(KPanelExtension::Position p);
++KDE_EXPORT int sizeValue(KPanelExtension::Size s);
++KDE_EXPORT QString copyDesktopFile(const KURL&url);
++KDE_EXPORT QString newDesktopFile(const KURL&url);
+
+ /**
+ * Calculate the appropriate position for a popup menu based on the
+ * direction, the size of the menu, the widget geometry, and a optional
+ * point in the local coordinates of the widget.
+ */
+-QPoint popupPosition(KPanelApplet::Direction d,
++KDE_EXPORT QPoint popupPosition(KPanelApplet::Direction d,
+ const QWidget* popup,
+ const QWidget* source);
+-QPoint popupPosition(KPanelApplet::Direction d,
++KDE_EXPORT QPoint popupPosition(KPanelApplet::Direction d,
+ const QWidget* popup,
+ const QWidget* source,
+ const QPoint& p);
+-void colorize(QImage& image);
++KDE_EXPORT void colorize(QImage& image);
+
+ }
+
+Index: kickerSettings.kcfgc
+===================================================================
+RCS file: /home/kde/kdebase/kicker/share/kickerSettings.kcfgc,v
+retrieving revision 1.2
+retrieving revision 1.3
+diff -u -p -r1.2 -r1.3
+--- kicker/share/kickerSettings.kcfgc 3 Feb 2005 09:22:01 -0000 1.2
++++ kicker/share/kickerSettings.kcfgc 4 Feb 2005 15:23:59 -0000 1.3
+@@ -2,4 +2,5 @@ File=kickerSettings.kcfg
+ Singleton=true
+ ClassName=KickerSettings
+ Mutators=true
++Visibility=KDE_EXPORT
+ IncludeFiles=qapplication.h
diff --git a/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild b/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild
index a2c2a3d502cb..98d11a65c925 100644
--- a/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild
+++ b/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild,v 1.1 2005/02/09 16:14:47 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.4.0_beta2.ebuild,v 1.2 2005/02/10 14:15:22 greg_g Exp $
inherit kde-dist eutils
@@ -33,6 +33,9 @@ src_unpack() {
kde_src_unpack
epatch ${FILESDIR}/${PVR}/startkde-gentoo.diff
+
+ # see kde bug 98628. Applied for rc1.
+ epatch ${FILESDIR}/kicker-visibility.diff
}
src_compile() {