summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 09:59:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-03 09:59:21 +0000
commita7789279e32db3907755bd8a615d192ea9ca66e9 (patch)
tree00103e29ee05539f8c48b407a4e026b9348dc75b /kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild
parentBump to 3.5.5 (pre-release). (diff)
downloadgentoo-2-a7789279e32db3907755bd8a615d192ea9ca66e9.tar.gz
gentoo-2-a7789279e32db3907755bd8a615d192ea9ca66e9.tar.bz2
gentoo-2-a7789279e32db3907755bd8a615d192ea9ca66e9.zip
Bump to 3.5.5 (pre-release).
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild')
-rw-r--r--kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild
new file mode 100644
index 000000000000..45163d39ad62
--- /dev/null
+++ b/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics-kfile-plugins/kdegraphics-kfile-plugins-3.5.5.ebuild,v 1.1 2006/10/03 09:59:21 flameeyes Exp $
+
+KMNAME=kdegraphics
+KMMODULE=kfile-plugins
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="kfile plugins from kdegraphics"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="openexr"
+DEPEND="media-libs/tiff
+ openexr? ( media-libs/openexr )"
+
+# compilation of the tiff plugin depends on the check in acinclude.m4.in,
+# which doesn't have a switch.
+
+# ps installed with kghostview, pdf installed with kpdf
+KMEXTRACTONLY="kfile-plugins/ps kfile-plugins/pdf"
+
+src_compile() {
+ myconf="$myconf $(use_with openexr)"
+ kde-meta_src_compile
+}