summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-03-04 18:00:22 +0000
commita4c1d03d518d1416c826bb73ad524dc9bf1702a5 (patch)
treed6a50377f609e5e7550ca8a99686adcdcbdbd7a1 /kde-base/kget
parentRemoved unneccessary python_copy_sources (diff)
downloadgentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.gz
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.tar.bz2
gentoo-2-a4c1d03d518d1416c826bb73ad524dc9bf1702a5.zip
[kde-base] Add KDE SC 4.6.1
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kget')
-rw-r--r--kde-base/kget/ChangeLog7
-rw-r--r--kde-base/kget/kget-4.6.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kget/ChangeLog b/kde-base/kget/ChangeLog
index 2e4c0c601071..542c431856c5 100644
--- a/kde-base/kget/ChangeLog
+++ b/kde-base/kget/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kget/ChangeLog,v 1.180 2011/01/26 20:29:23 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kget/ChangeLog,v 1.181 2011/03/04 18:00:10 alexxy Exp $
+
+*kget-4.6.1 (04 Mar 2011)
+
+ 04 Mar 2011; Alexey Shvetsov <alexxy@gentoo.org> +kget-4.6.1.ebuild:
+ Version bump KDE SC 4.6.1
*kget-4.6.0 (26 Jan 2011)
diff --git a/kde-base/kget/kget-4.6.1.ebuild b/kde-base/kget/kget-4.6.1.ebuild
new file mode 100644
index 000000000000..d779d85dd6ec
--- /dev/null
+++ b/kde-base/kget/kget-4.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kget/kget-4.6.1.ebuild,v 1.1 2011/03/04 18:00:10 alexxy Exp $
+
+EAPI=3
+
+KDE_HANDBOOK="optional"
+KMNAME="kdenetwork"
+WEBKIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="An advanced download manager for KDE"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bittorrent semantic-desktop sqlite"
+
+RDEPEND="
+ app-crypt/qca:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep libkonq)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)
+ bittorrent? ( >=net-libs/libktorrent-1.0.3 )
+ sqlite? ( dev-db/sqlite:3 )
+ webkit? ( >=kde-misc/kwebkitpart-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+ # Disable bittorrent as supported mimetype
+ if ! use bittorrent; then
+ sed -e '/MimeType=/s|application/x-bittorrent;||' \
+ -i kget/desktop/kget.desktop || die
+ fi
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bittorrent KTorrent)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_with sqlite)
+ $(cmake-utils_use_with webkit KWebKitPart)
+ )
+ kde4-meta_src_configure
+}