summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-10-19 22:58:49 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-10-19 22:58:49 +0000
commitc84e023890574ca296d869377fccf66c96ebd321 (patch)
treed590ad22253110d4d41873947cb042b8a29b7d0a /kde-base/kicker/kicker-3.5.8.ebuild
parentBump to KDE 3.5.8. (diff)
downloadgentoo-2-c84e023890574ca296d869377fccf66c96ebd321.tar.gz
gentoo-2-c84e023890574ca296d869377fccf66c96ebd321.tar.bz2
gentoo-2-c84e023890574ca296d869377fccf66c96ebd321.zip
Bump to KDE 3.5.8.
(Portage version: 2.1.3.15)
Diffstat (limited to 'kde-base/kicker/kicker-3.5.8.ebuild')
-rw-r--r--kde-base/kicker/kicker-3.5.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/kde-base/kicker/kicker-3.5.8.ebuild b/kde-base/kicker/kicker-3.5.8.ebuild
new file mode 100644
index 000000000000..96f9bd2c704f
--- /dev/null
+++ b/kde-base/kicker/kicker-3.5.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kicker/kicker-3.5.8.ebuild,v 1.1 2007/10/19 22:58:48 philantrop Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdebase-3.5-patchset-03.tar.bz2"
+
+DESCRIPTION="Kicker is the KDE application starter panel and is also capable of some useful applets and extensions."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+
+RDEPEND="
+$(deprange $PV $MAXKDEVER kde-base/libkonq)
+$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ xcomposite? ( x11-libs/libXcomposite )"
+
+DEPEND="${RDEPEND}"
+
+KMCOPYLIB="libkonq libkonq"
+KMEXTRACTONLY="libkonq
+ kdm/kfrontend/themer/"
+KMCOMPILEONLY="kdmlib/"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}