summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-05-31 21:33:44 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-05-31 21:33:44 +0000
commit6eb147de1710ff76602e6ab6441ba65be7f7fce2 (patch)
tree0cf184c8a09e97fe2fc26a3450d71ca50902253e /kde-base/kooka
parentVersion bump. (diff)
downloadgentoo-2-6eb147de1710ff76602e6ab6441ba65be7f7fce2.tar.gz
gentoo-2-6eb147de1710ff76602e6ab6441ba65be7f7fce2.tar.bz2
gentoo-2-6eb147de1710ff76602e6ab6441ba65be7f7fce2.zip
Fix detection of gocr (#92779).
(Portage version: 2.0.51.19)
Diffstat (limited to 'kde-base/kooka')
-rw-r--r--kde-base/kooka/ChangeLog6
-rw-r--r--kde-base/kooka/files/kdegraphics-3.4.1-gocr.patch14
-rw-r--r--kde-base/kooka/kooka-3.4.1.ebuild7
3 files changed, 24 insertions, 3 deletions
diff --git a/kde-base/kooka/ChangeLog b/kde-base/kooka/ChangeLog
index a3694d84ffee..1591a83ffd32 100644
--- a/kde-base/kooka/ChangeLog
+++ b/kde-base/kooka/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kooka
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.8 2005/05/25 21:23:09 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/ChangeLog,v 1.9 2005/05/31 21:33:44 greg_g Exp $
+
+ 31 May 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/kdegraphics-3.4.1-gocr.patch, kooka-3.4.1.ebuild:
+ Fix detection of gocr (#92779).
*kooka-3.4.1 (25 May 2005)
diff --git a/kde-base/kooka/files/kdegraphics-3.4.1-gocr.patch b/kde-base/kooka/files/kdegraphics-3.4.1-gocr.patch
new file mode 100644
index 000000000000..1edb6b89bf9a
--- /dev/null
+++ b/kde-base/kooka/files/kdegraphics-3.4.1-gocr.patch
@@ -0,0 +1,14 @@
+diff -Nur kdegraphics-3.4.1.orig/kooka/ksaneocr.cpp kdegraphics-3.4.1/kooka/ksaneocr.cpp
+--- kdegraphics-3.4.1.orig/kooka/ksaneocr.cpp 2005-05-23 14:05:50.000000000 +0200
++++ kdegraphics-3.4.1/kooka/ksaneocr.cpp 2005-05-31 18:31:43.000000000 +0200
+@@ -108,6 +108,10 @@
+ {
+ m_ocrEngine = OCRAD;
+ }
++ else if( eng == "gocr" )
++ {
++ m_ocrEngine = GOCR;
++ }
+
+ #ifdef HAVE_KADMOS
+ else if( eng == QString("kadmos") ) m_ocrEngine = KADMOS;
diff --git a/kde-base/kooka/kooka-3.4.1.ebuild b/kde-base/kooka/kooka-3.4.1.ebuild
index 7ee5ffd13d9d..5993c4393500 100644
--- a/kde-base/kooka/kooka-3.4.1.ebuild
+++ b/kde-base/kooka/kooka-3.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.4.1.ebuild,v 1.2 2005/05/26 17:14:28 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kooka/kooka-3.4.1.ebuild,v 1.3 2005/05/31 21:33:44 greg_g Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -14,4 +14,7 @@ DEPEND="$(deprange $PV $MAXKDEVER kde-base/libkscan)"
OLDDEPEND="~kde-base/libkscan-$PV"
KMCOPYLIB="libkscan libkscan"
-KMEXTRACTONLY="libkscan" \ No newline at end of file
+KMEXTRACTONLY="libkscan"
+
+# Fix detection of gocr (kde bug 90082).
+PATCHES1="${FILESDIR}/kdegraphics-3.4.1-gocr.patch"