summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:14:07 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:14:07 +0000
commit44f9d03145639722c1f640618466e8bd0d16c38d (patch)
tree0374c0e1ed090d798c5f75d77dcc47eb63edbaea /kde-base/korganizer/korganizer-3.5.9.ebuild
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-44f9d03145639722c1f640618466e8bd0d16c38d.tar.gz
gentoo-2-44f9d03145639722c1f640618466e8bd0d16c38d.tar.bz2
gentoo-2-44f9d03145639722c1f640618466e8bd0d16c38d.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/korganizer/korganizer-3.5.9.ebuild')
-rw-r--r--kde-base/korganizer/korganizer-3.5.9.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/kde-base/korganizer/korganizer-3.5.9.ebuild b/kde-base/korganizer/korganizer-3.5.9.ebuild
new file mode 100644
index 000000000000..9551f3007c70
--- /dev/null
+++ b/kde-base/korganizer/korganizer-3.5.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korganizer/korganizer-3.5.9.ebuild,v 1.1 2008/02/20 23:14:07 philantrop Exp $
+
+KMNAME=kdepim
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdepim-3.5-patchset-04.tar.bz2"
+
+DESCRIPTION="A Personal Organizer for KDE"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=kde-base/libkpimexchange-${PV}:${SLOT}
+>=kde-base/libkdepim-${PV}:${SLOT}
+>=kde-base/libkcal-${PV}:${SLOT}
+>=kde-base/libkpimidentities-${PV}:${SLOT}
+>=kde-base/ktnef-${PV}:${SLOT}
+>=kde-base/kdepim-kresources-${PV}:${SLOT}
+>=kde-base/kontact-${PV}:${SLOT}
+>=kde-base/libkholidays-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+KMCOPYLIB="
+ libkdepim libkdepim
+ libkpimexchange libkpimexchange
+ libkcal libkcal
+ libkpimidentities libkpimidentities
+ libktnef ktnef/lib
+ libkcal_resourceremote kresources/remote
+ libkpinterfaces kontact/interfaces
+ libkholidays libkholidays
+ libkmime libkmime"
+KMEXTRACTONLY="
+ libkpimexchange/
+ libkcal/
+ libkdepim/
+ libkpimidentities/
+ libkmime/
+ mimelib/
+ ktnef/
+ certmanager/lib/
+ kresources/remote/
+ kmail/kmailIface.h
+ kontact/interfaces/
+ libkholidays"
+KMCOMPILEONLY="
+ libemailfunctions"
+
+# They seems to be used only by korganizer
+KMEXTRA="
+ kgantt
+ kdgantt
+ kontact/plugins/korganizer/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of korganizer deps.
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ # Broken test
+ sed -e "s:check_PROGRAMS = testalarmdlg:check_PROGRAMS =:" -i korganizer/korgac/Makefile.am || die "sed failed"
+}