summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
committerJohannes Huber <johu@gentoo.org>2014-07-16 17:41:08 +0000
commitc9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f (patch)
tree94015d5f29e37019f20bdced917f52e9b11645da /kde-base/korundum
parentAdd kde-workspace 4.11.11 SRC_URI, remove obsolete. (diff)
downloadgentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.gz
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.tar.bz2
gentoo-2-c9d9af7b4a2d35fabb1adf67a471ad2c1f09fc2f.zip
Version bump KDE SC 4.13.3
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/korundum')
-rw-r--r--kde-base/korundum/ChangeLog7
-rw-r--r--kde-base/korundum/korundum-4.13.3.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/kde-base/korundum/ChangeLog b/kde-base/korundum/ChangeLog
index c9492e666a5e..8950894de78b 100644
--- a/kde-base/korundum/ChangeLog
+++ b/kde-base/korundum/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/korundum
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.219 2014/06/19 13:32:37 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/ChangeLog,v 1.220 2014/07/16 17:40:54 johu Exp $
+
+*korundum-4.13.3 (16 Jul 2014)
+
+ 16 Jul 2014; Johannes Huber <johu@gentoo.org> +korundum-4.13.3.ebuild:
+ Version bump KDE SC 4.13.3
19 Jun 2014; Chris Reffett <creffett@gentoo.org> -korundum-4.13.1.ebuild:
Remove KDE SC 4.13.1
diff --git a/kde-base/korundum/korundum-4.13.3.ebuild b/kde-base/korundum/korundum-4.13.3.ebuild
new file mode 100644
index 000000000000..b996fac26721
--- /dev/null
+++ b/kde-base/korundum/korundum-4.13.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/korundum/korundum-4.13.3.ebuild,v 1.1 2014/07/16 17:40:54 johu Exp $
+
+EAPI=5
+
+OPENGL_REQUIRED="always"
+
+USE_RUBY="ruby19"
+# Only one ruby version is supported:
+# 1) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 2) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-base ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="akonadi debug kate nepomuk okular"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Ruby"
+
+DEPEND="
+ $(add_kdebase_dep qtruby)
+ $(add_kdebase_dep smokekde 'akonadi?,kate?,okular?,nepomuk?')
+ $(add_kdebase_dep smokeqt)
+"
+RDEPEND="${DEPEND}
+"
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_unpack() {
+ local S="${WORKDIR}/${P}"
+ kde4-base_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-base_src_prepare
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ local mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with nepomuk)
+ $(cmake-utils_use_with nepomuk Soprano)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ )
+ kde4-base_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-base_src_install
+}