summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 22:51:57 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 22:51:57 +0000
commit51931a86a8d175583c746f5e44ba4f97a70e66b5 (patch)
tree4ee5fc40b0d938272a5badbdf83e960f32db3714 /kde-base/kstars
parentBump kde to 4.1.4 (diff)
downloadgentoo-2-51931a86a8d175583c746f5e44ba4f97a70e66b5.tar.gz
gentoo-2-51931a86a8d175583c746f5e44ba4f97a70e66b5.tar.bz2
gentoo-2-51931a86a8d175583c746f5e44ba4f97a70e66b5.zip
Bump kde to 4.1.4
(Portage version: 2.2_rc21/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog9
-rw-r--r--kde-base/kstars/kstars-4.1.4.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index e9e3b8244595..5a5ac61f6cb3 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.106 2008/11/16 08:04:06 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.107 2009/01/13 22:51:57 alexxy Exp $
+
+*kstars-4.1.4 (13 Jan 2009)
+
+ 13 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +kstars-4.1.4.ebuild:
+ Bump to 4.1.4
15 Nov 2008; Mike Frysinger <vapier@gentoo.org> kstars-4.1.3.ebuild:
Add ppc/ppc64 love #244306.
diff --git a/kde-base/kstars/kstars-4.1.4.ebuild b/kde-base/kstars/kstars-4.1.4.ebuild
new file mode 100644
index 000000000000..ad269f411977
--- /dev/null
+++ b/kde-base/kstars/kstars-4.1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.1.4.ebuild,v 1.1 2009/01/13 22:51:57 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdeedu
+inherit kde4-meta flag-o-matic toolchain-funcs
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug fits htmlhandbook nova sbig usb"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ fits? ( sci-libs/cfitsio )
+ nova? ( >=sci-libs/libnova-0.12.1 )
+ sbig? ( sci-libs/indilib
+ usb? ( dev-libs/libusb ) )"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/${PN}-4.1.0-destdir.patch")
+
+src_unpack() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+
+ kde4-meta_src_unpack
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with nova Nova)
+ $(cmake-utils_use_with sbig SBIG)
+ $(cmake-utils_use_with usb USB)"
+
+ sed -i -e "s:add_subdirectory(cmake):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+ sed -i -e "s:add_subdirectory( cmake ):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+
+ kde4-meta_src_configure
+
+ # FIXME Unhandled arguments - added sbig but not sure about use descriptions or flag names...
+ # WITH_SBIG - Switch which controls the detection of the proprietary and binary only SBIG CCD universal library. No ebuild for this package
+ # are available at the moment.
+ # ssh_tunnel -> INDI Server binds locally. Remote clients may only connect
+ # via SSH Tunneling.
+}