summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
committerJohannes Huber <johu@gentoo.org>2014-05-13 17:43:47 +0000
commitad239490ed9eef8b7e06727b919d4593f51667ae (patch)
tree86688474b00c8427904e72d675cbe3d82b38d1c2 /kde-base/ksystemlog
parentVersion bump. (diff)
downloadgentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.gz
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.tar.bz2
gentoo-2-ad239490ed9eef8b7e06727b919d4593f51667ae.zip
Version bump KDE SC 4.13.1
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.13.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index cf8717d126d6..8789b6a9161a 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.209 2014/05/08 10:32:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.210 2014/05/13 17:43:38 johu Exp $
+
+*ksystemlog-4.13.1 (13 May 2014)
+
+ 13 May 2014; Johannes Huber <johu@gentoo.org> +ksystemlog-4.13.1.ebuild:
+ Version bump KDE SC 4.13.1
08 May 2014; Agostino Sarubbo <ago@gentoo.org> -ksystemlog-4.11.5.ebuild:
Remove old
diff --git a/kde-base/ksystemlog/ksystemlog-4.13.1.ebuild b/kde-base/ksystemlog/ksystemlog-4.13.1.ebuild
new file mode 100644
index 000000000000..99b511167774
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.13.1.ebuild,v 1.1 2014/05/13 17:43:38 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}