summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
commitb0c8c41397c5a2e84e4a1126a6ac202205014ee7 (patch)
tree1c82eef4e9829216eda4b7a814332e668a7afcea /kde-base/ksystemlog
parentVersion bump to snapshot version since there are a lot of fixes and upstream ... (diff)
downloadgentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.gz
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.bz2
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.zip
Version bump KDE SC 4.12.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.12.4.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index 144d7f8f4e5f..7ed73eb33797 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.198 2014/03/11 13:06:22 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.199 2014/04/01 18:09:37 johu Exp $
+
+*ksystemlog-4.12.4 (01 Apr 2014)
+
+ 01 Apr 2014; Johannes Huber <johu@gentoo.org> +ksystemlog-4.12.4.ebuild:
+ Version bump KDE SC 4.12.4
11 Mar 2014; Johannes Huber <johu@gentoo.org> -ksystemlog-4.12.2.ebuild:
Remove KDE SC 4.12.2
diff --git a/kde-base/ksystemlog/ksystemlog-4.12.4.ebuild b/kde-base/ksystemlog/ksystemlog-4.12.4.ebuild
new file mode 100644
index 000000000000..c32cf47bd969
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.12.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.12.4.ebuild,v 1.1 2014/04/01 18:09:37 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="KDE system log viewer"
+HOMEPAGE="http://www.kde.org/applications/system/ksystemlog/"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}