summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-06-15 17:24:10 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-06-15 17:24:10 +0000
commite7475f3013ac45bbfa6149e96eb235c5b0a4a449 (patch)
treee73dad8e74da9f9ab82e896284d1835b2cc13f87 /kde-base/kwin
parentCleanup. (diff)
downloadgentoo-2-e7475f3013ac45bbfa6149e96eb235c5b0a4a449.tar.gz
gentoo-2-e7475f3013ac45bbfa6149e96eb235c5b0a4a449.tar.bz2
gentoo-2-e7475f3013ac45bbfa6149e96eb235c5b0a4a449.zip
Version bump KDE SC 4.11.10
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.11.10.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index c7a9c304829a..22ee48caa6e7 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.386 2014/05/08 10:32:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.387 2014/06/15 17:24:08 kensington Exp $
+
+*kwin-4.11.10 (15 Jun 2014)
+
+ 15 Jun 2014; Michael Palimaka <kensington@gentoo.org> +kwin-4.11.10.ebuild:
+ Version bump KDE SC 4.11.10
08 May 2014; Agostino Sarubbo <ago@gentoo.org> -kwin-4.11.5.ebuild:
Remove old
diff --git a/kde-base/kwin/kwin-4.11.10.ebuild b/kde-base/kwin/kwin-4.11.10.ebuild
new file mode 100644
index 000000000000..b3a79d7c8898
--- /dev/null
+++ b/kde-base/kwin/kwin-4.11.10.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.11.10.ebuild,v 1.1 2014/06/15 17:24:08 kensington Exp $
+
+EAPI=5
+
+KMNAME="kde-workspace"
+DECLARATIVE_REQUIRED="always"
+OPENGL_REQUIRED="always"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 8: kwin-TestVirtualDesktops hangs even with virtualx
+
+inherit flag-o-matic kde4-meta
+
+DESCRIPTION="KDE window manager"
+HOMEPAGE+=" http://userbase.kde.org/KWin"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug gles opengl wayland"
+
+COMMONDEPEND="
+ $(add_kdebase_dep kactivities)
+ $(add_kdebase_dep kdelibs opengl)
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep liboxygenstyle)
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ opengl? ( >=media-libs/mesa-7.10 )
+ gles? ( >=media-libs/mesa-7.12[egl(+),gles2] )
+ wayland? ( >=media-libs/mesa-9.0[egl(+),wayland] )
+"
+DEPEND="${COMMONDEPEND}
+ x11-libs/xcb-util-renderutil
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ x11-proto/fixesproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+"
+RDEPEND="${COMMONDEPEND}
+ x11-apps/scripts
+"
+
+KMEXTRACTONLY="
+ ksmserver/
+ libs/kephal/
+ libs/oxygen/
+"
+
+# you need one of these
+REQUIRED_USE="!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )"
+
+src_configure() {
+ # FIXME Remove when activity API moved away from libkworkspace
+ append-cppflags "-I${EPREFIX}/usr/include/kworkspace"
+
+ mycmakeargs=(
+ $(cmake-utils_use_with gles OpenGLES)
+ $(cmake-utils_use gles KWIN_BUILD_WITH_OPENGLES)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with wayland Wayland)
+ -DWITH_X11_Xcomposite=ON
+ )
+
+ kde4-meta_src_configure
+}