summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-22 15:59:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-22 15:59:24 +0000
commitf4d6311a99776da2954a60b33f97b75a9186aaaf (patch)
treea69928a51cd0a8f92c5da6240f5b0bf1e3979c73 /kde-base/okteta
parentDrop all Prefix profiles to experimental state for the time being. (diff)
downloadgentoo-2-f4d6311a99776da2954a60b33f97b75a9186aaaf.tar.gz
gentoo-2-f4d6311a99776da2954a60b33f97b75a9186aaaf.tar.bz2
gentoo-2-f4d6311a99776da2954a60b33f97b75a9186aaaf.zip
Make okteta actualy functional. Per bug #292608.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/okteta')
-rw-r--r--kde-base/okteta/ChangeLog9
-rw-r--r--kde-base/okteta/files/4.3.3-detect_changes_correctly.patch16
-rw-r--r--kde-base/okteta/files/4.3.3-fix_inverse_save_logic.patch16
-rw-r--r--kde-base/okteta/okteta-4.3.3-r1.ebuild (renamed from kde-base/okteta/okteta-4.3.3.ebuild)7
4 files changed, 46 insertions, 2 deletions
diff --git a/kde-base/okteta/ChangeLog b/kde-base/okteta/ChangeLog
index 69281ad43b91..4b8f0df8ea9b 100644
--- a/kde-base/okteta/ChangeLog
+++ b/kde-base/okteta/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/okteta
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okteta/ChangeLog,v 1.28 2009/11/09 00:16:15 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okteta/ChangeLog,v 1.29 2009/11/22 15:59:24 scarabeus Exp $
+
+*okteta-4.3.3-r1 (22 Nov 2009)
+
+ 22 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/4.3.3-detect_changes_correctly.patch, -okteta-4.3.3.ebuild,
+ +files/4.3.3-fix_inverse_save_logic.patch, +okteta-4.3.3-r1.ebuild:
+ Make okteta actualy functional. Per bug #292608.
08 Nov 2009; Alexey Shvetsov <alexxy@gentoo.org> -okteta-4.3.2.ebuild:
Drop KDE 4.3.2
diff --git a/kde-base/okteta/files/4.3.3-detect_changes_correctly.patch b/kde-base/okteta/files/4.3.3-detect_changes_correctly.patch
new file mode 100644
index 000000000000..6f27d817e3ab
--- /dev/null
+++ b/kde-base/okteta/files/4.3.3-detect_changes_correctly.patch
@@ -0,0 +1,16 @@
+Index: branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp
+===================================================================
+--- branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp (revision 1046928)
++++ branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp (revision 1046929)
+@@ -217,9 +217,9 @@
+ if( synchronizer )
+ {
+ AbstractSyncToRemoteJob *syncJob = synchronizer->startSyncToRemote();
+- const bool syncFailed = JobManager::executeJob( syncJob, mWidget );
++ const bool isSynced = JobManager::executeJob( syncJob, mWidget );
+
+- canClose = !syncFailed;
++ canClose = isSynced;
+ }
+ else
+ canClose = setSynchronizer( document );
diff --git a/kde-base/okteta/files/4.3.3-fix_inverse_save_logic.patch b/kde-base/okteta/files/4.3.3-fix_inverse_save_logic.patch
new file mode 100644
index 000000000000..6f27d817e3ab
--- /dev/null
+++ b/kde-base/okteta/files/4.3.3-fix_inverse_save_logic.patch
@@ -0,0 +1,16 @@
+Index: branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp
+===================================================================
+--- branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp (revision 1046928)
++++ branches/KDE/4.3/kdeutils/okteta/program/libkakao/core/system/kdocumentsyncmanager.cpp (revision 1046929)
+@@ -217,9 +217,9 @@
+ if( synchronizer )
+ {
+ AbstractSyncToRemoteJob *syncJob = synchronizer->startSyncToRemote();
+- const bool syncFailed = JobManager::executeJob( syncJob, mWidget );
++ const bool isSynced = JobManager::executeJob( syncJob, mWidget );
+
+- canClose = !syncFailed;
++ canClose = isSynced;
+ }
+ else
+ canClose = setSynchronizer( document );
diff --git a/kde-base/okteta/okteta-4.3.3.ebuild b/kde-base/okteta/okteta-4.3.3-r1.ebuild
index 0a6d390cf9f2..ac8f369f30d4 100644
--- a/kde-base/okteta/okteta-4.3.3.ebuild
+++ b/kde-base/okteta/okteta-4.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okteta/okteta-4.3.3.ebuild,v 1.1 2009/11/02 22:06:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okteta/okteta-4.3.3-r1.ebuild,v 1.1 2009/11/22 15:59:24 scarabeus Exp $
EAPI="2"
@@ -15,3 +15,8 @@ DEPEND="
app-crypt/qca:2
"
RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-detect_changes_correctly.patch"
+ "${FILESDIR}/${PV}-fix_inverse_save_logic.patch"
+)