summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-08-14 20:24:27 +0000
commit053fab4599b7a153575d6540f06f69fecd0d2740 (patch)
tree4f7d23e33c53b4249e734fa22c9151eae906afd0 /kde-base/okular
parentFixed and marked for ~x64-macos, bug #479554 (diff)
downloadgentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.gz
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.tar.bz2
gentoo-2-053fab4599b7a153575d6540f06f69fecd0d2740.zip
Version bump KDE SC 4.11.0
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.11.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index 2afa509352b0..a146f0489b1f 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.206 2013/08/02 17:21:04 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.207 2013/08/14 20:24:24 dilfridge Exp $
+
+*okular-4.11.0 (14 Aug 2013)
+
+ 14 Aug 2013; Andreas K. Huettel <dilfridge@gentoo.org> +okular-4.11.0.ebuild:
+ Version bump KDE SC 4.11.0
02 Aug 2013; Johannes Huber <johu@gentoo.org> -okular-4.10.4.ebuild:
Remove KDE SC 4.10.4
diff --git a/kde-base/okular/okular-4.11.0.ebuild b/kde-base/okular/okular-4.11.0.ebuild
new file mode 100644
index 000000000000..8c05fab2ca9a
--- /dev/null
+++ b/kde-base/okular/okular-4.11.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.11.0.ebuild,v 1.1 2013/08/14 20:24:24 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+
+#VIRTUALX_REQUIRED=test
+RESTRICT=test
+# test 2: parttest hangs
+
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+HOMEPAGE="http://okular.kde.org http://www.kde.org/applications/graphics/okular"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}