summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commitb55417d98c3ac6be2310a3971632cceac43c9378 (patch)
tree76ff040300cffb0bfdb60a4c1a785df48fbbf7cd /kde-base/phonon-kde
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadgentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.gz
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.tar.bz2
gentoo-2-b55417d98c3ac6be2310a3971632cceac43c9378.zip
[kde-base] Add KDE SC 4.6.0
(Portage version: 2.2.0_alpha19_p2/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog7
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.6.0.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 5426d4887331..cfc6d52644a0 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.74 2011/01/23 19:21:34 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.75 2011/01/26 20:28:52 alexxy Exp $
+
+*phonon-kde-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org> +phonon-kde-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
23 Jan 2011; Maciej Mrozowski <reavertm@gentoo.org>
phonon-kde-4.5.5.ebuild:
diff --git a/kde-base/phonon-kde/phonon-kde-4.6.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.6.0.ebuild
new file mode 100644
index 000000000000..feb65aa08eb5
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.6.0.ebuild,v 1.1 2011/01/26 20:28:52 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="alsa debug xine pulseaudio"
+
+DEPEND="
+ >=media-sound/phonon-4.4.3[xine?]
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_tests=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with xine)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}