summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-10-25 19:58:39 +0000
commitd184f1ab9f020bfde5c438ef4619ca58de2159f7 (patch)
tree7d64a3c945eda98cf0dbc517b9c12bbccf4f6c1e /kde-base/phonon-kde
parentVersion bump (diff)
downloadgentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.gz
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.tar.bz2
gentoo-2-d184f1ab9f020bfde5c438ef4619ca58de2159f7.zip
Version bump KDE SC 4.14.2
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-base/phonon-kde')
-rw-r--r--kde-base/phonon-kde/ChangeLog8
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.14.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/phonon-kde/ChangeLog b/kde-base/phonon-kde/ChangeLog
index 14a894d22c70..732093dd244c 100644
--- a/kde-base/phonon-kde/ChangeLog
+++ b/kde-base/phonon-kde/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/phonon-kde
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.231 2014/09/16 18:17:23 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/ChangeLog,v 1.232 2014/10/25 19:58:27 kensington Exp $
+
+*phonon-kde-4.14.2 (25 Oct 2014)
+
+ 25 Oct 2014; Michael Palimaka <kensington@gentoo.org>
+ +phonon-kde-4.14.2.ebuild:
+ Version bump KDE SC 4.14.2
*phonon-kde-4.14.1 (16 Sep 2014)
diff --git a/kde-base/phonon-kde/phonon-kde-4.14.2.ebuild b/kde-base/phonon-kde/phonon-kde-4.14.2.ebuild
new file mode 100644
index 000000000000..dbc1ade1cbff
--- /dev/null
+++ b/kde-base/phonon-kde/phonon-kde-4.14.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.14.2.ebuild,v 1.1 2014/10/25 19:58:27 kensington Exp $
+
+EAPI=5
+
+KMNAME="kde-runtime"
+KMMODULE="phonon"
+inherit kde4-meta
+
+DESCRIPTION="Phonon KDE Integration"
+HOMEPAGE="http://phonon.kde.org"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa debug pulseaudio"
+
+DEPEND="
+ media-libs/phonon[qt4]
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libcanberra
+ >=media-sound/pulseaudio-0.9.21[glib]
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_tests=OFF
+ -DWITH_Xine=OFF
+ $(cmake-utils_use_with alsa)
+ $(cmake-utils_use_with pulseaudio PulseAudio)
+ )
+
+ kde4-meta_src_configure
+}