summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-24 22:33:17 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-24 22:33:17 +0000
commit29c39ffc45cc058b4ffce616eff002199ea8ae53 (patch)
treeb055493e9d2e4dea10d11f51da613d34a9347433 /kde-base/plasma-workspace
parentUse autotools-utils eclass. (diff)
downloadgentoo-2-29c39ffc45cc058b4ffce616eff002199ea8ae53.tar.gz
gentoo-2-29c39ffc45cc058b4ffce616eff002199ea8ae53.tar.bz2
gentoo-2-29c39ffc45cc058b4ffce616eff002199ea8ae53.zip
Add another backported crash fix, bug 391285
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/plasma-workspace')
-rw-r--r--kde-base/plasma-workspace/ChangeLog9
-rw-r--r--kde-base/plasma-workspace/files/plasma-workspace-4.7.3-layoutcrash.patch27
-rw-r--r--kde-base/plasma-workspace/plasma-workspace-4.7.3-r6.ebuild (renamed from kde-base/plasma-workspace/plasma-workspace-4.7.3-r5.ebuild)3
3 files changed, 37 insertions, 2 deletions
diff --git a/kde-base/plasma-workspace/ChangeLog b/kde-base/plasma-workspace/ChangeLog
index f5c3d7eb71c9..8ac37dd0d9c8 100644
--- a/kde-base/plasma-workspace/ChangeLog
+++ b/kde-base/plasma-workspace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/plasma-workspace
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.135 2011/11/22 22:49:57 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/ChangeLog,v 1.136 2011/11/24 22:33:17 dilfridge Exp $
+
+*plasma-workspace-4.7.3-r6 (24 Nov 2011)
+
+ 24 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ -plasma-workspace-4.7.3-r5.ebuild, +plasma-workspace-4.7.3-r6.ebuild,
+ +files/plasma-workspace-4.7.3-layoutcrash.patch:
+ Add another backported crash fix, bug 391285
*plasma-workspace-4.7.3-r5 (22 Nov 2011)
diff --git a/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-layoutcrash.patch b/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-layoutcrash.patch
new file mode 100644
index 000000000000..4697a1fde8ba
--- /dev/null
+++ b/kde-base/plasma-workspace/files/plasma-workspace-4.7.3-layoutcrash.patch
@@ -0,0 +1,27 @@
+commit 77b1374b99ee91d23d8802dd1dec9a5f630e919a
+Author: Aaron Seigo <aseigo@kde.org>
+Date: Wed Nov 9 20:15:50 2011 +0100
+
+ only delete the layout when it isn't assigned to another layout
+
+ based on the patch by Raul Fernandes
+ BUG:275286
+
+diff --git a/plasma/desktop/applets/tasks/taskgroupitem.cpp b/plasma/desktop/applets/tasks/taskgroupitem.cpp
+index 6b23b71..d7816d3 100644
+--- a/plasma/desktop/applets/tasks/taskgroupitem.cpp
++++ b/plasma/desktop/applets/tasks/taskgroupitem.cpp
+@@ -79,8 +79,11 @@ TaskGroupItem::TaskGroupItem(QGraphicsWidget *parent, Tasks *applet)
+
+ TaskGroupItem::~TaskGroupItem()
+ {
+- delete m_tasksLayout;
+- m_tasksLayout = 0;
++ if (!m_offscreenLayout && !m_mainLayout) {
++ // only delete this if we have neither an offscreen layout or a mainlayout
++ // if we do, then they will delete the layout for us.
++ delete m_tasksLayout;
++ }
+ }
+
+ bool TaskGroupItem::isSplit()
diff --git a/kde-base/plasma-workspace/plasma-workspace-4.7.3-r5.ebuild b/kde-base/plasma-workspace/plasma-workspace-4.7.3-r6.ebuild
index cb013fc5683a..ec2939d0f3c3 100644
--- a/kde-base/plasma-workspace/plasma-workspace-4.7.3-r5.ebuild
+++ b/kde-base/plasma-workspace/plasma-workspace-4.7.3-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.7.3-r5.ebuild,v 1.1 2011/11/22 22:49:57 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/plasma-workspace/plasma-workspace-4.7.3-r6.ebuild,v 1.1 2011/11/24 22:33:17 dilfridge Exp $
EAPI=4
@@ -77,6 +77,7 @@ PATCHES=(
"${FILESDIR}/${PN}-4.7.3-weathercrash.patch"
"${FILESDIR}/${PN}-4.7.3-taskcrash.patch"
"${FILESDIR}/${PN}-4.7.3-calendarcrash.patch"
+ "${FILESDIR}/${PN}-4.7.3-layoutcrash.patch"
)
pkg_setup() {