summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-02-06 23:21:00 +0000
commit4cba78c8fcd56c326a180b231d15e11076652ab8 (patch)
tree2c17ca88ed78d7e028d5db315475f32581f8ef0d /kde-base/rocs/rocs-4.12.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.gz
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.tar.bz2
gentoo-2-4cba78c8fcd56c326a180b231d15e11076652ab8.zip
Version bump KDE SC 4.12.2
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'kde-base/rocs/rocs-4.12.2.ebuild')
-rw-r--r--kde-base/rocs/rocs-4.12.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/rocs/rocs-4.12.2.ebuild b/kde-base/rocs/rocs-4.12.2.ebuild
new file mode 100644
index 000000000000..4c92b6e5b5fe
--- /dev/null
+++ b/kde-base/rocs/rocs-4.12.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.12.2.ebuild,v 1.1 2014/02/06 23:20:04 dilfridge Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="KDE4 interface to work with Graph Theory"
+HOMEPAGE="http://www.kde.org/applications/education/rocs
+http://edu.kde.org/applications/mathematics/rocs"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/grantlee
+ dev-qt/qtxmlpatterns:4
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.49
+"
+
+RESTRICT=test
+# bug 443752
+
+src_test() {
+ local mycmakeargs=(-DKDE4_BUILD_TESTS=ON)
+ cmake-utils_src_configure
+ kde4-base_src_compile
+
+ cd "${BUILD_DIR}"
+ emake DESTDIR="${T}/tests" install
+ export KDEDIRS="${KDEDIRS}:${T}/tests/${PREFIX}"
+ kbuildsycoca4
+ ctest || die "tests failed"
+}