summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-07 00:12:59 +0000
commitb0cf2ebbfc7626d65b374788654d4e26028bda3f (patch)
tree473933e2eaf30d14938b24846be4b834a0d385d4 /kde-base/systemsettings
parentrename check_apache_threads to has_apache_threads as suggested by dberkholz (diff)
downloadgentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.gz
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.tar.bz2
gentoo-2-b0cf2ebbfc7626d65b374788654d4e26028bda3f.zip
Version bump to KDE 4.0.1.
(Portage version: 2.1.4.1)
Diffstat (limited to 'kde-base/systemsettings')
-rw-r--r--kde-base/systemsettings/ChangeLog8
-rw-r--r--kde-base/systemsettings/files/systemsettings-4.0.1-opengl.patch21
-rw-r--r--kde-base/systemsettings/systemsettings-4.0.1.ebuild66
3 files changed, 94 insertions, 1 deletions
diff --git a/kde-base/systemsettings/ChangeLog b/kde-base/systemsettings/ChangeLog
index e320143636dc..a20024c461b5 100644
--- a/kde-base/systemsettings/ChangeLog
+++ b/kde-base/systemsettings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/systemsettings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.3 2008/02/01 05:21:35 zlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.4 2008/02/07 00:11:37 philantrop Exp $
+
+*systemsettings-4.0.1 (06 Feb 2008)
+
+ 06 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/systemsettings-4.0.1-opengl.patch, +systemsettings-4.0.1.ebuild:
+ Version bump to KDE 4.0.1.
01 Feb 2008; Bo Ørsted Andresen <zlin@gentoo.org>
systemsettings-4.0.0.ebuild:
diff --git a/kde-base/systemsettings/files/systemsettings-4.0.1-opengl.patch b/kde-base/systemsettings/files/systemsettings-4.0.1-opengl.patch
new file mode 100644
index 000000000000..3a8d3ef0f0cb
--- /dev/null
+++ b/kde-base/systemsettings/files/systemsettings-4.0.1-opengl.patch
@@ -0,0 +1,21 @@
+--- workspace/CMakeLists.txt (revision 767202)
++++ workspace/CMakeLists.txt (working copy)
+@@ -16,8 +16,6 @@
+ include (MacroLibrary)
+ include (KDE4Defaults)
+
+-macro_optional_find_package(OpenGL)
+-
+ include(ConfigureChecks.cmake)
+ configure_file(config-unix.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-unix.h )
+ configure_file(config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h )
+--- workspace/kcontrol/screensaver/CMakeLists.txt
++++ workspace/kcontrol/screensaver/CMakeLists.txt
+@@ -1,5 +1,7 @@
+
++if(OPENGL_FOUND)
+ check_library_exists(GL glXChooseVisual "" HAVE_GLXCHOOSEVISUAL)
++endif(OPENGL_FOUND)
+ configure_file (config-screensaver.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-screensaver.h )
+
+ add_definitions (-DQT3_SUPPORT)
diff --git a/kde-base/systemsettings/systemsettings-4.0.1.ebuild b/kde-base/systemsettings/systemsettings-4.0.1.ebuild
new file mode 100644
index 000000000000..adb29cb1ba27
--- /dev/null
+++ b/kde-base/systemsettings/systemsettings-4.0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.0.1.ebuild,v 1.1 2008/02/07 00:11:37 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="System settings utility"
+IUSE="debug htmlhandbook ieee1394 opengl ssl +usb xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMONDEPEND="
+ >=app-misc/strigi-0.5.7
+ >=dev-libs/glib-2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXtst
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? ( virtual/opengl
+ virtual/glu )
+ ssl? ( dev-libs/openssl )
+ usb? ( >=dev-libs/libusb-0.1.10a )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/xextproto
+ x11-proto/kbproto
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}
+ || ( x11-misc/xkeyboard-config
+ x11-misc/xkbdata )
+ x11-apps/setxkbmap"
+
+KMEXTRA="kcontrol/"
+
+KMEXTRACTONLY="
+ krunner/org.kde.krunner.App.xml
+ krunner/org.kde.screensaver.xml
+ kwin/
+ libs/
+ plasma/"
+
+PATCHES="${FILESDIR}/${P}-opengl.patch"
+
+# FIXME: is have_openglxvisual found without screensaver
+src_compile() {
+ # Old keyboard-detection code is unmaintained,
+ # so we force the new stuff, using libxklavier.
+ mycmakeargs="${mycmakeargs}
+ -DUSE_XKLAVIER=ON -DWITH_LibXKlavier=ON
+ -DWITH_GLIB2=ON -DWITH_GObject=ON
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with ssl OpenSSL)
+ $(cmake-utils_use_with usb USB)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}