summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-24 19:52:58 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-24 19:52:58 +0000
commit0ff2f4dc2c2cf5cd235268e6591b130aa861f8df (patch)
treeb27ea4e6e1fee74278fe7ffbfc86e0c595f1b14c /kde-base
parentversion bump thanks to Jeremy Heslop <jeremy@jheslop.com> in bug 120132 (diff)
downloadgentoo-2-0ff2f4dc2c2cf5cd235268e6591b130aa861f8df.tar.gz
gentoo-2-0ff2f4dc2c2cf5cd235268e6591b130aa861f8df.tar.bz2
gentoo-2-0ff2f4dc2c2cf5cd235268e6591b130aa861f8df.zip
Add patch to fix the 'Save As...' problem that's not fixed in 3.5.1.
(Portage version: 2529-svn)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kpdf/ChangeLog6
-rw-r--r--kde-base/kpdf/files/kpdf-3.5.1-saveas.patch14
-rw-r--r--kde-base/kpdf/kpdf-3.5.1.ebuild4
3 files changed, 22 insertions, 2 deletions
diff --git a/kde-base/kpdf/ChangeLog b/kde-base/kpdf/ChangeLog
index c829a1656d2c..1f8c688411d7 100644
--- a/kde-base/kpdf/ChangeLog
+++ b/kde-base/kpdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kpdf
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/ChangeLog,v 1.68 2006/01/22 22:53:04 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/ChangeLog,v 1.69 2006/01/24 19:52:58 flameeyes Exp $
+
+ 24 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kpdf-3.5.1-saveas.patch, kpdf-3.5.1.ebuild:
+ Add patch to fix the 'Save As...' problem that's not fixed in 3.5.1.
*kpdf-3.5.1 (23 Jan 2006)
diff --git a/kde-base/kpdf/files/kpdf-3.5.1-saveas.patch b/kde-base/kpdf/files/kpdf-3.5.1-saveas.patch
new file mode 100644
index 000000000000..7649d393453e
--- /dev/null
+++ b/kde-base/kpdf/files/kpdf-3.5.1-saveas.patch
@@ -0,0 +1,14 @@
+--- branches/KDE/3.5/kdegraphics/kpdf/part.cpp 2006/01/18 21:57:05 499855
++++ branches/KDE/3.5/kdegraphics/kpdf/part.cpp 2006/01/23 23:11:54 501814
+@@ -697,6 +697,11 @@
+ KURL saveURL = KFileDialog::getSaveURL( url().isLocalFile() ? url().url() : url().fileName(), QString::null, widget() );
+ if ( saveURL.isValid() && !saveURL.isEmpty() )
+ {
++ if (saveURL == url())
++ {
++ KMessageBox::information( widget(), i18n("You are trying to overwrite \"%1\" with itself. This is not allowed. Please save it in another location.").arg(saveURL.filename()) );
++ return;
++ }
+ if ( KIO::NetAccess::exists( saveURL, false, widget() ) )
+ {
+ if (KMessageBox::warningContinueCancel( widget(), i18n("A file named \"%1\" already exists. Are you sure you want to overwrite it?").arg(saveURL.filename()), QString::null, i18n("Overwrite")) != KMessageBox::Continue)
diff --git a/kde-base/kpdf/kpdf-3.5.1.ebuild b/kde-base/kpdf/kpdf-3.5.1.ebuild
index 6e00c56ee356..b768efddecb0 100644
--- a/kde-base/kpdf/kpdf-3.5.1.ebuild
+++ b/kde-base/kpdf/kpdf-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.1.ebuild,v 1.1 2006/01/22 22:53:04 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpdf/kpdf-3.5.1.ebuild,v 1.2 2006/01/24 19:52:58 flameeyes Exp $
KMNAME=kdegraphics
MAXKDEVER=$PV
@@ -16,6 +16,8 @@ DEPEND=">=media-libs/freetype-2.0.5
media-libs/t1lib
>=app-text/poppler-bindings-0.3.1"
+PATCHES="${FILESDIR}/${P}-saveas.patch"
+
pkg_setup() {
if ! built_with_use app-text/poppler-bindings qt; then
eerror "This package requires app-text/poppler-bindings compiled with Qt support."