summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-09-10 18:53:52 +0000
committerDan Armak <danarmak@gentoo.org>2002-09-10 18:53:52 +0000
commit26e829101cf0d470755f0f6b0a0246fe704c1636 (patch)
treee5850a3c0d0eee4af678dd866f2ea170f191c885 /kde-base
parentallow kde-base 3.0.3 packages to use kdelibs =3.0.3* and not just ~3.0.3, bec... (diff)
downloadgentoo-2-26e829101cf0d470755f0f6b0a0246fe704c1636.tar.gz
gentoo-2-26e829101cf0d470755f0f6b0a0246fe704c1636.tar.bz2
gentoo-2-26e829101cf0d470755f0f6b0a0246fe704c1636.zip
bugfix and security patch release for kdelibs only
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog10
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.0.3a1
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.3a.ebuild87
3 files changed, 97 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 43f8bacf60e2..c0badff3ce11 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.19 2002/09/06 12:00:35 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.20 2002/09/10 18:53:52 danarmak Exp $
+
+*kdelibs-3.0.3a (10 Sep 2002)
+
+ 10 Sep 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ A bugfix and security patch release. Fixes the cross side scripting
+ vulnerability in khtml. Note: there are no 3.0.3a versions of other packages,
+ only of kdelibs!
*kdelibs-3.0.3-r1 (04 Sep 2002)
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.0.3a b/kde-base/kdelibs/files/digest-kdelibs-3.0.3a
new file mode 100644
index 000000000000..f8e44c40143c
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.0.3a
@@ -0,0 +1 @@
+MD5 02627f595af113f7d544561a7ff6ec85 kdelibs-3.0.3a.tar.bz2 7627677
diff --git a/kde-base/kdelibs/kdelibs-3.0.3a.ebuild b/kde-base/kdelibs/kdelibs-3.0.3a.ebuild
new file mode 100644
index 000000000000..a6c321090af7
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.0.3a.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.3a.ebuild,v 1.1 2002/09/10 18:53:52 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+# Only here, override kde.org's SRC_URI because of the unique 3.0.3a version number
+SRC_URI="mirror://kde/stable/3.0.3/src/$P.tar.bz2"
+
+DESCRIPTION="KDE $PV - base libraries needed by all kde programs"
+KEYWORDS="x86 ppc"
+HOMEPAGE="http//www.kde.org/"
+
+SLOT="3.0"
+LICENSE="GPL-2 LGPL-2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.0.3
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for bug #7359
+
+myconf="$myconf --enable-final --with-distribution=Gentoo"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+[ "$ARCH" != "ppc" ] && \
+ [ "$ARCH" != "sparc" ] && [ "$ARCH" != "sparc64" ] && \
+ myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+ echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+KDEDIRS=$PREFIX
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/65kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/50kdedir-${PV} # number goes up with version upgrade
+
+}
+
+