summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
commit44edf334eaa1d5e86b98c60382f1228598dfdc52 (patch)
tree0ab4b5c8ae2f25c2739d2b8417b92e804b9c0b28 /kde-base
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-44edf334eaa1d5e86b98c60382f1228598dfdc52.tar.gz
gentoo-2-44edf334eaa1d5e86b98c60382f1228598dfdc52.tar.bz2
gentoo-2-44edf334eaa1d5e86b98c60382f1228598dfdc52.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.1.3.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index c16086abdd2c..68298a0d261e 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.12 2008/10/21 09:55:16 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.13 2008/11/09 02:52:26 scarabeus Exp $
+
+*kde-l10n-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +kde-l10n-4.1.3.ebuild:
+ Version bump.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-kde-l10n-4.0.4.ebuild, -kde-l10n-4.0.5.ebuild:
diff --git a/kde-base/kde-l10n/kde-l10n-4.1.3.ebuild b/kde-base/kde-l10n/kde-l10n-4.1.3.ebuild
new file mode 100644
index 000000000000..d42e0f0b3b01
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.1.3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.1.3.ebuild,v 1.1 2008/11/09 02:52:26 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlhandbook"
+
+MY_LANGS="bg ca cs csb da de el en_GB eo es et fi fr fy ga gl hi hu it ja kk km ko
+ku lt lv mk ml nb nds nl nn pa pl pt pt_BR ru sl sr sv ta th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ if ! use htmlhandbook; then
+ sed -i \
+ -e "/docs/ s:^:#DONOTWANT:" \
+ ${DIR}/CMakeLists.txt \
+ || die "Disabling docs for ${lng} failed."
+ fi
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}