summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-11-11 22:45:55 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-11-11 22:45:55 +0000
commit85cac5a1725dcceb878deb2f19fd3c87af23b5fd (patch)
tree4654cf749a8b07b4542e6d2a0dcc45be028d4993 /kde-base
parentVersion bump. (diff)
downloadgentoo-2-85cac5a1725dcceb878deb2f19fd3c87af23b5fd.tar.gz
gentoo-2-85cac5a1725dcceb878deb2f19fd3c87af23b5fd.tar.bz2
gentoo-2-85cac5a1725dcceb878deb2f19fd3c87af23b5fd.zip
Added patch for building correctly on arm, fixes bug 341069
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/rocs/ChangeLog6
-rw-r--r--kde-base/rocs/files/rocs-4.5.3-double.patch125
-rw-r--r--kde-base/rocs/rocs-4.5.3.ebuild4
3 files changed, 133 insertions, 2 deletions
diff --git a/kde-base/rocs/ChangeLog b/kde-base/rocs/ChangeLog
index d3264dc797f0..1f762b5a0ea5 100644
--- a/kde-base/rocs/ChangeLog
+++ b/kde-base/rocs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/rocs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.20 2010/11/03 16:31:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/ChangeLog,v 1.21 2010/11/11 22:45:55 dilfridge Exp $
+
+ 11 Nov 2010; Andreas K. Huettel <dilfridge@gentoo.org> rocs-4.5.3.ebuild,
+ +files/rocs-4.5.3-double.patch:
+ Added patch for building correctly on arm, fixes bug 341069
*rocs-4.5.3 (03 Nov 2010)
diff --git a/kde-base/rocs/files/rocs-4.5.3-double.patch b/kde-base/rocs/files/rocs-4.5.3-double.patch
new file mode 100644
index 000000000000..2e4152776d00
--- /dev/null
+++ b/kde-base/rocs/files/rocs-4.5.3-double.patch
@@ -0,0 +1,125 @@
+diff -ru rocs-4.5.3.orig/doc/rocs/index.docbook rocs-4.5.3/doc/rocs/index.docbook
+--- rocs-4.5.3.orig/doc/rocs/index.docbook 2010-06-08 12:10:55.000000000 +0200
++++ rocs-4.5.3/doc/rocs/index.docbook 2010-11-10 01:21:53.467410347 +0100
+@@ -180,9 +180,9 @@
+ </programlisting>
+ <para>Node Variables:</para>
+ <programlisting>
+- double x
+- double y
+- double width
++ qreal x
++ qreal y
++ qreal width
+ string value
+ string name
+ string color // in HEXA
+@@ -197,7 +197,7 @@
+ string color ( em hexa )
+ string value
+ string name
+- double width
++ qreal width
+ string style ( dot, dash, dash dot, solid )
+
+ node start();
+diff -ru rocs-4.5.3.orig/rocs/src/Core/edge.h rocs-4.5.3/rocs/src/Core/edge.h
+--- rocs-4.5.3.orig/rocs/src/Core/edge.h 2010-06-08 12:10:59.000000000 +0200
++++ rocs-4.5.3/rocs/src/Core/edge.h 2010-11-10 01:23:28.283410355 +0100
+@@ -62,7 +62,7 @@
+ Q_PROPERTY(QString name READ name WRITE setName)
+
+ /*! this property holds the width of the edge */
+- Q_PROPERTY(double width READ width WRITE setWidth)
++ Q_PROPERTY(qreal width READ width WRITE setWidth)
+
+ /*! this property holds the style of the edge */
+ Q_PROPERTY(QString style READ style WRITE setStyle)
+@@ -169,7 +169,7 @@
+ qreal width () const {
+ return _width;
+ }
+- void setWidth(double w) {
++ void setWidth(qreal w) {
+ _width = w;
+ emit changed();
+ }
+@@ -239,7 +239,7 @@
+ bool _showValue;
+
+ QString _style;
+- double _width;
++ qreal _width;
+
+ Graph *_graph;
+ #ifdef USING_QTSCRIPT
+diff -ru rocs-4.5.3.orig/rocs/src/Core/node.h rocs-4.5.3/rocs/src/Core/node.h
+--- rocs-4.5.3.orig/rocs/src/Core/node.h 2010-06-08 12:10:59.000000000 +0200
++++ rocs-4.5.3/rocs/src/Core/node.h 2010-11-10 01:23:32.241410345 +0100
+@@ -85,7 +85,7 @@
+
+ void setX(int x);
+ void setY(int y);
+- void setWidth(double w);
++ void setWidth(qreal w);
+ void setPos(qreal x, qreal y);
+ qreal x() const;
+ qreal y() const;
+diff -ru rocs-4.5.3.orig/rocs/src/GraphicsItem/math_constants.h rocs-4.5.3/rocs/src/GraphicsItem/math_constants.h
+--- rocs-4.5.3.orig/rocs/src/GraphicsItem/math_constants.h 2010-06-08 12:10:59.000000000 +0200
++++ rocs-4.5.3/rocs/src/GraphicsItem/math_constants.h 2010-11-10 01:23:04.291410343 +0100
+@@ -23,10 +23,10 @@
+ #define MATH_CONSTANTS_H
+
+
+-static const double Pi = 3.14159265358979323846264338327950288419717;
++static const qreal Pi = 3.14159265358979323846264338327950288419717;
+
+ /// The value of Pi * 2
+-static const double TwoPi = 2.0 * Pi;
++static const qreal TwoPi = 2.0 * Pi;
+
+ /// The Value of PI / 3
+ static const qreal PI_3 = Pi / 3.0;
+diff -ru rocs-4.5.3.orig/rocs/src/Interface/NodePropertiesWidget.cpp rocs-4.5.3/rocs/src/Interface/NodePropertiesWidget.cpp
+--- rocs-4.5.3.orig/rocs/src/Interface/NodePropertiesWidget.cpp 2010-06-16 14:03:03.000000000 +0200
++++ rocs-4.5.3/rocs/src/Interface/NodePropertiesWidget.cpp 2010-11-10 01:22:25.998410281 +0100
+@@ -43,7 +43,7 @@
+ connect( _value, SIGNAL(textChanged(QString)), _node, SLOT(setValue(QString)));
+ connect( _x, SIGNAL(valueChanged(int)), _node, SLOT(setX(int)));
+ connect( _y, SIGNAL(valueChanged(int)), _node, SLOT(setY(int)));
+- connect( _width, SIGNAL(valueChanged(double)), _node, SLOT(setWidth(double)));
++ connect( _width, SIGNAL(valueChanged(qreal)), _node, SLOT(setWidth(qreal)));
+
+ GraphPropertiesModel *model = new GraphPropertiesModel();
+ model->setDataSource(_node);
+@@ -136,6 +136,6 @@
+ disconnect( _value, SIGNAL(textChanged(QString)), n, SLOT(setValue(QString)));
+ disconnect( _x, SIGNAL(valueChanged(int)), n, SLOT(setX(int)));
+ disconnect( _y, SIGNAL(valueChanged(int)), n, SLOT(setY(int)));
+- disconnect( _width, SIGNAL(valueChanged(double)), n, SLOT(setWidth(double)));
++ disconnect( _width, SIGNAL(valueChanged(qreal)), n, SLOT(setWidth(qreal)));
+
+ }
+\ Kein Zeilenumbruch am Dateiende.
+diff -ru rocs-4.5.3.orig/rocs/src/Interface/edgepropertieswidget.cpp rocs-4.5.3/rocs/src/Interface/edgepropertieswidget.cpp
+--- rocs-4.5.3.orig/rocs/src/Interface/edgepropertieswidget.cpp 2010-06-08 12:10:59.000000000 +0200
++++ rocs-4.5.3/rocs/src/Interface/edgepropertieswidget.cpp 2010-11-10 01:22:33.872410348 +0100
+@@ -52,7 +52,7 @@
+
+ connect(_value, SIGNAL(textChanged(QString)), _edge, SLOT(setValue(QString)));
+ connect(_name, SIGNAL(textChanged(QString)), _edge, SLOT(setName(QString)));
+- connect(_width, SIGNAL(valueChanged(double)), _edge, SLOT(setWidth(double)));
++ connect(_width, SIGNAL(valueChanged(qreal)), _edge, SLOT(setWidth(qreal)));
+ connect(_showName, SIGNAL(toggled(bool)), _edge, SLOT(hideName(bool)));
+ connect(_showValue, SIGNAL(toggled(bool)), _edge, SLOT(hideValue(bool)));
+
+@@ -101,7 +101,7 @@
+
+ disconnect(_value, SIGNAL(textChanged(QString)), _edge, SLOT(setValue(QString)));
+ disconnect(_name, SIGNAL(textChanged(QString)), _edge, SLOT(setName(QString)));
+- disconnect(_width, SIGNAL(valueChanged(double)), _edge, SLOT(setWidth(double)));
++ disconnect(_width, SIGNAL(valueChanged(qreal)), _edge, SLOT(setWidth(qreal)));
+ disconnect(_showName, SIGNAL(toggled(bool)), _edge, SLOT(hideName(bool)));
+ disconnect(_showValue, SIGNAL(toggled(bool)), _edge, SLOT(hideValue(bool)));
+ }
diff --git a/kde-base/rocs/rocs-4.5.3.ebuild b/kde-base/rocs/rocs-4.5.3.ebuild
index 77af73a8441a..2126f56293e5 100644
--- a/kde-base/rocs/rocs-4.5.3.ebuild
+++ b/kde-base/rocs/rocs-4.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.5.3.ebuild,v 1.1 2010/11/03 16:31:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/rocs/rocs-4.5.3.ebuild,v 1.2 2010/11/11 22:45:55 dilfridge Exp $
EAPI="3"
@@ -16,3 +16,5 @@ DEPEND="
>=dev-cpp/eigen-2.0.3:2
"
RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-double.patch" )