summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 19:21:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 19:21:26 +0000
commit8bf1fada43974bccef8c2e9552576406dc3b5d1c (patch)
tree694198cd9a0e600d94da850ac6b5972bf3b95bd5 /kde-base
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-8bf1fada43974bccef8c2e9552576406dc3b5d1c.tar.gz
gentoo-2-8bf1fada43974bccef8c2e9552576406dc3b5d1c.tar.bz2
gentoo-2-8bf1fada43974bccef8c2e9552576406dc3b5d1c.zip
Bump shiny new KDE 4.2.0
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.2.0.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 2e7e96d97f95..a4477bfb62c8 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.16 2009/01/14 14:33:10 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.17 2009/01/27 19:21:26 alexxy Exp $
+
+*kde-l10n-4.2.0 (27 Jan 2009)
+
+ 27 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +kde-l10n-4.2.0.ebuild:
+ Bump KDE-4.2.0
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> -kde-l10n-4.1.2.ebuild,
-kde-l10n-4.1.3.ebuild:
diff --git a/kde-base/kde-l10n/kde-l10n-4.2.0.ebuild b/kde-base/kde-l10n/kde-l10n-4.2.0.ebuild
new file mode 100644
index 000000000000..2268f3023061
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.2.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.2.0.ebuild,v 1.1 2009/01/27 19:21:26 alexxy Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlhandbook"
+
+MY_LANGS="ar bg bn_IN ca cs csb da de el en_GB es et eu fi fr ga gl gu he hi hu
+ is it ja kk km kn ko ku lt lv mai mk ml mr nb nds nl nn pa pl pt pt_BR
+ ro ru sl sr sv tg th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ if ! use htmlhandbook; then
+ sed -i \
+ -e "/docs/ s:^:#DONOTWANT:" \
+ ${DIR}/CMakeLists.txt \
+ || die "Disabling docs for ${lng} failed."
+ fi
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}