summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:19 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:19 +0000
commit92440ff3d57422e456e4409705f5cba8d41222ba (patch)
treedc70015d87591e01740b38b3ac37b8fc6402166e /kde-base
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-92440ff3d57422e456e4409705f5cba8d41222ba.tar.gz
gentoo-2-92440ff3d57422e456e4409705f5cba8d41222ba.tar.bz2
gentoo-2-92440ff3d57422e456e4409705f5cba8d41222ba.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/systemsettings/ChangeLog9
-rw-r--r--kde-base/systemsettings/systemsettings-4.0.3.ebuild61
2 files changed, 69 insertions, 1 deletions
diff --git a/kde-base/systemsettings/ChangeLog b/kde-base/systemsettings/ChangeLog
index be8697db1b1b..c1c815f90f57 100644
--- a/kde-base/systemsettings/ChangeLog
+++ b/kde-base/systemsettings/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/systemsettings
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.7 2008/03/20 18:28:25 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.8 2008/04/03 21:49:19 philantrop Exp $
+
+*systemsettings-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +systemsettings-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/systemsettings-4.0.1-opengl.patch, -systemsettings-4.0.1.ebuild:
diff --git a/kde-base/systemsettings/systemsettings-4.0.3.ebuild b/kde-base/systemsettings/systemsettings-4.0.3.ebuild
new file mode 100644
index 000000000000..4d206c7ffce5
--- /dev/null
+++ b/kde-base/systemsettings/systemsettings-4.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.0.3.ebuild,v 1.1 2008/04/03 21:49:19 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="System settings utility"
+IUSE="debug htmlhandbook opengl +usb xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMONDEPEND="
+ >=app-misc/strigi-0.5.7
+ >=dev-libs/glib-2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ usb? ( >=dev-libs/libusb-0.1.10a )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/xextproto
+ x11-proto/kbproto
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}
+ || ( x11-misc/xkeyboard-config
+ x11-misc/xkbdata )
+ x11-apps/setxkbmap"
+
+KMEXTRA="kcontrol/"
+
+KMEXTRACTONLY="krunner/org.kde.krunner.App.xml
+ krunner/org.kde.screensaver.xml
+ kwin/
+ libs/
+ plasma/"
+
+PATCHES="${FILESDIR}/${PN}-4.0.2-opengl.patch"
+
+# FIXME: is have_openglxvisual found without screensaver
+src_compile() {
+ # Old keyboard-detection code is unmaintained,
+ # so we force the new stuff, using libxklavier.
+ mycmakeargs="${mycmakeargs}
+ -DUSE_XKLAVIER=ON -DWITH_LibXKlavier=ON
+ -DWITH_GLIB2=ON -DWITH_GObject=ON
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with usb USB)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}