summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-05-07 16:07:55 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-05-07 16:07:55 +0000
commitbff06fe5da01e77967b36b93ebdd3ac32a5d9893 (patch)
tree6d3493a85a0622cbc840cdb83905100bcfb21882 /kde-base
parentRevbump to migrate to split-ant; improve style; add examples flag. Restrict t... (diff)
downloadgentoo-2-bff06fe5da01e77967b36b93ebdd3ac32a5d9893.tar.gz
gentoo-2-bff06fe5da01e77967b36b93ebdd3ac32a5d9893.tar.bz2
gentoo-2-bff06fe5da01e77967b36b93ebdd3ac32a5d9893.zip
Dropped the PDEPEND on net-im/kopete-otr because of keywording issues and added a post-install message instead. Re-added ~alpha. Invalidates bug 176926. Added upstream patch for cryptography, fixes bug 177319.
(Portage version: 2.1.2.6)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdenetwork/ChangeLog8
-rw-r--r--kde-base/kdenetwork/files/kopete-3.5.6-cryptobug.patch14
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild20
3 files changed, 33 insertions, 9 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index cbbdae2e2322..3a2e7bbed195 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdenetwork
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.259 2007/05/05 05:16:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.260 2007/05/07 16:07:55 philantrop Exp $
+
+ 07 May 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kopete-3.5.6-cryptobug.patch, kdenetwork-3.5.6-r1.ebuild:
+ Dropped the PDEPEND on net-im/kopete-otr because of keywording issues and
+ added a post-install message instead. Re-added ~alpha. Invalidates bug
+ 176926. Added upstream patch for cryptography, fixes bug 177319.
05 May 2007; Jeroen Roovers <jer@gentoo.org> kdenetwork-3.5.6-r1.ebuild:
Marked ~hppa (bug #176926).
diff --git a/kde-base/kdenetwork/files/kopete-3.5.6-cryptobug.patch b/kde-base/kdenetwork/files/kopete-3.5.6-cryptobug.patch
new file mode 100644
index 000000000000..331e567ce44e
--- /dev/null
+++ b/kde-base/kdenetwork/files/kopete-3.5.6-cryptobug.patch
@@ -0,0 +1,14 @@
+diff -Nru kdenetwork-3.5.6.orig/kopete/plugins/cryptography/cryptographyplugin.cpp kdenetwork-3.5.6/kopete/plugins/cryptography/cryptographyplugin.cpp
+--- kdenetwork-3.5.6.orig/kopete/plugins/cryptography/cryptographyplugin.cpp 2007-05-06 14:40:56.000000000 +0200
++++ kdenetwork-3.5.6/kopete/plugins/cryptography/cryptographyplugin.cpp 2007-05-06 14:42:06.000000000 +0200
+@@ -58,9 +58,7 @@
+ if( !pluginStatic_ )
+ pluginStatic_=this;
+
+- m_inboundHandler = 0;
+-/* m_inboundHandler = new Kopete::SimpleMessageHandlerFactory( Kopete::Message::Inbound,
+- Kopete::MessageHandlerFactory::InStageToSent, this, SLOT( slotIncomingMessage( Kopete::Message& ) ) );*/
++ m_inboundHandler = new Kopete::SimpleMessageHandlerFactory( Kopete::Message::Inbound, Kopete::MessageHandlerFactory::InStageToSent, this, SLOT( slotIncomingMessage( Kopete::Message& ) ) );
+ connect( Kopete::ChatSessionManager::self(),
+ SIGNAL( aboutToSend( Kopete::Message & ) ),
+ SLOT( slotOutgoingMessage( Kopete::Message & ) ) );
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
index 5b05cc8f70f3..cf9e21ac103e 100644
--- a/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
+++ b/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild,v 1.3 2007/05/05 05:16:26 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.6-r1.ebuild,v 1.4 2007/05/07 16:07:55 philantrop Exp $
inherit kde-dist eutils flag-o-matic
DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="crypt jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
SRC_URI="${SRC_URI}
mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
@@ -36,8 +36,7 @@ RDEPEND="${BOTH_DEPEND}
dev-lang/perl
ssl? ( dev-perl/IO-Socket-SSL
app-crypt/qca-tls )
- net-dialup/ppp
- crypt? ( app-crypt/gnupg )"
+ net-dialup/ppp"
DEPEND="${BOTH_DEPEND}
kernel_linux? ( virtual/os-headers )
@@ -46,10 +45,9 @@ DEPEND="${BOTH_DEPEND}
kernel_linux? ( x11-libs/libXv )
x11-proto/scrnsaverproto"
-PDEPEND="crypt? ( net-im/kopete-otr )"
-
PATCHES="${FILESDIR}/kopete-3.5.5-icqfix.patch
- ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+ ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch
+ ${FILESDIR}/kopete-3.5.6-cryptobug.patch"
pkg_setup() {
if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
@@ -88,3 +86,9 @@ src_install() {
newconfd "${WORKDIR}/patches/lisa.conf" lisa
newconfd "${WORKDIR}/patches/reslisa.conf" reslisa
}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "If you would like to use Off-The-Record encryption with Kopete, emerge net-im/kopete-otr."
+}