summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-02 19:51:08 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-02 19:51:08 +0000
commit3597c3262faccf49ab1b45af0e4561ff66dd6571 (patch)
tree281f5bd44bd2e2748d53f8bfa6e32d5a242423b2 /kde-misc/kio-sword
parentold (diff)
downloadgentoo-2-3597c3262faccf49ab1b45af0e4561ff66dd6571.tar.gz
gentoo-2-3597c3262faccf49ab1b45af0e4561ff66dd6571.tar.bz2
gentoo-2-3597c3262faccf49ab1b45af0e4561ff66dd6571.zip
Bump to 0.3, fixes #251585, patch from Francisco Jose Canizares Santofimia
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/kio-sword')
-rw-r--r--kde-misc/kio-sword/ChangeLog10
-rw-r--r--kde-misc/kio-sword/files/kio_sword-build_fixes.patch68
-rw-r--r--kde-misc/kio-sword/kio-sword-0.3.ebuild33
3 files changed, 109 insertions, 2 deletions
diff --git a/kde-misc/kio-sword/ChangeLog b/kde-misc/kio-sword/ChangeLog
index 893f11d5966a..e821f8d4b511 100644
--- a/kde-misc/kio-sword/ChangeLog
+++ b/kde-misc/kio-sword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-misc/kio-sword
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-sword/ChangeLog,v 1.6 2008/12/18 14:52:40 beandog Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-sword/ChangeLog,v 1.7 2009/03/02 19:51:07 patrick Exp $
+
+*kio-sword-0.3 (02 Mar 2009)
+
+ 02 Mar 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/kio_sword-build_fixes.patch, +kio-sword-0.3.ebuild:
+ Bump to 0.3, fixes #251585, patch from Francisco Jose Canizares Santofimia
18 Dec 2008; Steve Dibb <beandog@gentoo.org> kio-sword-0.2.ebuild:
Fix sword dep, bug 233257
diff --git a/kde-misc/kio-sword/files/kio_sword-build_fixes.patch b/kde-misc/kio-sword/files/kio_sword-build_fixes.patch
new file mode 100644
index 000000000000..10104682ae0e
--- /dev/null
+++ b/kde-misc/kio-sword/files/kio_sword-build_fixes.patch
@@ -0,0 +1,68 @@
+--- configure 2006-12-16 11:11:58.000000000 -0500
++++ configure.new 2007-01-12 09:49:21.000000000 -0500
+@@ -32379,7 +32379,7 @@
+ echo "$as_me:$LINENO: checking for Sword library files" >&5
+ echo $ECHO_N "checking for Sword library files... $ECHO_C" >&6
+
+-ac_sword_library_dirs="$ac_sword_dir/lib /usr/lib /usr/lib/sword /usr/local/lib /usr/local/lib/sword /usr/local/sword/lib"
++ac_sword_library_dirs="$ac_sword_dir/lib /usr/lib /usr/lib64 /usr/lib/sword /usr/local/lib /usr/local/lib/sword /usr/local/sword/lib"
+
+ if test "x$ac_static_sword" = "xYES"; then
+ SEARCH_LIBS="libsword.a";
+@@ -32518,7 +32518,7 @@
+ using namespace sword;
+ #endif
+
+-int main(int argc, char* argv) {
++int main(int argc, char* argv[]) {
+ std::cout << SWVersion::currentVersion << std::endl;
+ return 0;
+ }
+--- configure.in.in 2007-01-12 09:52:04.000000000 -0500
++++ configure.in.in.new 2007-01-12 09:52:27.000000000 -0500
+@@ -4,6 +4,6 @@
+ AC_C_BIGENDIAN
+ AC_CHECK_KDEMAXPATHLEN
+
+-AC_CHECK_SWORD(1.5.7, [$ac_use_static])
++AC_CHECK_SWORD(1.5.8, [$ac_use_static])
+
+ AC_CONFIG_FILES([ src/data/kio_sword.css ])
+--- src/renderer.cpp 2006-12-16 11:11:32.000000000 -0500
++++ src/renderer.cpp 2007-01-12 09:24:57.000000000 -0500
+@@ -150,7 +150,7 @@
+ else
+ setGlobalOption("Variants", "Primary Readings");
+
+- LocaleMgr::systemLocaleMgr.setDefaultLocaleName(options.locale());
++ LocaleMgr::getSystemLocaleMgr()->setDefaultLocaleName(options.locale());
+ }
+
+ /** Return an HTML hyperlinked list of all modules,
+@@ -471,7 +471,7 @@
+ return;
+
+ // FIXME - why do I need this call to setLocale()?
+- vk->setLocale(LocaleMgr::systemLocaleMgr.getDefaultLocaleName());
++ vk->setLocale(LocaleMgr::getSystemLocaleMgr()->getDefaultLocaleName());
+
+ modtextdir = textDirection(module);
+
+@@ -835,7 +835,7 @@
+
+ if (!vk)
+ return output;
+- vk->setLocale(LocaleMgr::systemLocaleMgr.getDefaultLocaleName());
++ vk->setLocale(LocaleMgr::getSystemLocaleMgr()->getDefaultLocaleName());
+
+ module->setSkipConsecutiveLinks(true);
+ vk->AutoNormalize(1);
+@@ -1015,7 +1015,7 @@
+
+ QStringList Renderer::availableLocales()
+ {
+- list<SWBuf> locales = LocaleMgr::systemLocaleMgr.getAvailableLocales();
++ list<SWBuf> locales = LocaleMgr::getSystemLocaleMgr()->getAvailableLocales();
+ list<SWBuf>::const_iterator it;
+ list<SWBuf>::const_iterator it_end = locales.end();
+ QStringList output;
diff --git a/kde-misc/kio-sword/kio-sword-0.3.ebuild b/kde-misc/kio-sword/kio-sword-0.3.ebuild
new file mode 100644
index 000000000000..2fac341b52a2
--- /dev/null
+++ b/kde-misc/kio-sword/kio-sword-0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kio-sword/kio-sword-0.3.ebuild,v 1.1 2009/03/02 19:51:07 patrick Exp $
+
+inherit kde eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="a nice kio handler to sword"
+HOMEPAGE="http://lukeplant.me.uk/kio-sword/"
+SRC_URI="mirror://sourceforge/kio-sword/kio_sword-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-text/sword-1.5.8"
+
+S="${WORKDIR}/kio_sword-${PV}"
+need-kde 3.3
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/kio_sword-build_fixes.patch
+}
+
+pkg_postinst() {
+ elog "It is recommended that you have modules installed for sword."
+ elog "Gentoo provides the \"sword-modules\" package for convenience:"
+ elog "\temerge sword-modules"
+}
+