summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-08 12:18:53 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-08 12:18:53 +0000
commitb30ac18824a97c5f9f7fe382f878f7b1e601735c (patch)
treeae94b460ceeb66de9500b3693b2d6700ec1cc68a /kde-misc/plasma-applet-daisy
parentx86 stable wrt bug #400065 (diff)
downloadgentoo-2-b30ac18824a97c5f9f7fe382f878f7b1e601735c.tar.gz
gentoo-2-b30ac18824a97c5f9f7fe382f878f7b1e601735c.tar.bz2
gentoo-2-b30ac18824a97c5f9f7fe382f878f7b1e601735c.zip
Revision bump adds an upstream patch from a fork to build with kde 4.8 spotted by kensington <gentoo@scribeofthenile.com>, bug #405857.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc/plasma-applet-daisy')
-rw-r--r--kde-misc/plasma-applet-daisy/ChangeLog12
-rw-r--r--kde-misc/plasma-applet-daisy/files/plasma-applet-daisy-0.0.4.25-kde48.patch107
-rw-r--r--kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25-r1.ebuild21
-rw-r--r--kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild4
4 files changed, 140 insertions, 4 deletions
diff --git a/kde-misc/plasma-applet-daisy/ChangeLog b/kde-misc/plasma-applet-daisy/ChangeLog
index 7b0fc1de0d81..8cc178c6aa2e 100644
--- a/kde-misc/plasma-applet-daisy/ChangeLog
+++ b/kde-misc/plasma-applet-daisy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-misc/plasma-applet-daisy
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/plasma-applet-daisy/ChangeLog,v 1.6 2011/10/29 00:22:20 abcd Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/plasma-applet-daisy/ChangeLog,v 1.7 2012/03/08 12:18:53 johu Exp $
+
+*plasma-applet-daisy-0.0.4.25-r1 (08 Mar 2012)
+
+ 08 Mar 2012; Johannes Huber <johu@gentoo.org>
+ +files/plasma-applet-daisy-0.0.4.25-kde48.patch,
+ +plasma-applet-daisy-0.0.4.25-r1.ebuild, plasma-applet-daisy-0.0.4.25.ebuild:
+ Revision bump adds an upstream patch from a fork to build with kde 4.8 spotted
+ by kensington <gentoo@scribeofthenile.com>, bug #405857.
29 Oct 2011; Jonathan Callen <abcd@gentoo.org>
plasma-applet-daisy-0.0.4.25.ebuild:
diff --git a/kde-misc/plasma-applet-daisy/files/plasma-applet-daisy-0.0.4.25-kde48.patch b/kde-misc/plasma-applet-daisy/files/plasma-applet-daisy-0.0.4.25-kde48.patch
new file mode 100644
index 000000000000..186ec02adaae
--- /dev/null
+++ b/kde-misc/plasma-applet-daisy/files/plasma-applet-daisy-0.0.4.25-kde48.patch
@@ -0,0 +1,107 @@
+--- applet/src/daisy.h
++++ applet/src/daisy.h
+@@ -102,8 +102,8 @@
+ #include <taskmanager/taskitem.h>
+ #include <taskmanager/groupmanager.h>
+ #include <taskmanager/startup.h>
+-using TaskManager::TaskPtr;
+-using TaskManager::StartupPtr;
++using TaskManager::Task;
++using TaskManager::Startup;
+ using TaskManager::GroupManager;
+
+
+@@ -337,7 +337,7 @@
+ bool checkLock();
+
+ void checkAttention( KWindowInfo taskInfo, QString widclass_tmp );
+- void createTaskThumbnail( TaskPtr task_tmp, int j );
++ void createTaskThumbnail( Task* task_tmp, int j );
+ void scrollTasks(int delta);
+
+
+@@ -418,7 +418,7 @@
+ QSizeF m_hoversz;
+
+
+- TaskPtr m_task;
++ Task* m_task;
+ GroupManager *m_groupManager;
+
+
+@@ -512,8 +512,8 @@
+ private slots:
+
+
+- void startupAdded(StartupPtr startupItem);
+- void startupRemoved(StartupPtr startupItem);
++ void startupAdded(Startup* startupItem);
++ void startupRemoved(Startup* startupItem);
+
+
+ void windowAdded(WId id);
+--- applet/src/daisyTasks.cpp
++++ applet/src/daisyTasks.cpp
+@@ -159,7 +159,7 @@
+ //-----------------------------------------------------------------------------
+ // Startup added
+ //FIXME
+-void daisy::startupAdded(StartupPtr startupItem)
++void daisy::startupAdded(Startup* startupItem)
+ {
+
+ m_startingwindow = -1;
+@@ -195,7 +195,7 @@
+ //-----------------------------------------------------------------------------
+ // Startup removed
+ //FIXME
+-void daisy::startupRemoved(StartupPtr startupItem)
++void daisy::startupRemoved(Startup* startupItem)
+ {
+
+ Q_UNUSED(startupItem);
+@@ -218,7 +218,7 @@
+
+ KWindowInfo taskInfo = KWindowSystem::windowInfo( id, NET::WMName | NET::WMVisibleName | NET::WMVisibleIconName | NET::WMState | NET::XAWMState | NET::WMDesktop, NET::WM2WindowClass );
+
+- TaskPtr task_tmp = TaskManager::TaskManager::self()->findTask( id );
++ Task* task_tmp = TaskManager::TaskManager::self()->findTask( id );
+
+
+ if ( m_alias.indexOf( taskInfo.windowClassName() ) != -1 || m_alias.indexOf( QString(taskInfo.windowClassClass().toLower()) ) != -1 )
+@@ -372,7 +372,7 @@
+ KWindowInfo taskInfo = KWindowSystem::windowInfo( *it, NET::WMName | NET::WMVisibleName | NET::WMVisibleIconName | NET::WMState | NET::XAWMState | NET::WMDesktop | NET::WMWindowType, NET::WM2WindowClass );
+
+
+- TaskPtr task_tmp = TaskManager::TaskManager::self()->findTask( *it );
++ Task* task_tmp = TaskManager::TaskManager::self()->findTask( *it );
+ if ( task_tmp && *it == KWindowSystem::activeWindow() )
+ {m_focusedWindow = *it;}
+
+@@ -478,7 +478,7 @@
+ //-----------------------------------------------------------------------------
+ // Create task thumbnail
+ //FIXME
+-void daisy::createTaskThumbnail( TaskPtr task_tmp, int j )
++void daisy::createTaskThumbnail( Task* task_tmp, int j )
+ {
+ QIcon thumbnail;
+ //thumbnail = QIcon( QPixmap::grabWindow ( task_tmp->win(), 0, 0, -1, -1 ) );//This would suck
+@@ -714,7 +714,7 @@
+ KWindowInfo taskInfo = KWindowSystem::windowInfo( m_focusedWindow, NET::WMState, NET::WM2WindowClass );
+ for (it = taskDict.begin(); it != taskDict.end(); ++it )
+ {
+- TaskPtr task_tmp = TaskManager::TaskManager::self()->findTask( *it );
++ Task* task_tmp = TaskManager::TaskManager::self()->findTask( *it );
+ if ( task_tmp ){real_taskDict << *it;}
+ }
+ if (real_taskDict.size() > 0)
+@@ -768,7 +768,7 @@
+ void daisy::delayTaskIcoChange(void)
+ {
+ m_uti_tmr->stop();
+- TaskPtr task_tmp = TaskManager::TaskManager::self()->findTask( m_toupwid );
++ Task* task_tmp = TaskManager::TaskManager::self()->findTask( m_toupwid );
+ if ( task_tmp )
+ {
+ // QIcon thumbnail;
diff --git a/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25-r1.ebuild b/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25-r1.ebuild
new file mode 100644
index 000000000000..24d7ec7a9aa9
--- /dev/null
+++ b/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25-r1.ebuild,v 1.1 2012/03/08 12:18:53 johu Exp $
+
+EAPI=4
+
+KDE_MINIMAL="4.8"
+inherit kde4-base
+
+DESCRIPTION="Simple application launcher for KDE 4's plasma desktop"
+HOMEPAGE="http://cdlszm.org/"
+SRC_URI="http://cdlszm.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+PATCHES=(
+ "${FILESDIR}/${P}-kde48.patch"
+)
diff --git a/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild b/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild
index 4c196bae8378..a1c48f21d31a 100644
--- a/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild
+++ b/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild,v 1.3 2011/10/29 00:22:20 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/plasma-applet-daisy/plasma-applet-daisy-0.0.4.25.ebuild,v 1.4 2012/03/08 12:18:53 johu Exp $
EAPI=4