summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-07-11 15:17:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-07-11 15:17:05 +0000
commit13a08e91401a3874911d692090990d5ff60c5204 (patch)
tree75be648e804e7486452c7d31d3a52a6cfbfeeb68 /kde-misc/tellico
parentFix --disable-ipv6 (bug #456788). (diff)
downloadgentoo-2-13a08e91401a3874911d692090990d5ff60c5204.tar.gz
gentoo-2-13a08e91401a3874911d692090990d5ff60c5204.tar.bz2
gentoo-2-13a08e91401a3874911d692090990d5ff60c5204.zip
Version bump wrt #476544
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'kde-misc/tellico')
-rw-r--r--kde-misc/tellico/ChangeLog7
-rw-r--r--kde-misc/tellico/tellico-2.3.8.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index e26afb5bd4e9..14c1505e3feb 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.121 2013/03/17 16:12:04 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.122 2013/07/11 15:17:05 mrueg Exp $
+
+*tellico-2.3.8 (11 Jul 2013)
+
+ 11 Jul 2013; Manuel Rüger <mrueg@gentoo.org> +tellico-2.3.8.ebuild:
+ Version bump wrt #476544
17 Mar 2013; Andreas K. Huettel <dilfridge@gentoo.org> tellico-2.3.7.ebuild:
poppler subslot dependencies
diff --git a/kde-misc/tellico/tellico-2.3.8.ebuild b/kde-misc/tellico/tellico-2.3.8.ebuild
new file mode 100644
index 000000000000..4fd78ac1e6e5
--- /dev/null
+++ b/kde-misc/tellico/tellico-2.3.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.3.8.ebuild,v 1.1 2013/07/11 15:17:05 mrueg Exp $
+
+EAPI=5
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr ga gl hu
+ia it ja kk lt mr ms nb nds nl nn pl pt pt_BR ro ru sk sl sv tr ug uk zh_CN
+zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A collection manager for the KDE environment"
+HOMEPAGE="http://tellico-project.org/"
+SRC_URI="http://tellico-project.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="addressbook cddb debug pdf scanner semantic-desktop taglib v4l xmp yaz"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qjson
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ media-libs/qimageblitz
+ dev-qt/qtdbus:4
+ addressbook? ( $(add_kdebase_dep kdepimlibs) )
+ cddb? ( $(add_kdebase_dep libkcddb) )
+ pdf? ( app-text/poppler:=[qt4] )
+ scanner? ( $(add_kdebase_dep libksane) )
+ semantic-desktop? ( dev-libs/soprano[raptor,redland] )
+ taglib? ( >=media-libs/taglib-1.5 )
+ v4l? ( >=media-libs/libv4l-0.8.3 )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2 )
+"
+RDEPEND="${DEPEND}"
+
+# tests need network access and well-defined server responses
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ # KDE_LINGUAS is also used to install appropriate handbooks
+ # since there is no en_US 'translation', it cannot be added
+ # hence making this impossible to install
+ mv doc/en_US doc/en || die "doc move failed"
+ sed -i -e 's/en_US/en/' doc/CMakeLists.txt || die "sed failed"
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable v4l WEBCAM)
+ $(cmake-utils_use_with xmp Exempi)
+ $(cmake-utils_use_with scanner KSane)
+ $(cmake-utils_use_with cddb Kcddb)
+ $(cmake-utils_use_with addressbook KdepimLibs)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_with yaz)
+ )
+
+ kde4-base_src_configure
+}