summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-06-13 21:27:42 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-06-13 21:27:42 +0000
commit23a3320433174ac541fd75d306971495c581e357 (patch)
treea21ae4453c4882e0159feff8c2bb1a006e9b84ed /kde-misc
parentVersion bump, portability fix in init script, thanks Sławomir Nizio. (diff)
downloadgentoo-2-23a3320433174ac541fd75d306971495c581e357.tar.gz
gentoo-2-23a3320433174ac541fd75d306971495c581e357.tar.bz2
gentoo-2-23a3320433174ac541fd75d306971495c581e357.zip
Version bump for new UFW
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kcm-ufw/ChangeLog7
-rw-r--r--kde-misc/kcm-ufw/kcm-ufw-0.4.3.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-misc/kcm-ufw/ChangeLog b/kde-misc/kcm-ufw/ChangeLog
index 1d0507cfeb0e..5eac6fccd40f 100644
--- a/kde-misc/kcm-ufw/ChangeLog
+++ b/kde-misc/kcm-ufw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kcm-ufw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm-ufw/ChangeLog,v 1.7 2012/04/19 19:24:08 thev00d00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm-ufw/ChangeLog,v 1.8 2012/06/13 21:27:42 thev00d00 Exp $
+
+*kcm-ufw-0.4.3 (13 Jun 2012)
+
+ 13 Jun 2012; Ian Whyman <thev00d00@gentoo.org> +kcm-ufw-0.4.3.ebuild:
+ Version bump for new UFW
19 Apr 2012; Ian Whyman <thev00d00@gentoo.org> +kcm-ufw-0.4.1-r3.ebuild,
-kcm-ufw-0.4.2.ebuild:
diff --git a/kde-misc/kcm-ufw/kcm-ufw-0.4.3.ebuild b/kde-misc/kcm-ufw/kcm-ufw-0.4.3.ebuild
new file mode 100644
index 000000000000..58d05bd16da9
--- /dev/null
+++ b/kde-misc/kcm-ufw/kcm-ufw-0.4.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kcm-ufw/kcm-ufw-0.4.3.ebuild,v 1.1 2012/06/13 21:27:42 thev00d00 Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+inherit python kde4-base
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="KCM module to control the Uncomplicated Firewall"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=137789"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug"
+
+LINGUAS="en es fr lt"
+for lingua in ${LINGUAS}; do
+ IUSE+=" linguas_${lingua}"
+done
+
+COMMON_DEPEND="
+ <net-firewall/ufw-0.31
+ sys-auth/polkit-kde-agent
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/automoc
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdebase_dep kcmshell)
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ LANGS=""
+ for x in ${LINGUAS}; do
+ use linguas_${x} && LANGS+="${x};"
+ done
+ MYCMAKEARGS="-DUFW_TRANSLATIONS=${LANGS}"
+ kde4-base_src_configure
+}