summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-16 11:57:26 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-16 11:57:26 +0000
commit5c0c01e042443afc2dc49ef187db8a11f0312ff1 (patch)
treeb04143a5238dbce3e0f5f233926ca2cf11fa7b3e /kde-misc
parentKeyword ~ppc ~ppc64 (diff)
downloadgentoo-2-5c0c01e042443afc2dc49ef187db8a11f0312ff1.tar.gz
gentoo-2-5c0c01e042443afc2dc49ef187db8a11f0312ff1.tar.bz2
gentoo-2-5c0c01e042443afc2dc49ef187db8a11f0312ff1.zip
Version bump.
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/tellico/ChangeLog8
-rw-r--r--kde-misc/tellico/tellico-2.3.6.ebuild58
2 files changed, 64 insertions, 2 deletions
diff --git a/kde-misc/tellico/ChangeLog b/kde-misc/tellico/ChangeLog
index c06142f5e576..1f81eaec6028 100644
--- a/kde-misc/tellico/ChangeLog
+++ b/kde-misc/tellico/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/tellico
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.111 2012/04/18 22:09:49 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/ChangeLog,v 1.112 2012/07/16 11:57:26 johu Exp $
+
+*tellico-2.3.6 (16 Jul 2012)
+
+ 16 Jul 2012; Johannes Huber <johu@gentoo.org> +tellico-2.3.6.ebuild:
+ Version bump.
18 Apr 2012; Johannes Huber <johu@gentoo.org>
-files/tellico-2.3.4-kdepimlibs.patch, -tellico-2.3.4.ebuild:
@@ -459,4 +464,3 @@
30 Oct 2004; Carsten Lohrke <carlo@gentoo.org> +metadata.xml,
+tellico-0.12.ebuild:
tellico, previously known as app-misc/bookcase
-
diff --git a/kde-misc/tellico/tellico-2.3.6.ebuild b/kde-misc/tellico/tellico-2.3.6.ebuild
new file mode 100644
index 000000000000..14de2c795fd9
--- /dev/null
+++ b/kde-misc/tellico/tellico-2.3.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/tellico/tellico-2.3.6.ebuild,v 1.1 2012/07/16 11:57:26 johu Exp $
+
+EAPI=4
+
+KDE_LINGUAS="bg bs ca ca@valencia cs da de el en_GB eo es et eu fi fr ga gl hu
+ia it ja kk lt ms nb nds nl nn pl pt pt_BR ro ru sk sv tr ug uk zh_CN zh_TW"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A collection manager for the KDE environment"
+HOMEPAGE="http://tellico-project.org/"
+SRC_URI="http://tellico-project.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="addressbook cddb debug pdf scanner semantic-desktop taglib v4l xmp yaz"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/qjson
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ media-libs/qimageblitz
+ x11-libs/qt-dbus:4
+ addressbook? ( $(add_kdebase_dep kdepimlibs) )
+ cddb? ( $(add_kdebase_dep libkcddb) )
+ pdf? ( >=app-text/poppler-0.12.3-r3[qt4] )
+ scanner? ( $(add_kdebase_dep libksane) )
+ semantic-desktop? ( dev-libs/soprano[raptor,redland] )
+ taglib? ( >=media-libs/taglib-1.5 )
+ v4l? ( >=media-libs/libv4l-0.8.3 )
+ xmp? ( >=media-libs/exempi-2 )
+ yaz? ( >=dev-libs/yaz-2 )
+"
+RDEPEND="${DEPEND}"
+
+# tests need network access and well-defined server responses
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_enable v4l WEBCAM)
+ $(cmake-utils_use_with xmp Exempi)
+ $(cmake-utils_use_with scanner KSane)
+ $(cmake-utils_use_with cddb Kcddb)
+ $(cmake-utils_use_with addressbook KdepimLibs)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with taglib)
+ $(cmake-utils_use_with yaz)
+ )
+
+ kde4-base_src_configure
+}