summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-10-15 18:30:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-10-15 18:30:03 +0000
commitc765136b560f6dde2ba75070222505660611f99d (patch)
treeac9e096c999a04eb28354096772a00677955e5d7 /lxde-base/lxde-common
parentNew initd file. Thanks to Simone Scanzoni <nonno.cicala@libero.it>. Fixes bug... (diff)
downloadgentoo-2-c765136b560f6dde2ba75070222505660611f99d.tar.gz
gentoo-2-c765136b560f6dde2ba75070222505660611f99d.tar.bz2
gentoo-2-c765136b560f6dde2ba75070222505660611f99d.zip
Add the executable bit to the lxde session file. Bug #437010. Move it directly to stable so everyone can benefit from it
(Portage version: 2.1.11.26/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'lxde-base/lxde-common')
-rw-r--r--lxde-base/lxde-common/ChangeLog9
-rw-r--r--lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/lxde-base/lxde-common/ChangeLog b/lxde-base/lxde-common/ChangeLog
index 8dd1b13b63e8..d8d6397522f0 100644
--- a/lxde-base/lxde-common/ChangeLog
+++ b/lxde-base/lxde-common/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for lxde-base/lxde-common
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.37 2012/08/25 00:01:31 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/ChangeLog,v 1.38 2012/10/15 18:30:03 hwoarang Exp $
+
+*lxde-common-0.5.5-r3 (15 Oct 2012)
+
+ 15 Oct 2012; Markos Chandras <hwoarang@gentoo.org>
+ +lxde-common-0.5.5-r3.ebuild:
+ Add the executable bit to the lxde session file. Bug #437010. Move it directly
+ to stable so everyone can benefit from it
25 Aug 2012; Markos Chandras <hwoarang@gentoo.org> -lxde-common-0.4.2.ebuild,
-lxde-common-0.5.0-r1.ebuild, -lxde-common-0.5.0-r2.ebuild,
diff --git a/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
new file mode 100644
index 000000000000..b15dd9828390
--- /dev/null
+++ b/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxde-common/lxde-common-0.5.5-r3.ebuild,v 1.1 2012/10/15 18:30:03 hwoarang Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Session default configuration files and nuoveXT2 iconset"
+HOMEPAGE="http://lxde.sf.net/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+PDEPEND="lxde-base/lxde-icon-theme"
+
+src_prepare() {
+ #bug 380043
+ epatch "${FILESDIR}"/${P}-logout.patch
+
+ # Rerun autotools
+ einfo "Regenerating autotools files..."
+ eautoreconf
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ # install session file
+ insinto /etc/X11/Sessions/
+ doins ${FILESDIR}/lxde
+ fperms 755 /etc/X11/Sessions/lxde
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ elog "${P} has renamed the configuration file name to"
+ elog "/etc/xdg/lxsession/LXDE/desktop.conf"
+ elog "Keep in mind you have to migrate your custom settings"
+ elog "from /etc/xdg/lxsession/LXDE/config"
+}