summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-07 09:58:02 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-07 09:58:02 +0000
commitd896f017bafe88ef3490ec9a8eb9f286b8328903 (patch)
treeb1b13056f7931e5c45016938c4b49064aa454595 /lxde-base
parentremove old (diff)
downloadgentoo-2-d896f017bafe88ef3490ec9a8eb9f286b8328903.tar.gz
gentoo-2-d896f017bafe88ef3490ec9a8eb9f286b8328903.tar.bz2
gentoo-2-d896f017bafe88ef3490ec9a8eb9f286b8328903.zip
Apply upstream patch for bug #412025. Thanks to everyone who contributed and tested
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxdm/ChangeLog9
-rw-r--r--lxde-base/lxdm/files/lxdm-0.4.1-event-check.patch25
-rw-r--r--lxde-base/lxdm/lxdm-0.4.1-r5.ebuild74
3 files changed, 107 insertions, 1 deletions
diff --git a/lxde-base/lxdm/ChangeLog b/lxde-base/lxdm/ChangeLog
index 8173ac3bf148..ea7bffcab781 100644
--- a/lxde-base/lxdm/ChangeLog
+++ b/lxde-base/lxdm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for lxde-base/lxdm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.14 2012/05/04 05:50:38 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.15 2012/05/07 09:58:01 hwoarang Exp $
+
+*lxdm-0.4.1-r5 (07 May 2012)
+
+ 07 May 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/lxdm-0.4.1-event-check.patch, +lxdm-0.4.1-r5.ebuild:
+ Apply upstream patch for bug #412025. Thanks to everyone who contributed and
+ tested
04 May 2012; Jeff Horelick <jdhore@gentoo.org> lxdm-0.3.0-r1.ebuild,
lxdm-0.3.0-r3.ebuild, lxdm-0.4.1-r1.ebuild, lxdm-0.4.1-r2.ebuild,
diff --git a/lxde-base/lxdm/files/lxdm-0.4.1-event-check.patch b/lxde-base/lxdm/files/lxdm-0.4.1-event-check.patch
new file mode 100644
index 000000000000..4c2d5b35235f
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.4.1-event-check.patch
@@ -0,0 +1,25 @@
+From d4e41ecb36a1ea29482b75674d804bb0f05540b2 Mon Sep 17 00:00:00 2001
+From: dgod <dgod.osa@gmail.com>
+Date: Sun, 25 Dec 2011 15:23:19 +0800
+Subject: [PATCH 1/1] fix event check bug caused cpu 100%
+
+---
+ src/lxcom.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/lxcom.c b/src/lxcom.c
+index 02763eb..18ee12e 100644
+--- a/src/lxcom.c
++++ b/src/lxcom.c
+@@ -89,7 +89,7 @@ static gboolean lxcom_prepare (GSource *source,gint *timeout)
+
+ static gboolean lxcom_check(GSource *source)
+ {
+- return TRUE;
++ return (((LXComSource*)source)->poll.revents&G_IO_IN)?TRUE:FALSE;
+ }
+
+ static gboolean lxcom_dispatch (GSource *source,GSourceFunc callback,gpointer user_data)
+--
+1.7.4.1
+
diff --git a/lxde-base/lxdm/lxdm-0.4.1-r5.ebuild b/lxde-base/lxdm/lxdm-0.4.1-r5.ebuild
new file mode 100644
index 000000000000..680763c2ecf2
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.4.1-r5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r5.ebuild,v 1.1 2012/05/07 09:58:01 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug gtk3 nls pam"
+
+RDEPEND="sys-auth/consolekit
+ x11-libs/libxcb
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Upstream bug, tarball contains pre-made lxdm.conf
+ rm "${S}"/data/lxdm.conf || die
+
+ # There is consolekit
+ epatch "${FILESDIR}/${P}-pam_console-disable.patch"
+ # Fix null pointer dereference, backported from git
+ epatch "${FILESDIR}/${P}-git-fix-null-pointer-deref.patch"
+
+ epatch "${FILESDIR}"/${P}-configure-add-pam.patch
+
+ # 403999
+ epatch "${FILESDIR}"/${P}-missing-pam-defines.patch
+
+ # 412025
+ epatch "${FILESDIR}"/${P}-event-check.patch
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO || die
+}
+
+pkg_postinst() {
+ echo
+ elog "LXDM in the early stages of development!"
+ echo
+}