summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:22:32 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:22:32 +0000
commit4732cae774220c8fbd833bdd644737eb9b4e0408 (patch)
tree306b606f85cf87072efa778545ab17178c09bf2e /mail-client/claws-mail-att-remover
parentmove pkgconfig from RDEPEND to DPEND only (diff)
downloadgentoo-2-4732cae774220c8fbd833bdd644737eb9b4e0408.tar.gz
gentoo-2-4732cae774220c8fbd833bdd644737eb9b4e0408.tar.bz2
gentoo-2-4732cae774220c8fbd833bdd644737eb9b4e0408.zip
version bump for bug 218708
(Portage version: 2.1.4.4)
Diffstat (limited to 'mail-client/claws-mail-att-remover')
-rw-r--r--mail-client/claws-mail-att-remover/ChangeLog8
-rw-r--r--mail-client/claws-mail-att-remover/claws-mail-att-remover-1.0.8.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/mail-client/claws-mail-att-remover/ChangeLog b/mail-client/claws-mail-att-remover/ChangeLog
index 899f33430856..f50f88d26890 100644
--- a/mail-client/claws-mail-att-remover/ChangeLog
+++ b/mail-client/claws-mail-att-remover/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-att-remover
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-att-remover/ChangeLog,v 1.10 2008/02/13 20:36:03 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-att-remover/ChangeLog,v 1.11 2008/05/12 12:22:32 opfer Exp $
+
+*claws-mail-att-remover-1.0.8 (12 May 2008)
+
+ 12 May 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-att-remover-1.0.8.ebuild:
+ version bump for bug 218708
13 Feb 2008; Andrej Kacian <ticho@gentoo.org>
claws-mail-att-remover-1.0.4.ebuild, claws-mail-att-remover-1.0.5.ebuild,
diff --git a/mail-client/claws-mail-att-remover/claws-mail-att-remover-1.0.8.ebuild b/mail-client/claws-mail-att-remover/claws-mail-att-remover-1.0.8.ebuild
new file mode 100644
index 000000000000..6134f9589509
--- /dev/null
+++ b/mail-client/claws-mail-att-remover/claws-mail-att-remover-1.0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-att-remover/claws-mail-att-remover-1.0.8.ebuild,v 1.1 2008/05/12 12:22:32 opfer Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION="This plugin lets you remove attachments from mails."
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.4.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"usr/lib*/claws-mail/plugins/*.{a,la}
+}