summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-06-19 10:28:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-06-19 10:28:27 +0000
commitee3963dc586d2dfd42b1a331fe251c9001c12b39 (patch)
treeb2b37fd314b7d2b845bf5c38d3674140c4e55415 /mail-client/evolution/evolution-1.4.6.ebuild
parentUpdated CVS snapshot (Manifest recommit) (diff)
downloadgentoo-2-ee3963dc586d2dfd42b1a331fe251c9001c12b39.tar.gz
gentoo-2-ee3963dc586d2dfd42b1a331fe251c9001c12b39.tar.bz2
gentoo-2-ee3963dc586d2dfd42b1a331fe251c9001c12b39.zip
Adding more gcc3.4 fixes to address bug #53688. Added --with-pic to force -fPIC for the static-libs that are included in dynamic libs to fix amd64 compilation. Closes bug #53702.
Diffstat (limited to 'mail-client/evolution/evolution-1.4.6.ebuild')
-rw-r--r--mail-client/evolution/evolution-1.4.6.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/mail-client/evolution/evolution-1.4.6.ebuild b/mail-client/evolution/evolution-1.4.6.ebuild
index 26cef303fee8..c3ad465cdff3 100644
--- a/mail-client/evolution/evolution-1.4.6.ebuild
+++ b/mail-client/evolution/evolution-1.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.6.ebuild,v 1.5 2004/06/09 15:36:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-1.4.6.ebuild,v 1.6 2004/06/19 10:28:27 eradicator Exp $
# kde before gnome2, otherwise kde_src_install will override gnome2_src_install
use kde && inherit kde
@@ -141,6 +141,8 @@ src_compile() {
use kde && [ -n "${KDEDIR}" ] \
&& myconf="${myconf} --with-kde-applnk-path=${KDEDIR}/share/applnk"
+ use amd64 && myconf="${myconf} --with-pic"
+
# Use Mozilla NSS/NSPR libs if 'mozilla' *and* 'ssl' in USE
if use ssl && use mozilla; then
if has_version "dev-libs/nspr"; then