summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-06-17 18:39:40 +0000
committerFabian Groffen <grobian@gentoo.org>2006-06-17 18:39:40 +0000
commit929ca1d81ef70667c0c0bcad4ca7b3162d925c36 (patch)
tree54e096c834c1f38235f2856e7f69ae463e079b0a /mail-client/muttng
parentAdd patch to fix strict aliasing breakages. (diff)
downloadgentoo-2-929ca1d81ef70667c0c0bcad4ca7b3162d925c36.tar.gz
gentoo-2-929ca1d81ef70667c0c0bcad4ca7b3162d925c36.tar.bz2
gentoo-2-929ca1d81ef70667c0c0bcad4ca7b3162d925c36.zip
use emake for install, cleanup, and quote ${D}
(Portage version: 2.1_rc2)
Diffstat (limited to 'mail-client/muttng')
-rw-r--r--mail-client/muttng/muttng-20060309.ebuild14
-rw-r--r--mail-client/muttng/muttng-20060329.ebuild14
-rw-r--r--mail-client/muttng/muttng-20060415.ebuild10
3 files changed, 11 insertions, 27 deletions
diff --git a/mail-client/muttng/muttng-20060309.ebuild b/mail-client/muttng/muttng-20060309.ebuild
index 6c5a7612808a..a68d5c94e4f5 100644
--- a/mail-client/muttng/muttng-20060309.ebuild
+++ b/mail-client/muttng/muttng-20060309.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060309.ebuild,v 1.2 2006/06/14 16:11:23 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060309.ebuild,v 1.3 2006/06/17 18:39:40 grobian Exp $
inherit eutils flag-o-matic
@@ -40,8 +40,6 @@ RDEPEND="nls? ( sys-devel/gettext )
virtual/tetex
)"
DEPEND="${RDEPEND}
- sys-devel/automake
- >=sys-devel/autoconf-2.5
net-mail/mailbase"
src_unpack() {
@@ -52,12 +50,6 @@ src_unpack() {
epatch "${FILESDIR}/${P}-statusbar_length.patch"
use doc || epatch "${FILESDIR}/${P}-nodoc.patch"
-
-# aclocal -I m4 || die "aclocal failed"
-# autoheader || die "autoheader failed"
-# emake -C m4 -f Makefile.am.in || die "emake in m4 failed"
-# automake --foreign || die "automake failed"
-# WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
}
src_compile() {
@@ -144,8 +136,8 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ emake DESTDIR="${D}" install || die "install failed"
+ find "${D}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
dodoc COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO
}
diff --git a/mail-client/muttng/muttng-20060329.ebuild b/mail-client/muttng/muttng-20060329.ebuild
index 7a80e3a6ff9e..2c03ee15a09e 100644
--- a/mail-client/muttng/muttng-20060329.ebuild
+++ b/mail-client/muttng/muttng-20060329.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060329.ebuild,v 1.2 2006/06/14 16:11:23 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060329.ebuild,v 1.3 2006/06/17 18:39:40 grobian Exp $
inherit eutils flag-o-matic
@@ -40,8 +40,6 @@ RDEPEND="nls? ( sys-devel/gettext )
virtual/tetex
)"
DEPEND="${RDEPEND}
- sys-devel/automake
- >=sys-devel/autoconf-2.5
net-mail/mailbase"
src_unpack() {
@@ -51,12 +49,6 @@ src_unpack() {
epatch "${FILESDIR}/${PN}-20060317-sigremovereply.patch"
use doc || epatch "${FILESDIR}/${PN}-20060309-nodoc.patch"
-
-# aclocal -I m4 || die "aclocal failed"
-# autoheader || die "autoheader failed"
-# emake -C m4 -f Makefile.am.in || die "emake in m4 failed"
-# automake --foreign || die "automake failed"
-# WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
}
src_compile() {
@@ -143,8 +135,8 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ emake DESTDIR="${D}" install || die "install failed"
+ find "${D}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
dodoc COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO
}
diff --git a/mail-client/muttng/muttng-20060415.ebuild b/mail-client/muttng/muttng-20060415.ebuild
index 8d106940ef91..c05ba943b6d3 100644
--- a/mail-client/muttng/muttng-20060415.ebuild
+++ b/mail-client/muttng/muttng-20060415.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060415.ebuild,v 1.2 2006/06/14 16:11:23 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/muttng/muttng-20060415.ebuild,v 1.3 2006/06/17 18:39:40 grobian Exp $
inherit eutils flag-o-matic
@@ -40,9 +40,9 @@ RDEPEND="nls? ( sys-devel/gettext )
virtual/tetex
)"
DEPEND="${RDEPEND}
- sys-devel/automake
- >=sys-devel/autoconf-2.5
net-mail/mailbase"
+# sys-devel/automake
+# >=sys-devel/autoconf-2.5
src_unpack() {
unpack ${A} || die "unpack failed"
@@ -143,8 +143,8 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die "install failed"
- find ${D}/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ emake DESTDIR="${D}" install || die "install failed"
+ find "${D}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
dodoc COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO
}