summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-07-26 22:18:23 +0000
committerTuan Van <langthang@gentoo.org>2004-07-26 22:18:23 +0000
commita65021756ac9d0aa74632bc3bd2940df633ae9d9 (patch)
treeafe126ef4842809507c6401b43410e97e5deb195 /mail-client/nail
parentsee sqlgui (diff)
downloadgentoo-2-a65021756ac9d0aa74632bc3bd2940df633ae9d9.tar.gz
gentoo-2-a65021756ac9d0aa74632bc3bd2940df633ae9d9.tar.bz2
gentoo-2-a65021756ac9d0aa74632bc3bd2940df633ae9d9.zip
veriosn bump, add virtual/mailx, block virtual/mailx.
Diffstat (limited to 'mail-client/nail')
-rw-r--r--mail-client/nail/ChangeLog10
-rw-r--r--mail-client/nail/Manifest5
-rw-r--r--mail-client/nail/files/digest-nail-10.81
-rw-r--r--mail-client/nail/files/nail-10.8-Makefile.patch24
-rw-r--r--mail-client/nail/nail-10.8.ebuild59
5 files changed, 97 insertions, 2 deletions
diff --git a/mail-client/nail/ChangeLog b/mail-client/nail/ChangeLog
index 20d5f53cf677..bd31f2621d73 100644
--- a/mail-client/nail/ChangeLog
+++ b/mail-client/nail/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for mail-client/nail
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.6 2004/07/17 22:08:37 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/ChangeLog,v 1.7 2004/07/26 22:18:23 langthang Exp $
+
+*nail-10.8 (26 Jul 2004)
+
+ 26 Jul 2004; Tuan Van <langthang@gentoo.org>
+ +files/nail-10.8-Makefile.patch, +nail-10.8.ebuild:
+ version bump.
+ added virtual/mailx.
+ added blocks virtual/mailx.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> nail-10.7.ebuild,
nail-9.30.ebuild:
diff --git a/mail-client/nail/Manifest b/mail-client/nail/Manifest
index 9a20e7fb98d3..5eaace68d789 100644
--- a/mail-client/nail/Manifest
+++ b/mail-client/nail/Manifest
@@ -1,6 +1,9 @@
+MD5 4f088c9941373e7f32deba04c86be535 nail-10.8.ebuild 2139
MD5 cb648860ebe5cc6749f113b4bed7cd9d nail-10.7.ebuild 2119
MD5 97009527a3465711e1c6e409a96bfd98 nail-9.30.ebuild 2163
-MD5 4714f39b1e56b46723c47beb23a6ddd1 ChangeLog 1375
+MD5 574f54ea24d73ac6d352dc057b235557 ChangeLog 1572
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 27d928aaebf2ccd3a13caefad9648ff5 files/digest-nail-10.7 62
+MD5 2a3e927f0b51d9d835a50e8e9befdc4a files/digest-nail-10.8 62
MD5 7e34958d8627a2cf4e1097009af12d90 files/digest-nail-9.30 61
+MD5 7382aa86560d45a33ff12f4a091a5cee files/nail-10.8-Makefile.patch 498
diff --git a/mail-client/nail/files/digest-nail-10.8 b/mail-client/nail/files/digest-nail-10.8
new file mode 100644
index 000000000000..79eb0c07658b
--- /dev/null
+++ b/mail-client/nail/files/digest-nail-10.8
@@ -0,0 +1 @@
+MD5 34145e8e70aa5e1b31f12aef24b13004 nail-10.8.tar.bz2 139777
diff --git a/mail-client/nail/files/nail-10.8-Makefile.patch b/mail-client/nail/files/nail-10.8-Makefile.patch
new file mode 100644
index 000000000000..525f85c62ff0
--- /dev/null
+++ b/mail-client/nail/files/nail-10.8-Makefile.patch
@@ -0,0 +1,24 @@
+--- Makefile.orig 2004-07-26 15:14:25.839795128 -0700
++++ Makefile 2004-07-26 15:15:34.546350144 -0700
+@@ -6,18 +6,18 @@
+ # See the file INSTALL if you need help.
+ #
+
+-PREFIX = /usr/local
++PREFIX = /usr
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/share/man
+ SYSCONFDIR = /etc
+
+ MAILRC = $(SYSCONFDIR)/nail.rc
+-MAILSPOOL = /var/mail
++MAILSPOOL = ~/.maildir
+ SENDMAIL = /usr/lib/sendmail
+
+ DESTDIR =
+
+-UCBINSTALL = /usr/ucb/install
++UCBINSTALL = /usr/bin/install
+
+ #CFLAGS =
+ #CPPFLAGS =
diff --git a/mail-client/nail/nail-10.8.ebuild b/mail-client/nail/nail-10.8.ebuild
new file mode 100644
index 000000000000..4b96b20678ed
--- /dev/null
+++ b/mail-client/nail/nail-10.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nail/nail-10.8.ebuild,v 1.1 2004/07/26 22:18:23 langthang Exp $
+
+inherit eutils
+DESCRIPTION="Nail is a mail user agent derived from Berkeley Mail 8.1 and contains builtin support for MIME messages."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://nail.sourceforge.net/"
+PROVIDE="virtual/mailx"
+DEPEND="virtual/libc
+ !virtual/mailx"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+src_compile() {
+ # ./configure no longer required
+ # patch to Gentoo specifics.
+ epatch ${FILESDIR}/${P}-Makefile.patch || die "patch failed."
+ emake || die "emake failed"
+}
+
+src_install () {
+ #add smtp flag to nail.rc so that it uses smtp by default (making it
+ #essentially mailer independent
+ echo -e "\n#use smtp on the local system by default. Change" >> nail.rc
+ echo -e "#\"localhost\" to your smtp server if you use a remote" >> nail.rc
+ echo -e "#smtp server. (Delete this line to use sendmail instead)" >> nail.rc
+ echo -e "set smtp=localhost" >> nail.rc
+
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS COPYING I18N INSTALL README
+ dodir /bin
+ dosym /usr/bin/nail /bin/mail
+ dosym /usr/bin/nail /usr/bin/mail
+ dosym /usr/bin/nail /usr/bin/Mail
+}
+
+pkg_postinst () {
+
+ echo -e "\n NOTE: The nail mailer does _not_ support maildir format.\n" \
+ " It is best to use nail only for outgoing mail, and\n" \
+ " really only use it for scripts that require it.\n\n" \
+ "NOTE: This build has ~/.maildir compiled in as the\n" \
+ " mail spool directory (for incoming mail).\n" \
+ " Nail will work for sending outgoing mail even if\n" \
+ " the mail spool directory does not exist.\n\n" \
+ "NOTE: When used to send mail via a remote smtp server\n" \
+ " nail does not require a local mail transfer agent.\n" \
+ " ISP smtp servers tend to have names like\n" \
+ " mail.ispname.com\n" \
+ " or\n" \
+ " smtp.ispname.com.\n" \
+ " If you do not wish to use a remote smtp server,\n" \
+ " then you WILL have to install a mta such as sendmail,\n" \
+ " postfix, exim, etcetera.\n"
+}