summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-09-06 18:16:07 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-09-06 18:16:07 +0000
commit6502116debdb02d86b8cb15fb82fd73b84d4d105 (patch)
treef880902c8aa38ea97f0509bf1ba029f9b052981f /mail-client
parentUpdate sparc bootstrap compiler (bug #483980). (diff)
downloadgentoo-2-6502116debdb02d86b8cb15fb82fd73b84d4d105.tar.gz
gentoo-2-6502116debdb02d86b8cb15fb82fd73b84d4d105.tar.bz2
gentoo-2-6502116debdb02d86b8cb15fb82fd73b84d4d105.zip
New package, based on the work by Mario Fetka and Michael Dwyer in the n4g overlay
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/novell-groupwise-client/ChangeLog11
-rw-r--r--mail-client/novell-groupwise-client/metadata.xml8
-rw-r--r--mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild74
3 files changed, 93 insertions, 0 deletions
diff --git a/mail-client/novell-groupwise-client/ChangeLog b/mail-client/novell-groupwise-client/ChangeLog
new file mode 100644
index 000000000000..0323b095207c
--- /dev/null
+++ b/mail-client/novell-groupwise-client/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for mail-client/novell-groupwise-client
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/novell-groupwise-client/ChangeLog,v 1.1 2013/09/06 18:16:07 dilfridge Exp $
+
+*novell-groupwise-client-8.0.2.96933 (06 Sep 2013)
+
+ 06 Sep 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ +novell-groupwise-client-8.0.2.96933.ebuild, +metadata.xml:
+ New package, based on the work by Mario Fetka and Michael Dwyer in the n4g
+ overlay
+
diff --git a/mail-client/novell-groupwise-client/metadata.xml b/mail-client/novell-groupwise-client/metadata.xml
new file mode 100644
index 000000000000..cff782e7bd92
--- /dev/null
+++ b/mail-client/novell-groupwise-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer><email>dilfridge@gentoo.org</email></maintainer>
+ <use>
+ <flag name='novell-jre'>Use the Java Runtime Environment provided by Novell</flag>
+ </use>
+</pkgmetadata>
diff --git a/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild b/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild
new file mode 100644
index 000000000000..5471ff872eec
--- /dev/null
+++ b/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/novell-groupwise-client/novell-groupwise-client-8.0.2.96933.ebuild,v 1.1 2013/09/06 18:16:07 dilfridge Exp $
+
+RESTRICT="binchecks fetch mirror strip"
+
+inherit eutils rpm multilib versionator
+
+MY_PV=$(replace_version_separator 3 '-')
+MY_P="${P/_p/-}"
+
+DESCRIPTION="Novell Groupwise Client for Linux"
+HOMEPAGE="http://www.novell.com/products/groupwise/"
+SRC_URI="gw802_hp3_client_linux_multi.tar.gz"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="novell-jre multilib"
+DEPEND=""
+RDEPEND="sys-libs/libstdc++-v3
+ !novell-jre? (
+ || ( virtual/jdk
+ virtual/jre )
+ multilib? (
+ amd64? ( app-emulation/emul-linux-x86-java ) ) )
+ multilib? (
+ amd64? ( app-emulation/emul-linux-x86-compat ) )"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}"/${PN}-${MY_PV}
+ cd ${PN}-${MY_PV}
+ rpm_unpack ./../gw${MY_PV}_client_linux_multi/${PN}-${MY_PV}.i586.rpm
+}
+
+src_compile() { :; }
+
+src_install() {
+ JRE_DIR="${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/java;
+
+ if use novell-jre; then
+ # Undo Sun's funny-business with packed .jar's
+ for i in $JRE_DIR/lib/*.pack; do
+ i_b=`echo $i | sed 's/\.pack$//'`;
+ einfo "Unpacking `basename $i` -> `basename $i_b.jar`";
+ $JRE_DIR/bin/unpack200 $i $i_b.jar || die "Unpack failed";
+ done;
+ else
+ if use multilib; then
+ rm -rf "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/java
+ sed -i 's%/opt/novell/groupwise/client/java/lib/i386%`java-config --select-vm=emul-linux-x86-java --jre-home`/lib/i386/client:`java-config --select-vm=emul-linux-x86-java --jre-home`/lib/i386/server:`java-config --select-vm=emul-linux-x86-java --jre-home`/lib/i386%' "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/bin/groupwise
+ else
+ rm -rf "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/java
+ sed -i 's%/opt/novell/groupwise/client/java/lib/i386%`java-config --jre-home`/jre/lib/i386/client:`java-config --jre-home`/jre/lib/i386/server:`java-config --jre-home`/jre/lib/i386%' "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/bin/groupwise
+ fi
+ fi
+
+ insinto /usr/share/applications
+ doins "${WORKDIR}"/${PN}-${MY_PV}/opt/novell/groupwise/client/gwclient.desktop
+
+ mv "${WORKDIR}"/${PN}-${MY_PV}/opt "${D}"/ || die "mv opt"
+
+ dodir /opt/bin
+ dosym /opt/novell/groupwise/client/bin/groupwise /opt/bin/groupwise
+}
+
+pkg_nofetch() {
+ einfo "You can obtain an evaluation version of the Groupwise client at"
+ einfo "${HOMEPAGE} - please download ${SRC_URI}"
+ einfo "and place it in ${DISTDIR}. Alternatively request the file"
+ einfo "from the Groupwise server provider of your organization."
+ einfo "Note that the client is useless without a server account."
+}