summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2007-06-23 18:05:54 +0000
committerMarius Mauch <genone@gentoo.org>2007-06-23 18:05:54 +0000
commit7b6d5c8513491d70db617cd85dbff1eadfc91c44 (patch)
tree24f18eb63dbd3459fa8eebd8830a53d5c827dd60 /mail-client
parentMarked unstable on mips, per #182196. (diff)
downloadgentoo-2-7b6d5c8513491d70db617cd85dbff1eadfc91c44.tar.gz
gentoo-2-7b6d5c8513491d70db617cd85dbff1eadfc91c44.tar.bz2
gentoo-2-7b6d5c8513491d70db617cd85dbff1eadfc91c44.zip
Check that pinentry was merged with USE=gtk or USE=qt3 (bug #170967)
(Portage version: 2.1.2.9)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/ChangeLog6
-rw-r--r--mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild14
-rw-r--r--mail-client/claws-mail/claws-mail-2.9.1.ebuild14
-rw-r--r--mail-client/claws-mail/claws-mail-2.9.2.ebuild14
4 files changed, 44 insertions, 4 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index f88c57f5532c..a70f63c11be9 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/claws-mail
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.33 2007/06/23 14:15:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.34 2007/06/23 18:05:54 genone Exp $
+
+ 23 Jun 2007; Marius Mauch <genone@gentoo.org> claws-mail-2.9.1.ebuild,
+ claws-mail-2.9.2.ebuild, claws-mail-2.10.0_rc1.ebuild:
+ Check that pinentry was merged with USE=gtk or USE=qt3 (bug #170967)
*claws-mail-2.10.0_rc1 (23 Jun 2007)
diff --git a/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild b/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
index d15aaf53f535..591a51aec8b4 100644
--- a/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
+++ b/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild,v 1.1 2007/06/23 14:15:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.10.0_rc1.ebuild,v 1.2 2007/06/23 18:05:54 genone Exp $
IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
@@ -47,6 +47,18 @@ RDEPEND="${COMMONDEPEND}
PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+pkg_setup() {
+ # we have to make sure that pinentry has gtk support for GPG support
+ if use crypt && ! built_with_use --missing true -o app-crypt/pinentry gtk qt3; then
+ eerror "You need to merge app-crypt/pinentry with USE=gtk or USE=qt3"
+ eerror "for working GPG support. You have the following options:"
+ eerror " - remerge app-crypt/pinentry with USE=gtk"
+ eerror " - remerge app-crypt/pinentry with USE=qt3"
+ eerror " - disable GPG support by setting USE=-crypt for this package"
+ die "missing gtk/qt support in app-crypt/pinentry"
+ fi
+}
+
src_compile() {
local myconf
diff --git a/mail-client/claws-mail/claws-mail-2.9.1.ebuild b/mail-client/claws-mail/claws-mail-2.9.1.ebuild
index 413879c76e7e..97be49104f2a 100644
--- a/mail-client/claws-mail/claws-mail-2.9.1.ebuild
+++ b/mail-client/claws-mail/claws-mail-2.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.9.1.ebuild,v 1.9 2007/05/26 01:34:52 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.9.1.ebuild,v 1.10 2007/06/23 18:05:54 genone Exp $
IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
@@ -47,6 +47,18 @@ RDEPEND="${COMMONDEPEND}
PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+pkg_setup() {
+ # we have to make sure that pinentry has gtk support for GPG support
+ if use crypt && ! built_with_use --missing true -o app-crypt/pinentry gtk qt3; then
+ eerror "You need to merge app-crypt/pinentry with USE=gtk or USE=qt3"
+ eerror "for working GPG support. You have the following options:"
+ eerror " - remerge app-crypt/pinentry with USE=gtk"
+ eerror " - remerge app-crypt/pinentry with USE=qt3"
+ eerror " - disable GPG support by setting USE=-crypt for this package"
+ die "missing gtk/qt support in app-crypt/pinentry"
+ fi
+}
+
src_compile() {
local myconf
diff --git a/mail-client/claws-mail/claws-mail-2.9.2.ebuild b/mail-client/claws-mail/claws-mail-2.9.2.ebuild
index e5c72b0fff58..d9aefc982972 100644
--- a/mail-client/claws-mail/claws-mail-2.9.2.ebuild
+++ b/mail-client/claws-mail/claws-mail-2.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.9.2.ebuild,v 1.1 2007/05/08 16:22:59 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.9.2.ebuild,v 1.2 2007/06/23 18:05:54 genone Exp $
IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
@@ -47,6 +47,18 @@ RDEPEND="${COMMONDEPEND}
PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+pkg_setup() {
+ # we have to make sure that pinentry has gtk support for GPG support
+ if use crypt && ! built_with_use --missing true -o app-crypt/pinentry gtk qt3; then
+ eerror "You need to merge app-crypt/pinentry with USE=gtk or USE=qt3"
+ eerror "for working GPG support. You have the following options:"
+ eerror " - remerge app-crypt/pinentry with USE=gtk"
+ eerror " - remerge app-crypt/pinentry with USE=qt3"
+ eerror " - disable GPG support by setting USE=-crypt for this package"
+ die "missing gtk/qt support in app-crypt/pinentry"
+ fi
+}
+
src_compile() {
local myconf