summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-10-13 17:57:14 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-10-13 17:57:14 +0000
commit8a3e99d5baedee5f22efed521fc04c5f31e73be7 (patch)
tree5b91979a6f951b4b302c5e21b85cb6862a61bddf /mail-client
parentVersion bump (#150772). (diff)
downloadgentoo-2-8a3e99d5baedee5f22efed521fc04c5f31e73be7.tar.gz
gentoo-2-8a3e99d5baedee5f22efed521fc04c5f31e73be7.tar.bz2
gentoo-2-8a3e99d5baedee5f22efed521fc04c5f31e73be7.zip
New bugfix release for 2.16.1
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/ChangeLog12
-rw-r--r--mail-client/evolution/evolution-2.8.1.ebuild200
-rw-r--r--mail-client/evolution/files/digest-evolution-2.8.16
-rw-r--r--mail-client/evolution/files/evolution-2.8.1-64-bit.patch138
4 files changed, 355 insertions, 1 deletions
diff --git a/mail-client/evolution/ChangeLog b/mail-client/evolution/ChangeLog
index 8119c9dae695..8985beef9c2a 100644
--- a/mail-client/evolution/ChangeLog
+++ b/mail-client/evolution/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for mail-client/evolution
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.144 2006/10/11 21:16:33 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/ChangeLog,v 1.145 2006/10/13 17:57:14 dang Exp $
+
+ 13 Oct 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/evolution-2.8.1-64-bit.patch, -evolution-2.8.0.ebuild,
+ +evolution-2.8.1.ebuild:
+ New bugfix release for 2.16.1
+
+*evolution-2.8.1 (13 Oct 2006)
+
+ 13 Oct 2006; Daniel Gryniewicz <dang@gentoo.org> +evolution-2.8.1.ebuild:
+ Bump to 2.8.1
11 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove obz from metadata due to retiring.
diff --git a/mail-client/evolution/evolution-2.8.1.ebuild b/mail-client/evolution/evolution-2.8.1.ebuild
new file mode 100644
index 000000000000..b566df904e68
--- /dev/null
+++ b/mail-client/evolution/evolution-2.8.1.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.8.1.ebuild,v 1.1 2006/10/13 17:57:14 dang Exp $
+
+inherit eutils flag-o-matic alternatives gnome2 autotools
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+SRC_URI="${SRC_URI}
+ bogofilter? ( mirror://gentoo/${PN}-2.5.5.1-bf-junk.tar.bz2 )"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# gstreamer for audio-inline, when it uses 0.10
+IUSE="bogofilter crypt dbus debug doc hal ipv6 kerberos krb4 ldap mono nntp pda profile spell ssl"
+
+# Pango dependency required to avoid font rendering problems
+# evolution-data-server dep is 1.5 because in the e-utils directories,
+# the includes reference locations only present in eds > 1.5
+RDEPEND=">=x11-themes/gnome-icon-theme-1.2
+ dev-libs/atk
+ >=gnome-extra/gtkhtml-3.9.90
+ >=dev-libs/glib-2
+ >=gnome-base/orbit-2.9.8
+ >=gnome-base/libbonobo-2
+ >=gnome-extra/evolution-data-server-1.7.90
+ >=gnome-base/libbonoboui-2.4.2
+ >=gnome-base/gnome-vfs-2.4
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomecanvas-2
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeprint-2.7
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=x11-libs/gtk+-2
+ >=gnome-base/libgnome-2
+ >=net-libs/libsoup-2.2.96
+ >=x11-libs/pango-1.8.1
+ x11-libs/libnotify
+ hal? ( >=sys-apps/hal-0.5.4 )
+ pda? (
+ >=app-pda/gnome-pilot-2
+ >=app-pda/gnome-pilot-conduits-2 )
+ spell? ( >=app-text/gnome-spell-1.0.5 )
+ crypt? ( >=app-crypt/gnupg-1.2.2 )
+ ssl? ( >=dev-libs/nspr-4.6.1
+ >=dev-libs/nss-3.11 )
+ ldap? ( >=net-nds/openldap-2 )
+ kerberos? ( virtual/krb5 )
+ krb4? ( virtual/krb5 )
+ dbus? ( sys-apps/dbus )
+ mono? ( >=dev-lang/mono-1 )
+ bogofilter? ( mail-filter/bogofilter )
+ !bogofilter? ( mail-filter/spamassassin )"
+# gstreamer? (
+# >=media-libs/gstreamer-0.10
+# >=media-libs/gst-plugins-base-0.10 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ sys-devel/bison
+ app-text/scrollkeeper
+ >=gnome-base/gnome-common-2.12.0
+ doc? ( >=dev-util/gtk-doc-0.6 )"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS* README"
+ELTCONF="--reverse-deps"
+
+
+pkg_setup() {
+ G2CONF="--disable-default-binary \
+ --without-kde-applnk-path \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_enable ipv6) \
+ $(use_enable mono) \
+ $(use_enable nntp) \
+ $(use_enable pda pilot-conduits) \
+ $(use_enable profile profiling) \
+ $(use_with ldap openldap) \
+ $(use_with kerberos krb5 /usr)"
+
+ if use krb4 && ! built_with_use virtual/krb5 krb4; then
+ ewarn
+ ewarn "In order to add kerberos 4 support, you have to emerge"
+ ewarn "virtual/krb5 with the 'krb4' USE flag enabled as well."
+ ewarn
+ ewarn "Skipping for now."
+ ewarn
+ G2CONF="${G2CONF} --without-krb4"
+ else
+ G2CONF="${G2CONF} $(use_with krb4 krb4 /usr)"
+ fi
+
+ # Plug-ins to install. Normally we would want something similar to
+ # --enable-plugins=all (plugins_base + plugins_standard), except for some
+ # special cases.
+ local plugins="calendar-file calendar-http calendar-weather \
+ itip-formatter plugin-manager default-source addressbook-file \
+ startup-wizard print-message mark-all-read groupwise-features \
+ groupwise-account-setup hula-account-setup mail-account-disable \
+ publish-calendar caldav \
+ bbdb subject-thread save-calendar select-one-source copy-tool \
+ mail-to-task mark-calendar-offline mailing-list-actions \
+ new-mail-notify default-mailer import-ics-attachments"
+
+ # For dev releases, add experimental plugins
+ plugins="${plugins} backup-restore folder-unsubscribe mail-to-meeting \
+ prefer-plain save-attachments"
+
+ if use bogofilter; then
+ plugins="${plugins} bf-junk-plugin"
+ else
+ plugins="${plugins} sa-junk-plugin"
+ fi
+
+ # The special cases
+
+ # remove this due to bug #128035 re-enable later if it doesn't dep on
+ # gstreamer-0.8
+ # use gstreamer && plugins="${plugins} audio-inline"
+ use dbus && plugins="${plugins} new-mail-notify"
+ use mono && plugins="${plugins} mono"
+
+ if built_with_use gnome-extra/evolution-data-server ldap; then
+ plugins="${plugins} exchange-operations"
+ fi
+
+ local pluginlist=""
+ for p in $plugins; do
+ [ "x$pluginlist" != "x" ] && pluginlist="${pluginlist},"
+ pluginlist="${pluginlist}${p}"
+ done
+
+ G2CONF="${G2CONF} --enable-plugins=${pluginlist}"
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+
+ gnome2_omf_fix help/omf.make
+
+ # Accept the list of plugins separated by commas instead of spaces.
+ epatch ${FILESDIR}/${PN}-2.3.7-configure_plugins.patch
+
+ # Move evo to URI-based saving
+ epatch ${FILESDIR}/${PN}-2.8.0-uri.patch.gz
+
+ # Fix 64-bit warnings
+ epatch ${FILESDIR}/${P}-64-bit.patch
+
+ # Add bogofilter junk plugin source
+ use bogofilter && epatch ${FILESDIR}/${PN}-2.7.3-bf-junk.patch.gz
+
+
+ eaclocal || die
+ _elibtoolize --copy --force || die
+ eautoheader || die
+ eautomake || die
+ intltoolize --force || die
+ eautoconf || die
+}
+
+src_compile() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ if use ssl ; then
+ sed -i -e "s|mozilla-nss|nss|
+ s|mozilla-nspr|nspr|" ${S}/configure
+ G2CONF="${G2CONF} --enable-nss=yes"
+ else
+ G2CONF="${G2CONF} --without-nspr-libs --without-nspr-includes \
+ --without-nss-libs --without-nss-includes"
+ fi
+
+ # problems with -O3 on gcc-3.3.1
+ replace-flags -O3 -O2
+
+ if [ "${ARCH}" = "hppa" ]; then
+ append-flags "-fPIC -ffunction-sections"
+ export LDFLAGS="-ffunction-sections -Wl,--stub-group-size=25000"
+ fi
+
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ alternatives_auto_makesym "/usr/bin/evolution" "/usr/bin/evolution-[0-9].[0-9]"
+ einfo "To change the default browser if you are not using GNOME, do:"
+ einfo "gconftool-2 --set /desktop/gnome/url-handlers/http/command -t string 'mozilla %s'"
+ einfo "gconftool-2 --set /desktop/gnome/url-handlers/https/command -t string 'mozilla %s'"
+ einfo ""
+ einfo "Replace 'mozilla %s' with which ever browser you use."
+}
diff --git a/mail-client/evolution/files/digest-evolution-2.8.1 b/mail-client/evolution/files/digest-evolution-2.8.1
new file mode 100644
index 000000000000..94690e15dbe4
--- /dev/null
+++ b/mail-client/evolution/files/digest-evolution-2.8.1
@@ -0,0 +1,6 @@
+MD5 31456188591167083628df719adc8f22 evolution-2.5.5.1-bf-junk.tar.bz2 10771
+RMD160 7ae764761607d50024fbec32680bc57e04ac7879 evolution-2.5.5.1-bf-junk.tar.bz2 10771
+SHA256 b8988b28836a201606d8fa651f48722ebac8c984dcc171f7f7a3b860d0f7a045 evolution-2.5.5.1-bf-junk.tar.bz2 10771
+MD5 6a08d1121bc126c4ed7035ab94a09871 evolution-2.8.1.tar.bz2 12873039
+RMD160 8a06f9a3d1a402d3e92edf1de623b07b09322059 evolution-2.8.1.tar.bz2 12873039
+SHA256 91d3e7c7fd961959fc01abcd7bb18747bfd8fe8b90bd91f03b4392b11f0e3a7b evolution-2.8.1.tar.bz2 12873039
diff --git a/mail-client/evolution/files/evolution-2.8.1-64-bit.patch b/mail-client/evolution/files/evolution-2.8.1-64-bit.patch
new file mode 100644
index 000000000000..2c59dbfbc9da
--- /dev/null
+++ b/mail-client/evolution/files/evolution-2.8.1-64-bit.patch
@@ -0,0 +1,138 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/a11y/calendar/ea-gnome-calendar.c evolution-2.8.1/a11y/calendar/ea-gnome-calendar.c
+--- evolution-2.8.1.orig/a11y/calendar/ea-gnome-calendar.c 2006-09-30 01:24:35.000000000 -0400
++++ evolution-2.8.1/a11y/calendar/ea-gnome-calendar.c 2006-10-13 12:12:10.000000000 -0400
+@@ -30,6 +30,7 @@
+ #include <libecal/e-cal-time-util.h>
+ #include <libedataserver/e-data-server-util.h>
+ #include <libgnome/gnome-i18n.h>
++#include <libedataserver/e-data-server-util.h>
+
+ static void ea_gnome_calendar_class_init (EaGnomeCalendarClass *klass);
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/addressbook/gui/widgets/e-minicard.c evolution-2.8.1/addressbook/gui/widgets/e-minicard.c
+--- evolution-2.8.1.orig/addressbook/gui/widgets/e-minicard.c 2006-10-02 02:25:24.000000000 -0400
++++ evolution-2.8.1/addressbook/gui/widgets/e-minicard.c 2006-10-13 12:12:10.000000000 -0400
+@@ -41,6 +41,7 @@
+ #include "e-contact-editor.h"
+ #include <e-util/e-html-utils.h>
+ #include <e-util/e-icon-factory.h>
++#include <e-util/e-html-utils.h>
+ #include <libebook/e-destination.h>
+ #include "a11y/addressbook/ea-addressbook.h"
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/calendar/gui/e-cal-model-tasks.h evolution-2.8.1/calendar/gui/e-cal-model-tasks.h
+--- evolution-2.8.1.orig/calendar/gui/e-cal-model-tasks.h 2006-09-30 01:24:36.000000000 -0400
++++ evolution-2.8.1/calendar/gui/e-cal-model-tasks.h 2006-10-13 12:12:10.000000000 -0400
+@@ -64,6 +64,7 @@
+ void e_cal_model_tasks_mark_task_complete (ECalModelTasks *model, gint model_row);
+ void e_cal_model_tasks_mark_task_incomplete (ECalModelTasks *model, gint model_row);
+ void e_cal_model_tasks_update_due_tasks (ECalModelTasks *model);
++void e_cal_model_tasks_mark_task_incomplete (ECalModelTasks *model, gint model_row);
+
+ G_END_DECLS
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/calendar/gui/e-day-view.c evolution-2.8.1/calendar/gui/e-day-view.c
+--- evolution-2.8.1.orig/calendar/gui/e-day-view.c 2006-08-07 00:47:43.000000000 -0400
++++ evolution-2.8.1/calendar/gui/e-day-view.c 2006-10-13 12:12:10.000000000 -0400
+@@ -65,6 +65,7 @@
+ #include "calendar-commands.h"
+ #include "calendar-config.h"
+ #include "goto.h"
++#include "e-calendar-view.h"
+ #include "e-cal-model-calendar.h"
+ #include "e-day-view-time-item.h"
+ #include "e-day-view-top-item.h"
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/calendar/gui/e-meeting-store.c evolution-2.8.1/calendar/gui/e-meeting-store.c
+--- evolution-2.8.1.orig/calendar/gui/e-meeting-store.c 2006-04-22 00:39:20.000000000 -0400
++++ evolution-2.8.1/calendar/gui/e-meeting-store.c 2006-10-13 12:12:10.000000000 -0400
+@@ -1472,7 +1472,7 @@
+ guint
+ e_meeting_store_get_num_queries (EMeetingStore *store)
+ {
+- g_return_if_fail (E_IS_MEETING_STORE (store));
++ g_return_val_if_fail (E_IS_MEETING_STORE (store), 0);
+
+ return store->priv->num_queries;
+ }
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/calendar/gui/e-week-view.c evolution-2.8.1/calendar/gui/e-week-view.c
+--- evolution-2.8.1.orig/calendar/gui/e-week-view.c 2006-09-30 01:24:36.000000000 -0400
++++ evolution-2.8.1/calendar/gui/e-week-view.c 2006-10-13 12:12:10.000000000 -0400
+@@ -69,6 +69,7 @@
+ #include "e-week-view-layout.h"
+ #include "e-week-view-main-item.h"
+ #include "e-week-view-titles-item.h"
++#include "e-calendar-view.h"
+ #include "misc.h"
+ #include <e-util/e-icon-factory.h>
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/calendar/gui/gnome-cal.h evolution-2.8.1/calendar/gui/gnome-cal.h
+--- evolution-2.8.1.orig/calendar/gui/gnome-cal.h 2006-09-30 01:24:36.000000000 -0400
++++ evolution-2.8.1/calendar/gui/gnome-cal.h 2006-10-13 12:12:10.000000000 -0400
+@@ -200,6 +200,7 @@
+
+ GtkWidget * gnome_calendar_get_tag (GnomeCalendar *gcal);
+
++GtkWidget * gnome_calendar_get_tag (GnomeCalendar *gcal);
+ G_END_DECLS
+
+ #endif
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/composer/e-msg-composer.c evolution-2.8.1/composer/e-msg-composer.c
+--- evolution-2.8.1.orig/composer/e-msg-composer.c 2006-09-30 01:24:40.000000000 -0400
++++ evolution-2.8.1/composer/e-msg-composer.c 2006-10-13 12:12:10.000000000 -0400
+@@ -64,6 +64,7 @@
+ #include <libgnome/gnome-exec.h>
+ #include <libgnome/gnome-help.h>
+ #include <libgnome/gnome-i18n.h>
++#include <libgnome/gnome-help.h>
+ #include <libgnomeui/gnome-uidefs.h>
+ #include <libgnomeui/gnome-window-icon.h>
+
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/e-util/e-profile-event.c evolution-2.8.1/e-util/e-profile-event.c
+--- evolution-2.8.1.orig/e-util/e-profile-event.c 2006-02-08 06:43:02.000000000 -0500
++++ evolution-2.8.1/e-util/e-profile-event.c 2006-10-13 12:12:10.000000000 -0400
+@@ -133,12 +133,6 @@
+
+ e_event_emit((EEvent *)epe, "event", (EEventTarget *)t);
+ }
+-#else
+-#undef e_profile_event_emit
+-void
+-e_profile_event_emit(const char *id, const char *uid, guint32 flags)
+-{
+-}
+ #endif
+
+ /* ********************************************************************** */
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/e-util/e-util.h evolution-2.8.1/e-util/e-util.h
+--- evolution-2.8.1.orig/e-util/e-util.h 2006-09-02 02:42:18.000000000 -0400
++++ evolution-2.8.1/e-util/e-util.h 2006-10-13 12:12:10.000000000 -0400
+@@ -29,6 +29,7 @@
+ #include <limits.h>
+ #include <gconf/gconf-client.h>
+ #include <cairo.h>
++#include <gtk/gtk.h>
+
+ #ifdef __cplusplus
+ extern "C" {
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/mail/em-format-html-display.c evolution-2.8.1/mail/em-format-html-display.c
+--- evolution-2.8.1.orig/mail/em-format-html-display.c 2006-09-30 02:22:49.000000000 -0400
++++ evolution-2.8.1/mail/em-format-html-display.c 2006-10-13 12:12:14.000000000 -0400
+@@ -42,6 +42,7 @@
+ #include <gtkhtml/gtkhtml-embedded.h>
+ #include <gtkhtml/gtkhtml-search.h>
+
++#include <gtk/gtk.h>
+ #include <gtk/gtkeventbox.h>
+ #include <gtk/gtkvbox.h>
+ #include <gtk/gtkhbox.h>
+diff --exclude-from=/home/dang/.diffrc -u -ruN evolution-2.8.1.orig/plugins/mono/mono-plugin.c evolution-2.8.1/plugins/mono/mono-plugin.c
+--- evolution-2.8.1.orig/plugins/mono/mono-plugin.c 2005-12-17 13:47:10.000000000 -0500
++++ evolution-2.8.1/plugins/mono/mono-plugin.c 2006-10-13 12:12:14.000000000 -0400
+@@ -8,6 +8,7 @@
+ #include <mono/metadata/object.h>
+ #include <mono/metadata/appdomain.h>
+ #include <mono/metadata/assembly.h>
++#include <mono/metadata/threads.h>
+ #include <mono/jit/jit.h>
+
+ #define d(x)