summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2011-04-30 18:38:24 +0000
committerChristian Faulhammer <fauli@gentoo.org>2011-04-30 18:38:24 +0000
commit95310590dee8ef69ab58fe704e40d8f303fc3a0b (patch)
tree5d7525d364242f06e37c7da5e1cd5ee0d000b4fb /mail-client
parentversion bump (bug #362031) (diff)
downloadgentoo-2-95310590dee8ef69ab58fe704e40d8f303fc3a0b.tar.gz
gentoo-2-95310590dee8ef69ab58fe704e40d8f303fc3a0b.tar.bz2
gentoo-2-95310590dee8ef69ab58fe704e40d8f303fc3a0b.zip
revision bump to fix bug 362297, which is a crash on start-up
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/ChangeLog8
-rw-r--r--mail-client/claws-mail/claws-mail-3.7.9-r1.ebuild145
-rw-r--r--mail-client/claws-mail/files/claws-mail-3.7.9_notify_crash.patch16
3 files changed, 168 insertions, 1 deletions
diff --git a/mail-client/claws-mail/ChangeLog b/mail-client/claws-mail/ChangeLog
index e41a103c2473..9d53be098395 100644
--- a/mail-client/claws-mail/ChangeLog
+++ b/mail-client/claws-mail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.174 2011/04/26 18:26:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.175 2011/04/30 18:38:24 fauli Exp $
+
+*claws-mail-3.7.9-r1 (30 Apr 2011)
+
+ 30 Apr 2011; Christian Faulhammer <fauli@gentoo.org>
+ +claws-mail-3.7.9-r1.ebuild, +files/claws-mail-3.7.9_notify_crash.patch:
+ revision bump to fix bug 362297, which is a crash on start-up
26 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> claws-mail-3.7.9.ebuild:
Use gnome2-utils.eclass to update the cache instead of calling
diff --git a/mail-client/claws-mail/claws-mail-3.7.9-r1.ebuild b/mail-client/claws-mail/claws-mail-3.7.9-r1.ebuild
new file mode 100644
index 000000000000..cb6de286a3ba
--- /dev/null
+++ b/mail-client/claws-mail/claws-mail-3.7.9-r1.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-3.7.9-r1.ebuild,v 1.1 2011/04/30 18:38:24 fauli Exp $
+
+EAPI="2"
+
+inherit eutils multilib gnome2-utils
+
+DESCRIPTION="An email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org/"
+
+SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bogofilter crypt dbus dillo doc +gnutls +imap ipv6 ldap nntp pda session smime spamassassin spell ssl startup-notification xface"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.6:2
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=net-libs/gnutls-2.0.3 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ dillo? ( www-client/dillo )
+ spell? ( >=app-text/enchant-1.0.0 )
+ imap? ( >=net-libs/libetpan-0.57 )
+ nntp? ( >=net-libs/libetpan-0.57 )
+ gnutls? ( >=net-libs/gnutls-2.0.3 )
+ startup-notification? ( x11-libs/startup-notification )
+ bogofilter? ( mail-filter/bogofilter )
+ session? ( x11-libs/libSM
+ x11-libs/libICE )
+ smime? ( >=app-crypt/gpgme-0.4.5 )"
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ dev-util/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+PLUGIN_NAMES="acpi-notifier address_keeper archive att-remover attachwarner clamd fancy fetchinfo gtkhtml mailmbox newmail notification perl python rssyl spam_report tnef_parse vcalendar"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}_notify_crash.patch
+}
+
+src_configure() {
+ local myconf
+ # libetpan is needed if user wants nntp or imap functionality
+ if use imap || use nntp; then
+ myconf="--enable-libetpan"
+ else
+ myconf="--disable-libetpan"
+ fi
+
+ # The usage of openssl was discarded once and USE=ssl is mapped to
+ # USE=gnutls now. Maybe USE=ssl can fade out sometime
+ if use ssl || use gnutls; then
+ myconf="${myconf} --enable-gnutls"
+ else
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable dbus) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell enchant) \
+ $(use_enable xface compface) \
+ $(use_enable doc manual) \
+ $(use_enable startup-notification) \
+ $(use_enable session libsm) \
+ $(use_enable crypt pgpmime-plugin) \
+ $(use_enable crypt pgpinline-plugin) \
+ $(use_enable crypt pgpcore-plugin) \
+ $(use_enable dillo dillo-viewer-plugin) \
+ $(use_enable spamassassin spamassassin-plugin) \
+ $(use_enable bogofilter bogofilter-plugin) \
+ $(use_enable smime smime-plugin) \
+ --docdir=/usr/share/doc/${PF} \
+ --enable-trayicon-plugin \
+ --disable-maemo ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins ${PN}.png || die
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins ${PN}-${res}.png ${PN}.png || die
+ done
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ insinto /usr/share/applications
+ doins ${PN}.desktop
+
+ einfo "Installing extra tools"
+ cd "${S}"/tools
+ exeinto /usr/$(get_libdir)/${PN}/tools
+ doexe *.pl *.py *.conf *.sh || die
+ doexe tb2claws-mail update-po uudec uuooffice || die
+
+ # kill useless plugin files
+ rm -f "${D}"/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ UPDATE_PLUGINS=""
+ for x in ${PLUGIN_NAMES}; do
+ has_version mail-client/${PN}-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+ done
+ if [ -n "${UPDATE_PLUGINS}" ]; then
+ elog
+ elog "You have to re-emerge or update the following plugins:"
+ elog
+ for x in ${UPDATE_PLUGINS}; do
+ elog " mail-client/${PN}-$x"
+ done
+ elog
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/mail-client/claws-mail/files/claws-mail-3.7.9_notify_crash.patch b/mail-client/claws-mail/files/claws-mail-3.7.9_notify_crash.patch
new file mode 100644
index 000000000000..1046092fd68f
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-3.7.9_notify_crash.patch
@@ -0,0 +1,16 @@
+Fixes crash with libnotify, reported upstream
+
+http://bugs.gentoo.org/show_bug.cgi?id=362297
+
+
+--- src/main.c.orig 2011-04-30 20:18:09.853235001 +0200
++++ src/main.c 2011-04-30 20:18:26.993660501 +0200
+@@ -331,7 +331,7 @@
+ gtk_widget_show(hack);
+ }
+
+- xdisplay = gdk_display_get_default();
++ xdisplay = GDK_DISPLAY_XDISPLAY(gdk_display_get_default());
+ sn_display = sn_display_new(xdisplay,
+ sn_error_trap_push,
+ sn_error_trap_pop);