summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-07-20 20:09:35 +0000
committerFabian Groffen <grobian@gentoo.org>2009-07-20 20:09:35 +0000
commita280e0dc365112cfd0cbb8db4890f10ceb03d47f (patch)
treec922cdc5cfb444ecfc93f013725498d0f0298135 /mail-client
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-a280e0dc365112cfd0cbb8db4890f10ceb03d47f.tar.gz
gentoo-2-a280e0dc365112cfd0cbb8db4890f10ceb03d47f.tar.bz2
gentoo-2-a280e0dc365112cfd0cbb8db4890f10ceb03d47f.zip
Apply follow-up patch for tab-subject-questionmark patch, add new patch for new mail in mailboxes just left, rename gpgme USE-flag to gpg, require <gpgme-1.2.0 for now, since 1.2.0 doesn't really work, bug #278394
(Portage version: 2.2.00.13830-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mutt/ChangeLog11
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch86
-rw-r--r--mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch38
-rw-r--r--mail-client/mutt/metadata.xml1
-rw-r--r--mail-client/mutt/mutt-1.5.20-r2.ebuild238
5 files changed, 373 insertions, 1 deletions
diff --git a/mail-client/mutt/ChangeLog b/mail-client/mutt/ChangeLog
index 4f363d36531b..97559d9cf1f0 100644
--- a/mail-client/mutt/ChangeLog
+++ b/mail-client/mutt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/mutt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.138 2009/07/02 08:44:33 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/ChangeLog,v 1.139 2009/07/20 20:09:35 grobian Exp $
+
+*mutt-1.5.20-r2 (20 Jul 2009)
+
+ 20 Jul 2009; Fabian Groffen <grobian@gentoo.org> +mutt-1.5.20-r2.ebuild,
+ +files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch,
+ +files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch:
+ Apply follow-up patch for tab-subject-questionsmark patch, add new patch
+ for new mail in mailboxes just left, rename gpgme USE-flag to gpg, require
+ <gpgme-1.2.0 for now, since 1.2.0 doesn't really work, bug #278394
*mutt-1.5.20-r1 (02 Jul 2009)
diff --git a/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch b/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
new file mode 100644
index 000000000000..b9088e727766
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
@@ -0,0 +1,86 @@
+http://dev.mutt.org/trac/changeset/118b8fef8aae
+http://dev.mutt.org/trac/ticket/3290
+
+Suppress new mail notification from mailbox just left. Closes #3290.
+
+
+Index: buffy.c
+===================================================================
+--- buffy.c (revision 5914:25e46aad362b)
++++ buffy.c (revision 5973:118b8fef8aae)
+@@ -45,4 +45,6 @@
+ static short BuffyCount = 0; /* how many boxes with new mail */
+ static short BuffyNotify = 0; /* # of unnotified new boxes */
++
++static BUFFY* buffy_get (const char *path);
+
+ /* Find the last message in the file.
+@@ -498,4 +500,15 @@
+ }
+
++void mutt_buffy_setnotified (const char *path)
++{
++ BUFFY *buffy;
++
++ buffy = buffy_get(path);
++ if (!buffy)
++ return;
++
++ buffy->notified = 1;
++}
++
+ int mutt_buffy_notify (void)
+ {
+@@ -542,2 +555,29 @@
+ *s = '\0';
+ }
++
++/* fetch buffy object for given path, if present */
++static BUFFY* buffy_get (const char *path)
++{
++ BUFFY *cur;
++ char *epath;
++
++ if (!path)
++ return NULL;
++
++ epath = safe_strdup(path);
++ mutt_expand_path(epath, mutt_strlen(epath));
++
++ for (cur = Incoming; cur; cur = cur->next)
++ {
++ /* must be done late because e.g. IMAP delimiter may change */
++ mutt_expand_path (cur->path, sizeof (cur->path));
++ if (!mutt_strcmp(cur->path, path))
++ {
++ FREE (&epath);
++ return cur;
++ }
++ }
++
++ FREE (&epath);
++ return NULL;
++}
+Index: buffy.h
+===================================================================
+--- buffy.h (revision 5779:7bc332ddd8fc)
++++ buffy.h (revision 5973:118b8fef8aae)
+@@ -44,2 +44,5 @@
+ according to stat() info taken before a modification */
+ void mutt_buffy_cleanup (const char *buf, struct stat *st);
++
++/* mark mailbox just left as already notified */
++void mutt_buffy_setnotified (const char *path);
+Index: mx.c
+===================================================================
+--- mx.c (revision 5930:ed7eb5de7536)
++++ mx.c (revision 5973:118b8fef8aae)
+@@ -706,4 +706,8 @@
+ return;
+
++ /* never announce that a mailbox we've just left has new mail. #3290
++ * XXX: really belongs in mx_close_mailbox, but this is a nice hook point */
++ mutt_buffy_setnotified(ctx->path);
++
+ if (ctx->mx_close)
+ ctx->mx_close (ctx);
diff --git a/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch b/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
new file mode 100644
index 000000000000..9aa969d0696e
--- /dev/null
+++ b/mail-client/mutt/files/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
@@ -0,0 +1,38 @@
+http://dev.mutt.org/trac/changeset/298194c414f0
+
+Allow tabs in index subject. Closes #3270.
+
+http://dev.mutt.org/trac/changeset/cff8e8ce4327
+
+Render blanks to spaces in index, fixes [298194c414f0]
+
+wcwidth(<tab>) returns -1 so 'foo<tab>bar' was rendered to 'foobar',
+and now to 'foo bar'. Closes #3270 again.
+
+
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 5939:199b126a7623)
++++ configure.ac (revision 5958:298194c414f0)
+@@ -1216,5 +1216,5 @@
+
+ AC_CHECK_HEADERS(wctype.h)
+-AC_CHECK_FUNCS(iswalnum iswalpha iswcntrl iswdigit)
++AC_CHECK_FUNCS(iswalnum iswalpha iswblank iswcntrl iswdigit)
+ AC_CHECK_FUNCS(iswgraph iswlower iswprint iswpunct iswspace iswupper)
+ AC_CHECK_FUNCS(iswxdigit towupper towlower)
+Index: curs_lib.c
+===================================================================
+--- curs_lib.c (revision 5936:642987450d83)
++++ curs_lib.c (revision 5958:cff8e8ce4327)
+@@ -726,5 +726,10 @@
+ else
+ {
++#ifdef HAVE_ISWBLANK
++ if (iswblank (wc))
++ wc = ' ';
++ else
++#endif
+ if (!IsWPrint (wc))
+ wc = '?';
+ w = wcwidth (wc);
diff --git a/mail-client/mutt/metadata.xml b/mail-client/mutt/metadata.xml
index bfde6776a1c5..c1daef150653 100644
--- a/mail-client/mutt/metadata.xml
+++ b/mail-client/mutt/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="gpgme">Enable support for <pkg>app-crypt/gpgme</pkg></flag>
+ <flag name="gpg">Enable support for <pkg>app-crypt/gpgme</pkg></flag>
<flag name="pop">Enable support for pop</flag>
<flag name="sidebar">Use the vanilla tree + sidebar patch</flag>
<flag name="smime">Enable support for smime</flag>
diff --git a/mail-client/mutt/mutt-1.5.20-r2.ebuild b/mail-client/mutt/mutt-1.5.20-r2.ebuild
new file mode 100644
index 000000000000..4b5f40013d5a
--- /dev/null
+++ b/mail-client/mutt/mutt-1.5.20-r2.ebuild
@@ -0,0 +1,238 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mutt/mutt-1.5.20-r2.ebuild,v 1.1 2009/07/20 20:09:35 grobian Exp $
+
+inherit eutils flag-o-matic autotools
+
+PATCHSET_REV="-r2"
+
+# note: latest sidebar patches can be found here:
+# http://www.lunar-linux.org/index.php?option=com_content&task=view&id=44
+SIDEBAR_PATCH_N="patch-1.5.20.sidebar.20090619.txt"
+
+DESCRIPTION="a small but very powerful text-based mail client"
+HOMEPAGE="http://www.mutt.org"
+SRC_URI="ftp://ftp.mutt.org/mutt/devel/${P}.tar.gz
+ !vanilla? (
+ !sidebar? (
+ mirror://gentoo/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ http://dev.gentoo.org/~grobian/distfiles/${P}-gentoo-patches${PATCHSET_REV}.tar.bz2
+ )
+ )
+ sidebar? (
+ http://www.lunar-linux.org/~tchan/mutt/${SIDEBAR_PATCH_N}
+ )"
+IUSE="berkdb crypt debug gdbm gnutls gpg idn imap mbox nls nntp pop qdbm sasl
+sidebar smime smtp ssl vanilla"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+RDEPEND=">=sys-libs/ncurses-5.2
+ qdbm? ( dev-db/qdbm )
+ !qdbm? (
+ gdbm? ( sys-libs/gdbm )
+ !gdbm? ( berkdb? ( >=sys-libs/db-4 ) )
+ )
+ imap? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ pop? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ smtp? (
+ gnutls? ( >=net-libs/gnutls-1.0.17 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ )
+ idn? ( net-dns/libidn )
+ gpg? ( >=app-crypt/gpgme-0.9.0 <app-crypt/gpgme-1.2.0 )
+ smime? ( >=dev-libs/openssl-0.9.6 )
+ app-misc/mime-types"
+DEPEND="${RDEPEND}
+ net-mail/mailbase
+ !vanilla? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || ( www-client/lynx www-client/w3m www-client/elinks )
+ )"
+
+PATCHDIR="${WORKDIR}"/${P}-gentoo-patches${PATCHSET_REV}
+
+src_unpack() {
+ unpack ${A//${SIDEBAR_PATCH_N}}
+ cd "${S}"
+
+ # this patch is non-generic and only works because we use a sysconfdir
+ # different from the one used by the mailbase ebuild
+ use prefix && epatch "${FILESDIR}"/mutt-1.5.13-prefix-mailcap.patch
+
+ epatch "${FILESDIR}"/mutt-1.5.18-bdb-prefix.patch # fix bdb detection
+ epatch "${FILESDIR}"/mutt-1.5.18-interix.patch
+ epatch "${FILESDIR}"/mutt-1.5.18-solaris-ncurses-chars.patch
+ # post-release hot-fixes
+ epatch "${FILESDIR}"/mutt-1.5.20-imap-port-invalid-d6f88fbf8387.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-header-weeding-f40de578e8ed.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-display-unsigned-pgp-7f37d0a57d83.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-unmailbox-segfault-25e46aad362b.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-mbox-new-mail-bd59be56c6b0.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-mbox-unchanged-new-mail-9ae13dedb5ed.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-imap-start-fatal-fe30f394cbe6.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-tab-subject-questionmark-298194c414f0-cff8e8ce4327.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-smtp-batch-mode-0a3de4d9a009-f6c6066a5925.patch
+ epatch "${FILESDIR}"/mutt-1.5.20-leave-mailbox-no-new-mail-118b8fef8aae.patch
+
+ if use !vanilla && use !sidebar ; then
+ use nntp || rm "${PATCHDIR}"/06-nntp.patch
+ for p in "${PATCHDIR}"/*.patch ; do
+ epatch "${p}"
+ done
+ fi
+
+ if use sidebar ; then
+ use vanilla || \
+ ewarn "The sidebar patch is only applied to a vanilla mutt tree."
+ epatch "${DISTDIR}"/${SIDEBAR_PATCH_N}
+ fi
+
+ AT_M4DIR="m4" eautoreconf
+
+ # this should be done only when we're not root
+ if [[ ${UID} != 0 ]] ; then
+ sed -i \
+ -e 's/@DOTLOCK_GROUP@/'"`id -gn`"'/g' \
+ Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ declare myconf="
+ $(use_enable nls) \
+ $(use_enable gpg gpgme) \
+ $(use_enable imap) \
+ $(use_enable pop) \
+ $(use_enable smtp) \
+ $(use_enable crypt pgp) \
+ $(use_enable smime) \
+ $(use_enable debug) \
+ $(use_with idn) \
+ --with-curses \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PN}-${PVR} \
+ --with-regex \
+ --enable-nfs-fix --enable-external-dotlock \
+ $(use_with !nntp mixmaster) \
+ --with-exec-shell=${EPREFIX}/bin/sh"
+
+ case $CHOST in
+ *-darwin7)
+ # locales are broken on Panther
+ myconf="${myconf} --enable-locales-fix --without-wc-funcs"
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ *-solaris*)
+ # Solaris has no flock in the standard headers
+ myconf="${myconf} --enable-fcntl --disable-flock"
+ ;;
+ *)
+ myconf="${myconf} --disable-fcntl --enable-flock"
+ ;;
+ esac
+
+ # See Bug #22787
+ unset WANT_AUTOCONF_2_5 WANT_AUTOCONF
+
+ # mutt prioritizes gdbm over bdb, so we will too.
+ # hcache feature requires at least one database is in USE.
+ if use qdbm; then
+ myconf="${myconf} --enable-hcache \
+ --with-qdbm --without-gdbm --without-bdb"
+ elif use gdbm ; then
+ myconf="${myconf} --enable-hcache \
+ --without-qdbm --with-gdbm --without-bdb"
+ elif use berkdb; then
+ myconf="${myconf} --enable-hcache \
+ --without-gdbm --without-qdbm --with-bdb"
+ else
+ myconf="${myconf} --disable-hcache \
+ --without-qdbm --without-gdbm --without-bdb"
+ fi
+
+ # there's no need for gnutls, ssl or sasl without socket support
+ if use pop || use imap || use smtp ; then
+ if use gnutls; then
+ myconf="${myconf} --with-gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl"
+ fi
+ # not sure if this should be mutually exclusive with the other two
+ myconf="${myconf} $(use_with sasl)"
+ else
+ myconf="${myconf} --without-gnutls --without-ssl --without-sasl"
+ fi
+
+ if use mbox; then
+ myconf="${myconf} --with-mailpath=${EPREFIX}/var/spool/mail"
+ else
+ myconf="${myconf} --with-homespool=Maildir"
+ fi
+
+ if use !vanilla && use !sidebar ; then
+ # rr.compressed patch
+ myconf="${myconf} --enable-compressed"
+
+ # nntp patch applied conditionally, so avoid QA warning when doing
+ # --disable-nntp while patch not being applied, bug #262069
+ use nntp && myconf="${myconf} --enable-nntp"
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ local ED=${ED-${D}}
+ make DESTDIR="${D}" install || die "install failed"
+ find "${ED}"/usr/share/doc -type f | grep -v "html\|manual" | xargs gzip
+ if use mbox; then
+ insinto /etc/mutt
+ newins "${FILESDIR}"/Muttrc.mbox Muttrc
+ else
+ insinto /etc/mutt
+ doins "${FILESDIR}"/Muttrc
+ fi
+
+ # A newer file is provided by app-misc/mime-types. So we link it.
+ rm "${ED}"/etc/${PN}/mime.types
+ dosym /etc/mime.types /etc/${PN}/mime.types
+
+ # charset.alias is installed by libiconv
+ rm -f "${ED}"/usr/lib/charset.alias
+ rm -f "${ED}"/usr/share/locale/locale.alias
+
+ dodoc BEWARE COPYRIGHT ChangeLog NEWS OPS* PATCHES README* TODO VERSION
+}
+
+pkg_setup() {
+ if ! use gpg &&
+ has_version ${CATEGORY}/${PN} &&
+ built_with_use ${CATEGORY}/${PN} gpgme ;
+ then
+ ewarn 'The "gpgme" USE-flag has been changed into "gpg". You'
+ ewarn 'previously had "gpgme" set, and you most likely want to'
+ ewarn 'enable "gpg" instead, right now, to obtain equivalent behaviour.'
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "If you are new to mutt you may want to take a look at"
+ elog "the Gentoo QuickStart Guide to Mutt E-Mail:"
+ elog " http://www.gentoo.org/doc/en/guide-to-mutt.xml"
+ echo
+}