summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-01-19 10:25:15 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-01-19 10:25:15 +0000
commita6048e6bfe53d48a65b0523b89df6b8503106200 (patch)
tree8ad8afb3569561d1bae195edfbd3c4a2c59b6675 /mail-client
parentnew upstream release. (diff)
downloadgentoo-2-a6048e6bfe53d48a65b0523b89df6b8503106200.tar.gz
gentoo-2-a6048e6bfe53d48a65b0523b89df6b8503106200.tar.bz2
gentoo-2-a6048e6bfe53d48a65b0523b89df6b8503106200.zip
new upstream release.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog9
-rw-r--r--mail-client/sylpheed/files/digest-sylpheed-2.3.13
-rw-r--r--mail-client/sylpheed/sylpheed-2.3.1.ebuild74
3 files changed, 84 insertions, 2 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index f18d2d673dcc..9df2da8efc57 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.208 2006/12/24 14:44:03 hattya Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.209 2007/01/19 10:25:15 hattya Exp $
+
+*sylpheed-2.3.1 (19 Jan 2007)
+
+ 19 Jan 2007; Akinori Hattori <hattya@gentoo.org> +sylpheed-2.3.1.ebuild:
+ new upstream release.
*sylpheed-2.3.0 (24 Dec 2006)
diff --git a/mail-client/sylpheed/files/digest-sylpheed-2.3.1 b/mail-client/sylpheed/files/digest-sylpheed-2.3.1
new file mode 100644
index 000000000000..e61b578d3e48
--- /dev/null
+++ b/mail-client/sylpheed/files/digest-sylpheed-2.3.1
@@ -0,0 +1,3 @@
+MD5 12fb8622bc76b42a3bd6e734495ec4c3 sylpheed-2.3.1.tar.bz2 2614551
+RMD160 2ef027681b34641c32e2c962159fc990fd3c2ef3 sylpheed-2.3.1.tar.bz2 2614551
+SHA256 d08f4fe273c06d874bafd05c47e9e6433777fc9840372488bf0f5ec94e90cd7e sylpheed-2.3.1.tar.bz2 2614551
diff --git a/mail-client/sylpheed/sylpheed-2.3.1.ebuild b/mail-client/sylpheed/sylpheed-2.3.1.ebuild
new file mode 100644
index 000000000000..4c491da1661a
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-2.3.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-2.3.1.ebuild,v 1.1 2007/01/19 10:25:15 hattya Exp $
+
+WANT_AUTOMAKE=1.4
+
+inherit autotools eutils
+
+IUSE="crypt ipv6 ldap nls pda spell ssl xface"
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+
+PROVIDE="virtual/sylpheed"
+
+DEPEND=">=x11-libs/gtk+-2.4
+ nls? ( >=sys-devel/gettext-0.12.1 )
+ crypt? ( >=app-crypt/gpgme-0.4.5 )
+ ldap? ( >=net-nds/openldap-2.0.11 )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell )
+ ssl? ( dev-libs/openssl )
+ xface? ( >=media-libs/compface-1.4 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ x11-misc/shared-mime-info"
+
+src_unpack() {
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-2.*.diff
+
+ eautomake
+ elibtoolize
+
+}
+
+src_compile() {
+
+ econf \
+ `use_enable crypt gpgme` \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_enable nls` \
+ `use_enable pda jpilot` \
+ `use_enable spell gtkspell` \
+ `use_enable ssl` \
+ `use_enable xface compface` \
+ || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install
+
+ dodir /usr/share/pixmaps
+ insinto /usr/share/pixmaps
+ doins *.png
+
+ insinto /usr/share/applications
+ doins sylpheed.desktop
+
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+}