summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-02-28 04:22:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-02-28 04:22:14 +0000
commitd74aa7ef80fa41e8753a5f97567ba347e6139420 (patch)
tree0de280faf03f6c8d5c7b327637278e9869969797 /mail-filter/anomy-sanitizer
parentInitial commit with version 1.2.4.0 (diff)
downloadgentoo-2-d74aa7ef80fa41e8753a5f97567ba347e6139420.tar.gz
gentoo-2-d74aa7ef80fa41e8753a5f97567ba347e6139420.tar.bz2
gentoo-2-d74aa7ef80fa41e8753a5f97567ba347e6139420.zip
quote ROOT
(Portage version: 2.1.11.50/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'mail-filter/anomy-sanitizer')
-rw-r--r--mail-filter/anomy-sanitizer/ChangeLog9
-rw-r--r--mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild32
2 files changed, 22 insertions, 19 deletions
diff --git a/mail-filter/anomy-sanitizer/ChangeLog b/mail-filter/anomy-sanitizer/ChangeLog
index a364e962d849..2c4970c2c4a8 100644
--- a/mail-filter/anomy-sanitizer/ChangeLog
+++ b/mail-filter/anomy-sanitizer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-filter/anomy-sanitizer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/anomy-sanitizer/ChangeLog,v 1.18 2012/06/04 23:33:37 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/anomy-sanitizer/ChangeLog,v 1.19 2013/02/28 04:22:14 mr_bones_ Exp $
+
+ 28 Feb 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ anomy-sanitizer-1.76-r1.ebuild:
+ quote ROOT
04 Jun 2012; Zac Medico <zmedico@gentoo.org> anomy-sanitizer-1.76-r1.ebuild:
inherit user for enewgroup and enewuser
@@ -81,4 +85,3 @@
files/sample_e-mail-architektur.flw, files/sample_mailfiler.sh:
Anomy-sanitizer mail filter, originally posted by Thiemo Kellner
<thiemo@thiam.ch> and worked on by Alessandro Pisani <alextxm@tin.it>.
-
diff --git a/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild b/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
index 02b01f9d5360..d3013bf71b39 100644
--- a/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
+++ b/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild,v 1.5 2012/06/04 23:33:37 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/anomy-sanitizer/anomy-sanitizer-1.76-r1.ebuild,v 1.6 2013/02/28 04:22:14 mr_bones_ Exp $
EAPI=4
inherit eutils user
@@ -72,20 +72,20 @@ pkg_preinst() {
}
pkg_postinst() {
- chown -R sanitizer:sanitizer ${ROOT}/${SANI_WORKDIR}
- chmod -R a-rwx,g+X,u+rwX ${ROOT}/${SANI_WORKDIR}
- chown -R sanitizer:sanitizer ${ROOT}/${DEST}
- chmod -R a-rwx,g+rX,u+rX ${ROOT}/${DEST}
- chown sanitizer:sanitizer ${ROOT}/${SANI_CONFDIR}/anomy.conf
- chmod 0640 ${ROOT}/${SANI_CONFDIR}/anomy.conf
- chmod u+x ${ROOT}/${DEST}/bin/*.pl
- chmod u+x ${ROOT}/${DEST}/testcases/*.sh
- chmod u+w ${ROOT}/${DEST}/*
- chmod u+w ${ROOT}/${DEST}/bin
- chmod u+w ${ROOT}/${DEST}/bin/Anomy
- chmod u+w ${ROOT}/${DEST}/bin/Anomy/Sanitizer
- chmod u+w ${ROOT}/${DEST}/testcases
- chmod u+w ${ROOT}/${DEST}/testcases/results.def
+ chown -R sanitizer:sanitizer "${ROOT}"/${SANI_WORKDIR}
+ chmod -R a-rwx,g+X,u+rwX "${ROOT}"/${SANI_WORKDIR}
+ chown -R sanitizer:sanitizer "${ROOT}"/${DEST}
+ chmod -R a-rwx,g+rX,u+rX "${ROOT}"/${DEST}
+ chown sanitizer:sanitizer "${ROOT}"/${SANI_CONFDIR}/anomy.conf
+ chmod 0640 "${ROOT}"/${SANI_CONFDIR}/anomy.conf
+ chmod u+x "${ROOT}"/${DEST}/bin/*.pl
+ chmod u+x "${ROOT}"/${DEST}/testcases/*.sh
+ chmod u+w "${ROOT}"/${DEST}/*
+ chmod u+w "${ROOT}"/${DEST}/bin
+ chmod u+w "${ROOT}"/${DEST}/bin/Anomy
+ chmod u+w "${ROOT}"/${DEST}/bin/Anomy/Sanitizer
+ chmod u+w "${ROOT}"/${DEST}/testcases
+ chmod u+w "${ROOT}"/${DEST}/testcases/results.def
elog ""
elog "There is a howto for the integration of sanitizer"