summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-05-18 08:31:07 +0000
committerTorsten Veller <tove@gentoo.org>2005-05-18 08:31:07 +0000
commit7e52d358ce80e0a6a5e6e84dcdbc3228d1b4fcf0 (patch)
treeb3c0bd02d427c570460d54c6f877067f9711d52a /mail-filter
parentStable on ppc64; added ~ppc64 to KEYWORDS (diff)
downloadgentoo-2-7e52d358ce80e0a6a5e6e84dcdbc3228d1b4fcf0.tar.gz
gentoo-2-7e52d358ce80e0a6a5e6e84dcdbc3228d1b4fcf0.tar.bz2
gentoo-2-7e52d358ce80e0a6a5e6e84dcdbc3228d1b4fcf0.zip
Version bump.
(Portage version: 2.0.51.22)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog7
-rw-r--r--mail-filter/bogofilter/Manifest12
-rw-r--r--mail-filter/bogofilter/bogofilter-0.94.12.ebuild71
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-0.94.121
4 files changed, 80 insertions, 11 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index a11c1bc5609f..e3798609ee34 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.34 2005/05/11 05:43:11 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.35 2005/05/18 08:31:07 tove Exp $
+
+*bogofilter-0.94.12 (18 May 2005)
+
+ 18 May 2005; Torsten Veller <tove@gentoo.org> +bogofilter-0.94.12.ebuild:
+ New Stable release.
*bogofilter-0.94.11 (11 May 2005)
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index 53309c418837..613dc7160451 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 adfa1ea9bb27f46d16ee44070e1a3e2d bogofilter-0.94.12.ebuild 2079
MD5 adfa1ea9bb27f46d16ee44070e1a3e2d bogofilter-0.94.11.ebuild 2079
MD5 e2285a40ab55c158c5b275ff758c520c bogofilter-0.92.8.ebuild 1572
MD5 eb4ea17273979c3ebaf2479383ca9e9e ChangeLog 11680
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 da1f17c4122aef956d3ce96662b42e4f files/digest-bogofilter-0.94.11 71
+MD5 6955a93d3bd9dccc7bbb1ae68b2e8175 files/digest-bogofilter-0.94.12 71
MD5 1970df6e6d8dabe53d04a6f120d0b8bb files/digest-bogofilter-0.92.8 70
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCgZt8V3J2n04EauwRAsScAKCvxstcl0jZsDp2FMvn/7nyhyFzxgCgi9Yd
-KHiLZ2dnTpMr5QlM3Dn7Zbw=
-=A5fF
------END PGP SIGNATURE-----
diff --git a/mail-filter/bogofilter/bogofilter-0.94.12.ebuild b/mail-filter/bogofilter/bogofilter-0.94.12.ebuild
new file mode 100644
index 000000000000..5604f3b7832e
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-0.94.12.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.94.12.ebuild,v 1.1 2005/05/18 08:31:07 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="doc gsl"
+
+RDEPEND="virtual/libc
+ >=sys-libs/db-3.2
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_compile() {
+ local myconf=""
+ use !gsl && myconf="--with-included-gsl" # 'without-' doesn't work
+# myconf="$(use_with !gsl included-gsl)"
+
+ econf ${myconf} || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,bogogrep,mime.get.rfc822,parmtest.sh}
+ doexe contrib/{randomtrain,scramble,*.pl}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,bogo.R,bogogrep.c,dot-qmail-bogofilter-default}
+ doins contrib/{trainbogo.sh,*.example}
+
+ dodoc AUTHORS COPYING INSTALL NEWS README
+ dodoc RELEASE.NOTES* TODO doc/integrating-with-*
+ dodoc GETTING.STARTED doc/README.db
+
+ dodir /usr/share/doc/${PF}/samples
+ mv ${D}/etc/* ${D}/usr/share/doc/${PF}/samples/
+ rmdir ${D}/etc
+
+ if useq doc; then
+ dohtml doc/*.html
+ else
+ dohtml doc/bogofilter-faq{,-fr}.html doc/bogofilter-tuning.HOWTO.html
+ fi
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Incompatible changes in bogofilter-0.93 and -0.94:"
+ ewarn "Please read the documentation (RELEASE.NOTES, README.db)!"
+ ewarn ""
+ einfo ""
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ einfo ""
+ einfo "Contributed tools and documentation is in ${ROOT}usr/share/${PN}/contrib"
+ einfo "beside documentation in ${ROOT}usr/share/doc/${PF}."
+ einfo ""
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-0.94.12 b/mail-filter/bogofilter/files/digest-bogofilter-0.94.12
new file mode 100644
index 000000000000..d52a14d3fcf7
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-0.94.12
@@ -0,0 +1 @@
+MD5 489337defebff75d8e2b46350e946752 bogofilter-0.94.12.tar.bz2 723385