summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-09-14 17:34:29 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-09-14 17:34:29 +0000
commitcc9212e7d358f2f6a9f915aa4e9ba2083dd76380 (patch)
treefaf377acf3f76ce64b5844001e2919d35e1babf0 /mail-mta/msmtp
parentUnmasked app-editors/ted. (diff)
downloadgentoo-2-cc9212e7d358f2f6a9f915aa4e9ba2083dd76380.tar.gz
gentoo-2-cc9212e7d358f2f6a9f915aa4e9ba2083dd76380.tar.bz2
gentoo-2-cc9212e7d358f2f6a9f915aa4e9ba2083dd76380.zip
Version bump, #235313
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'mail-mta/msmtp')
-rw-r--r--mail-mta/msmtp/ChangeLog8
-rw-r--r--mail-mta/msmtp/msmtp-1.4.16.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/mail-mta/msmtp/ChangeLog b/mail-mta/msmtp/ChangeLog
index 1ba3e10cdd04..8355cfd20420 100644
--- a/mail-mta/msmtp/ChangeLog
+++ b/mail-mta/msmtp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/msmtp
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.70 2008/03/22 14:51:06 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.71 2008/09/14 17:34:29 dertobi123 Exp $
+
+*msmtp-1.4.16 (14 Sep 2008)
+
+ 14 Sep 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +msmtp-1.4.16.ebuild:
+ Version bump, #235313
*msmtp-1.4.14 (22 Mar 2008)
diff --git a/mail-mta/msmtp/msmtp-1.4.16.ebuild b/mail-mta/msmtp/msmtp-1.4.16.ebuild
new file mode 100644
index 000000000000..e211bb689d00
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.4.16.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.16.ebuild,v 1.1 2008/09/14 17:34:29 dertobi123 Exp $
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/msmtp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnutls idn mailwrapper nls sasl ssl"
+
+DEPEND="idn? ( net-dns/libidn )
+ nls? ( virtual/libintl )
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=virtual/gsasl-0.2.4 )"
+
+RDEPEND="${DEPEND}
+ !mailwrapper? ( !virtual/mta )
+ mailwrapper? ( >=net-mail/mailwrapper-0.2 )"
+
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/mta"
+
+src_compile () {
+ local myconf
+
+ if use gnutls ; then
+ myconf="--with-ssl=gnutls"
+ elif use ssl ; then
+ myconf="--with-ssl=openssl"
+ else
+ myconf="--with-ssl=no"
+ fi
+
+ econf \
+ $(use_with idn libidn) \
+ $(use_with sasl libgsasl) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use mailwrapper ; then
+ insinto /etc/mail
+ doins "${FILESDIR}"/mailer.conf
+ else
+ dodir /usr/sbin
+ dosym /usr/bin/msmtp /usr/sbin/sendmail || die "dosym failed"
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS \
+ doc/{Mutt+msmtp.txt,msmtprc*} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/msmtp.html || die "dohtml failed"
+ dodoc doc/msmtp.pdf
+ fi
+
+ local msmtpqueuedir=/usr/share/${PN}/msmtpqueue
+ insinto ${msmtpqueuedir}
+ exeinto ${msmtpqueuedir}
+ doins scripts/msmtpqueue/{ChangeLog,README} || die "dodoc scripts/msmtpqueue failed"
+ doexe scripts/msmtpqueue/*.sh || die "doexe failed"
+}