summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-06-05 13:48:56 +0000
committerEray Aslan <eras@gentoo.org>2012-06-05 13:48:56 +0000
commitb920e79631cadc786c429cabd7c5ca2e5f4744ae (patch)
treef741206788affeecf3217f9034b5a8e90527f564 /mail-mta/nullmailer
parentRemove old. (diff)
downloadgentoo-2-b920e79631cadc786c429cabd7c5ca2e5f4744ae.tar.gz
gentoo-2-b920e79631cadc786c429cabd7c5ca2e5f4744ae.tar.bz2
gentoo-2-b920e79631cadc786c429cabd7c5ca2e5f4744ae.zip
Version bump. Change --chuid to --user in init script. Bugs #415417 #405529
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta/nullmailer')
-rw-r--r--mail-mta/nullmailer/ChangeLog5
-rw-r--r--mail-mta/nullmailer/files/init.d-nullmailer-r156
-rw-r--r--mail-mta/nullmailer/nullmailer-1.10.ebuild121
3 files changed, 181 insertions, 1 deletions
diff --git a/mail-mta/nullmailer/ChangeLog b/mail-mta/nullmailer/ChangeLog
index 1584b5fd66a5..4bf07943f330 100644
--- a/mail-mta/nullmailer/ChangeLog
+++ b/mail-mta/nullmailer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-mta/nullmailer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.46 2012/06/04 21:06:18 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/ChangeLog,v 1.47 2012/06/05 13:48:56 eras Exp $
+
+ 05 Jun 2012; Eray Aslan <eras@gentoo.org> +files/init.d-nullmailer-r1:
+ Version bump. Change --chuid to --user in init script. Bugs #415417 #405529
04 Jun 2012; Zac Medico <zmedico@gentoo.org> nullmailer-1.05.ebuild,
nullmailer-1.06.ebuild:
diff --git a/mail-mta/nullmailer/files/init.d-nullmailer-r1 b/mail-mta/nullmailer/files/init.d-nullmailer-r1
new file mode 100644
index 000000000000..5b5f58e110b9
--- /dev/null
+++ b/mail-mta/nullmailer/files/init.d-nullmailer-r1
@@ -0,0 +1,56 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/files/init.d-nullmailer-r1,v 1.1 2012/06/05 13:48:55 eras Exp $
+
+DAEMON="/usr/sbin/nullmailer-send"
+ARGS="--daemon"
+USER=nullmail
+GROUP=nullmail
+
+depend() {
+ need net logger
+}
+
+checkconfig() {
+ local error=0
+ local f=/etc/nullmailer/me
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ f=/etc/nullmailer/defaultdomain
+ if [ ! -s ${f} ]; then
+ eerror "${f} does not exist"
+ error=1
+ fi
+ if [ ${error} -eq 1 ]; then
+ einfo "You need to run 'emerge --config nullmailer'!"
+ fi
+ if [ -e /service/nullmailer ]; then
+ eerror "Nullmailer is already running under svscan!"
+ error=2
+ fi
+ if [ ${error} -ne 0 ]; then
+ return 1
+ else
+ return 0
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Starting nullmailer"
+ cd /var/nullmailer
+ start-stop-daemon --start --quiet --user ${USER}:${GROUP} \
+ --exec ${DAEMON} -- ${ARGS}
+ eend $?
+}
+
+stop() {
+ checkconfig # to avoid init.d stopping svscan instance
+ ebegin "Stopping nullmailer"
+ cd /var/nullmailer
+ start-stop-daemon --stop --user ${USER} --exec ${DAEMON}
+ eend $?
+}
diff --git a/mail-mta/nullmailer/nullmailer-1.10.ebuild b/mail-mta/nullmailer/nullmailer-1.10.ebuild
new file mode 100644
index 000000000000..cb7484330664
--- /dev/null
+++ b/mail-mta/nullmailer/nullmailer-1.10.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nullmailer/nullmailer-1.10.ebuild,v 1.1 2012/06/05 13:48:56 eras Exp $
+
+EAPI=4
+inherit eutils flag-o-matic autotools user multilib
+
+MY_P="${P/_rc/RC}"
+S=${WORKDIR}/${MY_P}
+DEBIAN_PV=1.10
+DEBIAN_PR="1"
+DEBIAN_P="${PN}-${DEBIAN_PV}"
+DEBIAN_PF="${DEBIAN_P/-/_}-${DEBIAN_PR}"
+DEBIAN_SRC="${DEBIAN_PF}.debian.tar.gz"
+DESCRIPTION="Simple relay-only local mail transport agent"
+SRC_URI="http://untroubled.org/${PN}/archive/${MY_P}.tar.gz
+ mirror://debian/pool/main/n/${PN}/${DEBIAN_SRC}"
+HOMEPAGE="http://untroubled.org/nullmailer/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ssl"
+
+DEPEND="sys-apps/groff
+ ssl? ( net-libs/gnutls )"
+RDEPEND="virtual/shadow
+ virtual/logger
+ ssl? ( net-libs/gnutls )
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp
+ !mail-mta/nbsmtp
+ !mail-mta/netqmail
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp"
+
+src_prepare() {
+ EPATCH_OPTS="-d ${S} -p1" \
+ epatch "${DISTDIR}"/${DEBIAN_SRC}
+ # why revert? Ask Robin when he is back!
+ EPATCH_OPTS="-d ${WORKDIR} -p0 -R" \
+ epatch "${WORKDIR}"/debian/patches/02_ipv6.diff
+ # this fixes the debian daemon/syslog to actually compile
+ sed -i.orig \
+ -e '/^nullmailer_send_LDADD/s, =, = ../lib/cli++/libcli++.a,' \
+ "${S}"/src/Makefile.am || die "Sed failed"
+
+ eautoreconf
+}
+
+pkg_setup() {
+ enewgroup nullmail 88
+ enewuser nullmail 88 -1 /var/nullmailer nullmail
+}
+
+src_configure() {
+ # Note that we pass a different directory below due to bugs in the makefile!
+ econf \
+ --localstatedir=/var \
+ $(use_enable ssl tls)
+}
+
+src_install () {
+ einstall localstatedir="${D}"/var/nullmailer
+ dodoc AUTHORS BUGS HOWTO INSTALL ChangeLog NEWS README TODO
+ # A small bit of sample config
+ insinto /etc/nullmailer
+ newins "${FILESDIR}"/remotes.sample-1.04 remotes
+ # daemontools stuff
+ dodir /var/nullmailer/service{,/log}
+ insinto /var/nullmailer/service
+ newins scripts/nullmailer.run run
+ fperms 700 /var/nullmailer/service/run
+ insinto /var/nullmailer/service/log
+ newins scripts/nullmailer-log.run run
+ fperms 700 /var/nullmailer/service/log/run
+ # usablity
+ dodir /usr/$(get_libdir)
+ dosym /usr/sbin/sendmail usr/$(get_libdir)/sendmail
+ # permissions stuff
+ keepdir /var/log/nullmailer /var/nullmailer/{tmp,queue}
+ fperms 770 /var/log/nullmailer /var/nullmailer/{tmp,queue}
+ fowners nullmail:nullmail /usr/sbin/nullmailer-queue /usr/bin/mailq
+ fperms 4711 /usr/sbin/nullmailer-queue /usr/bin/mailq
+ fowners nullmail:nullmail /var/log/nullmailer /var/nullmailer/{tmp,queue,trigger}
+ fperms 660 /var/nullmailer/trigger
+ newinitd "${FILESDIR}"/init.d-nullmailer-r1 nullmailer
+}
+
+pkg_postinst() {
+ [ ! -e "${ROOT}"/var/nullmailer/trigger ] && mkfifo "${ROOT}"/var/nullmailer/trigger
+ chown nullmail:nullmail "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue,trigger}
+ chmod 770 "${ROOT}"/var/log/nullmailer "${ROOT}"/var/nullmailer/{tmp,queue}
+ chmod 660 "${ROOT}"/var/nullmailer/trigger
+
+ elog "To create an initial setup, please do:"
+ elog "emerge --config =${CATEGORY}/${PF}"
+ echo
+ elog "To start nullmailer at boot you may use either the nullmailer init.d"
+ elog "script, or emerge sys-process/supervise-scripts, enable the"
+ elog "svscan init.d script and create the following link:"
+ elog "ln -fs /var/nullmailer/service /service/nullmailer"
+ echo
+}
+
+pkg_config() {
+ if [ ! -s "${ROOT}"/etc/nullmailer/me ]; then
+ einfo "Setting /etc/nullmailer/me"
+ /bin/hostname --fqdn > "${ROOT}"/etc/nullmailer/me
+ fi
+ if [ ! -s "${ROOT}"/etc/nullmailer/defaultdomain ]; then
+ einfo "Setting /etc/nullmailer/defaultdomain"
+ /bin/hostname --domain > "${ROOT}"/etc/nullmailer/defaultdomain
+ fi
+}