summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-25 23:28:42 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-25 23:28:42 +0000
commitc83a052aef1656231a7d9295c2b2c085bc55b518 (patch)
tree8a1a212fe7c2cb511d5a64ded62f229ba1dc42e3 /mail-mta/ssmtp/files
parentOld. (diff)
downloadgentoo-2-c83a052aef1656231a7d9295c2b2c085bc55b518.tar.gz
gentoo-2-c83a052aef1656231a7d9295c2b2c085bc55b518.tar.bz2
gentoo-2-c83a052aef1656231a7d9295c2b2c085bc55b518.zip
Revbump, add patches for Darwin/Solaris, bump to EAPI-3, add prefix support & keywords, die on failure, cleanup
(Portage version: v2.2_rc67-80-ge064530/cvs/Linux i686)
Diffstat (limited to 'mail-mta/ssmtp/files')
-rw-r--r--mail-mta/ssmtp/files/ssmtp-2.61-darwin7.patch10
-rw-r--r--mail-mta/ssmtp/files/ssmtp-2.62-darwin-crypto.patch18
-rw-r--r--mail-mta/ssmtp/files/ssmtp-2.62-solaris-basename-conflict.patch38
3 files changed, 66 insertions, 0 deletions
diff --git a/mail-mta/ssmtp/files/ssmtp-2.61-darwin7.patch b/mail-mta/ssmtp/files/ssmtp-2.61-darwin7.patch
new file mode 100644
index 000000000000..8f6aaec76c4b
--- /dev/null
+++ b/mail-mta/ssmtp/files/ssmtp-2.61-darwin7.patch
@@ -0,0 +1,10 @@
+--- ssmtp-2.61/ssmtp.c
++++ ssmtp-2.61/ssmtp.c
+@@ -14,6 +14,7 @@
+ */
+ #define VERSION "2.60.4"
+
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <sys/param.h>
diff --git a/mail-mta/ssmtp/files/ssmtp-2.62-darwin-crypto.patch b/mail-mta/ssmtp/files/ssmtp-2.62-darwin-crypto.patch
new file mode 100644
index 000000000000..202efda9c9b1
--- /dev/null
+++ b/mail-mta/ssmtp/files/ssmtp-2.62-darwin-crypto.patch
@@ -0,0 +1,18 @@
+Fix linking error:
+
+Undefined symbols:
+ "_X509_free", referenced from:
+ _smtp_open in ssmtp.o
+ld: symbol(s) not found
+
+
+--- configure.in
++++ configure.in
+@@ -53,6 +53,7 @@
+ if test x$enableval = xyes ; then
+ AC_DEFINE(HAVE_SSL)
+ LIBS="$LIBS -lssl"
++ AC_SEARCH_LIBS([X509_free], [crypto])
+ fi
+ enableval=""
+
diff --git a/mail-mta/ssmtp/files/ssmtp-2.62-solaris-basename-conflict.patch b/mail-mta/ssmtp/files/ssmtp-2.62-solaris-basename-conflict.patch
new file mode 100644
index 000000000000..362ba5948fa8
--- /dev/null
+++ b/mail-mta/ssmtp/files/ssmtp-2.62-solaris-basename-conflict.patch
@@ -0,0 +1,38 @@
+This function overshadows the one from libc on Solaris, and guess what,
+is hence never called. Since the original one has an entirely different
+contract, it results in unconditional segfaults lateron, so always use
+the internal copy as it's small enough not to care.
+
+--- ssmtp.c
++++ ssmtp.c
+@@ -223,11 +223,10 @@
+ exit(1);
+ }
+
+-#ifndef _GNU_SOURCE
+ /*
+-basename() -- Return last element of path
++xbasename() -- Return last element of path
+ */
+-char *basename(char *str)
++char *xbasename(char *str)
+ {
+ char *p;
+
+@@ -238,7 +237,6 @@
+
+ return(strdup(p));
+ }
+-#endif /* _GNU_SOURCE */
+
+ /*
+ strip_pre_ws() -- Return pointer to first non-whitespace character
+@@ -2058,7 +2056,7 @@
+ (void)signal(SIGTTOU, SIG_IGN);
+
+ /* Set the globals */
+- prog = basename(argv[0]);
++ prog = xbasename(argv[0]);
+
+ hostname = xgethostname();
+